<!DOCTYPE html><html lang="en"><head><link rel="apple-touch-icon" sizes="57x57" href="/img/favicons/apple-icon-57x57.png"/><link rel="apple-touch-icon" sizes="60x60" href="/img/favicons/apple-icon-60x60.png"/><link rel="apple-touch-icon" sizes="72x72" href="/img/favicons/apple-icon-72x72.png"/><link rel="apple-touch-icon" sizes="76x76" href="/img/favicons/apple-icon-76x76.png"/><link rel="apple-touch-icon" sizes="114x114" href="/img/favicons/apple-icon-114x114.png"/><link rel="apple-touch-icon" sizes="120x120" href="/img/favicons/apple-icon-120x120.png"/><link rel="apple-touch-icon" sizes="144x144" href="/img/favicons/apple-icon-144x144.png"/><link rel="apple-touch-icon" sizes="152x152" href="/img/favicons/apple-icon-152x152.png"/><link rel="apple-touch-icon" sizes="180x180" href="/img/favicons/apple-icon-180x180.png"/><link rel="icon" type="image/png" sizes="192x192" href="/img/favicons/android-icon-192x192.png"/><link rel="icon" type="image/png" sizes="32x32" href="/img/favicons/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="96x96" href="/img/favicons/favicon-96x96.png"/><link rel="icon" type="image/png" sizes="16x16" href="/img/favicons/favicon-16x16.png"/><link rel="manifest" crossorigin="use-credentials" href="/manifest.json"/><meta name="msapplication-TileImage" content="/img/favicons/ms-icon-144x144.png"/><link rel="preconnect" href="https://vidtech.cbsinteractive.com"/><link rel="preconnect" href="https://cdn.cookielaw.org"/><link rel="preconnect" href="https://www.insideedition.com"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/><meta http-equiv="content-language" content="en_US"/><meta property="fb:app_id" content="966341826790079"/><meta property="fb:admins" content="3111204"/><meta property="fb:pages" content="71728150722"/><meta property="og:site_name" content="Inside Edition"/><meta name="twitter:site" content="@insideedition"/><meta name="twitter:site:id" content="23603092"/><meta name="theme-color" content="#fd005b"/><meta name="msapplication-TileColor" content="#fd005b"/><script>var utag_data = window.utag_data || {}; window.utag_data.isSPA = true;</script><script src="https://tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js" async=""></script><script>
                !function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var
                  d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();
              </script><script>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];cbsoptanon.onAdsReady(function(cmp, options) {console.log('Ads loaded, npa flag: ', options['npaFlag']);});
              </script><script src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js" async=""></script><script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charSet="UTF-8" data-domain-script="1e90d9ec-e15e-4932-a026-f218893ce26c" async=""></script><script async="" src="https://www.googletagmanager.com/gtag/js?id=AW-604815933"></script><script>
                window.cbsoptanon.cmd.push(function (cmp) {
                  cmp.ot.awaitInitialConsent(function () {
                    window.dataLayer = window.dataLayer || [];
                    function gtag() {
                      dataLayer.push(arguments);
                    }
                    gtag("js", new Date());
                    gtag("config", "AW-604815933");
                  });
                });
              </script><script>
                !function(f,b,e,v,n,t,s){
                  if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};
                  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];
                  t=b.createElement(e);
                  t.async=!0;
                  t.src=v;
                  t.setAttribute("class", "optanon-category-3");
                  t.setAttribute("data-src", v);
                  t.setAttribute("type", "text/plain");
                  s=b.getElementsByTagName(e)[0];
                  s.parentNode.insertBefore(t,s)}
                  (window,document,'script','https://connect.facebook.net/en_US/fbevents.js'); 
                  fbq('init', '1223619061322807'); fbq('track', 'PageView');
              </script><noscript><img alt="" height="1" width="1" src="https://www.facebook.com/tr?id=1223619061322807&amp;ev=PageView&amp;noscript=1"/></noscript><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><title>Man Causes Stir After His Homemade ‘Hydro Pod’ Washes Up on Florida Beach on Its Way Up the East Coast | Inside Edition</title><meta name="title" content="Man Causes Stir After His Homemade ‘Hydro Pod’ Washes Up on Florida Beach on Its Way Up the East Coast"/><link rel="canonical" href="https://www.insideedition.com/man-causes-stir-after-his-homemade-hydro-pod-washes-up-on-florida-beach-on-its-way-up-the-east"/><link rel="image_src" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d&amp;width=1280&amp;height=720"/><meta name="robots" content="index"/><meta name="description" content="Ray “Reza” Baluchi was discovered in the middle of a journey up the east coast. "/><meta property="og:description" content="Ray “Reza” Baluchi was discovered in the middle of a journey up the east coast. "/><meta property="og:title" content="Man Causes Stir When Homemade ‘Hydro Pod’ Washes Up on Beach"/><meta property="og:type" content="Article"/><meta property="og:url" content="https://www.insideedition.com/man-causes-stir-after-his-homemade-hydro-pod-washes-up-on-florida-beach-on-its-way-up-the-east"/><meta property="og:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d&amp;width=1280&amp;height=720"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta property="og:video:secure_url" content="https://cbsi-insideedition-video-fastly.global.ssl.fastly.net/2021/08/03/1929398339850/080321_beach_bubble_web-e0f4008e_765614_5192.mp4"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="Ray “Reza” Baluchi was discovered in the middle of a journey up the east coast. "/><meta name="twitter:title" content="Man Causes Stir When Homemade ‘Hydro Pod’ Washes Up on Beach"/><meta name="twitter:url" content="https://www.insideedition.com/man-causes-stir-after-his-homemade-hydro-pod-washes-up-on-florida-beach-on-its-way-up-the-east"/><meta name="twitter:creator" content="@insideedition"/><meta name="twitter:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d&amp;width=1280&amp;height=720"/><meta name="twitter:image:width" content="1280"/><meta name="twitter:image:height" content="720"/><meta property="article:published_time" content="2021-08-04T09:14:31-0700"/><meta name="keywords" content="Inside Edition, Offbeat, News, florida, new York"/><link rel="amphtml" href="https://www.insideedition.com/man-causes-stir-after-his-homemade-hydro-pod-washes-up-on-florida-beach-on-its-way-up-the-east?amp"/><script type="application/ld+json">{"@context":"http://schema.org","articleSection":"News","dateModified":"2021-08-04T09:14:31-0700","headline":"Man Causes Stir After His Homemade ‘Hydro Pod’ Washes Up on Florida Beach on Its Way Up the East Coast","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.insideedition.comman-causes-stir-after-his-homemade-hydro-pod-washes-up-on-florida-beach-on-its-way-up-the-east"},"datePublished":"2021-08-04T09:14:31-0700","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}},"url":"https://www.insideedition.comman-causes-stir-after-his-homemade-hydro-pod-washes-up-on-florida-beach-on-its-way-up-the-east","description":"Ray “Reza” Baluchi was discovered in the middle of a journey up the east coast. ","keywords":["Inside Edition, Offbeat, News, florida, new York"],"image":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d","height":1080,"width":1920},"author":{"@type":"Person","name":"IE Staff"},"video":{"@context":"https://schema.org","@type":"VideoObject","name":"Man Causes Stir When His Homemade ‘Hydro Pod’ Washes Up on Florida Beach","description":"Ray “Reza” Baluchi was discovered in the middle of a journey up the east coast. ","thumbnailUrl":"/sites/default/files/images/2021-08/080321_beach_bubble_web2.jpg","thumbnail":{"@context":"https://schema.org","@type":"ImageObject","height":"360","width":"640","url":"/sites/default/files/images/2021-08/080321_beach_bubble_web2.jpg"},"uploadDate":"2021-08-03T13:52:21-07:00","duration":"PT107S","embedUrl":"https://cbsi-insideedition-video-fastly.global.ssl.fastly.net/2021/08/03/1929398339850/765613_hls/master.m3u8","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}}}}</script><link rel="preload" as="image" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d&amp;width=1280&amp;height=720" imagesrcset="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d&amp;width=375&amp;height=211 375w, https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-08/080321_beach_bubble_web2.jpg?h=d1cb525d&amp;width=1170&amp;height=658 1170w" imagesizes="(max-width: 375px) 375px, 1170px"/><meta name="next-head-count" content="29"/><link rel="preload" href="/_next/static/css/cccf23090934e9f393a7.css" as="style"/><link rel="stylesheet" href="/_next/static/css/cccf23090934e9f393a7.css" data-n-g=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-f4a1f2beb5f7f31e58c2.js"></script><script defer="" src="/_next/static/chunks/05d954cf.478b728c71b065ee791f.js"></script><script defer="" src="/_next/static/chunks/c8f7fe3b0e41be846d5687592cf2018ff6e22687.924f3cf6681c565dbf29.js"></script><script defer="" src="/_next/static/chunks/29.2ff34dba5c5982d997a7.js"></script><script defer="" src="/_next/static/chunks/29107295.46bdb1fdbaaa5375f613.js"></script><script defer="" src="/_next/static/chunks/37.6b35136ca9c620b8f7e8.js"></script><script defer="" src="/_next/static/chunks/34.637ff1eb4b17da15638f.js"></script><script defer="" src="/_next/static/chunks/46.4d3326ec6f07c866c810.js"></script><script defer="" src="/_next/static/chunks/10.df0e0e2c3d30626636e1.js"></script><script src="/_next/static/chunks/webpack-dacf61425df953c39786.js" defer=""></script><script src="/_next/static/chunks/framework.349d8128c43083da4feb.js" defer=""></script><script src="/_next/static/chunks/8ee68e2f7a377ff7d6252d8a286d32cd381bdb6b.68b683f2c546ffb2b0d8.js" defer=""></script><script src="/_next/static/chunks/935c8fc39c1900be54ae90ebe42c4d44b484d9e9.b9a7689575ae676c0483.js" defer=""></script><script src="/_next/static/chunks/main-70db3d274ef2cc679ea5.js" defer=""></script><script src="/_next/static/chunks/8319099ad425c8acdf977f17bb41cc0ad9fc874a.22de1298b7b19670dcbb.js" defer=""></script><script src="/_next/static/chunks/fd4d69a6baf501ca903f2f3b32fa85dda3cdc35e.1ab173a867b7636e367e.js" defer=""></script><script src="/_next/static/chunks/pages/_app-8fbcb806f25c5e084b9f.js" defer=""></script><script src="/_next/static/chunks/cc7a0964956b8b2541223f9213d292a28b44f495.e32f56cc1a72ead803f7.js" defer=""></script><script src="/_next/static/chunks/9fb5278feeac55446b3a011644941715c803d961.1d5d7fa51fe1453f5c8b.js" defer=""></script><script src="/_next/static/chunks/pages/%5B...alias%5D-83f7909c979b709f79ca.js" defer=""></script><script src="/_next/static/insideedition/_buildManifest.js" defer=""></script><script src="/_next/static/insideedition/_ssgManifest.js" defer=""></script></head><body class="skybox-auto-collapse"><div id="__next"><div id="preload"><div><div class="dark"><div class="main-menu__sticky" style="top:0"><div class="header__wrapper"><div id="sticky-banner" class=""><div data-ad-ref="omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div><div data-ad-ref="mobile-omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div></div><div data-ad-ref="intromercial"></div><header class="header affix-top dark" style="top:0px" id="header"><div class="header__container"><div class="header__column-1"><div class="header__logo_toggle_wrapper"><button type="button" class="header__menu-toggle header__menu-toggle--collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"><span class="sr-only">Toggle navigation</span></button><a class="header__logo" href="/"><img height="46" width="68" class="header__logo__image" alt="Inside Edition Logo" src="/img/logo.svg"/></a></div><div class="header__nav" style="display:none;transform:translateY(-100%) translateZ(0)"><ul class="main-menu"><li class="main-menu__item main-menu__item--submenu-closed"><a href="/news" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">News</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/news">Latest News</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/crime">Crime</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/politics">Politics</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/health">Health</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/entertainment">Entertainment</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/royals">Royals</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/human-interest">Human Interest</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/inspirational">Inspirational</a></li></ul></li><li class="main-menu__item"><a href="/videos" class="main-menu__link" aria-label="Video">Video</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/investigative" class="main-menu__link" aria-label="Investigative">Investigative</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/category/the-issue" class="main-menu__link" aria-label="The Issue">The Issue</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/offbeat" class="main-menu__link" aria-label="Offbeat">Offbeat</a></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/more" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">More</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/animals">Animal Edition</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/photos">Photos</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/heroes">Heroes</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/in-depth">Inside Edition InDepth</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/sports">Sports</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/flashback">Flashback</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/shopping">Shopping</a></li></ul></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/showfinder" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">Watch on TV</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/showfinder">Local Listings</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/meet-the-team">Meet the Team</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/today-inside-edition">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="header__column-2"><div class="header__search header__search--closed"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group"><label for="edit-keywords"><span class="sr-only">Search</span></label><input type="search" id="edit-keywords" class="header__search-form__input-keywords" value="" title="Enter the terms you wish to search for." placeholder="Search" name="keywords" size="15" maxLength="128"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><input type="hidden" data-drupal-selector="edit-search-block-form" name="form_id" value="search_block_form"/><div data-drupal-selector="edit-actions" class="header__search-form__actions" id="edit-actions"><button type="submit" class="header__search-form__actions__submit" name="op" value="" aria-hidden="true"></button></div></form></div><button type="button" class="header__search__close-button" aria-label="Close Search"></button><div class="header__social"><ul class="header__social-menu"><li class="header__social-menu__item"><a href="http://www.facebook.com/Inside.Edition" class="header__social-menu__link header__social-menu__link--facebook"><span class="sr-only">Facebook Inside Edition</span></a></li><li class="header__social-menu__item"><a href="http://twitter.com/insideedition" class="header__social-menu__link header__social-menu__link--twitter"><span class="sr-only">Twitter Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://instagram.com/insideedition/" class="header__social-menu__link header__social-menu__link--instagram"><span class="sr-only">Instagram Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://www.youtube.com/insideedition" class="header__social-menu__link header__social-menu__link--youtube"><span class="sr-only">YouTube Inside Edition</span></a></li></ul></div></div></div></header></div></div><div class="wrap-site"><main><div class="wrap-site"><div class="content"><div class="top-container"><h1 class="content__title">Man Causes Stir After His Homemade ‘Hydro Pod’ Washes Up on Florida Beach on Its Way Up the East Coast</h1><div class="cat-social-container"><div class="content__category"><a href="https://www.insideedition.com/offbeat">Offbeat</a></div><div class="content__share"><div class="share"><button type="button" class="share__social-btn" aria-label="Share to Facebook"><div></div></button><button type="button" class="share__social-btn" aria-label="Share to Twitter"><div></div></button></div></div></div></div><div class="content__header-video"><div class="content__header-video-wrap"><div class="sticky "><button type="button" class="stuck-close"><div></div></button><div></div></div></div></div><div class="carousel-main"><script async="" src="https://i-amlg-prod.appspot.com/display?id=5d00772f-4308-406f-a9e5-ae50341b6975"></script><div class="carousel__mask"></div><div class="carousel-rec__wrapper"><div class="carousel-rec"><div class="carousel__container"><button type="button" aria-label="Man Causes Stir When His Homemade ‘Hydro Pod’ Washes Up on Florida Beach"><h3 class="card__title line-clamp"> <!-- -->Man Causes Stir When His Homemade ‘Hydro Pod’ Washes Up on Florida Beach<!-- --> </h3></button><button type="button" aria-label="Pregnant Woman Suffers 3rd Degree Leg Burns From Fireworks "><h3 class="card__title line-clamp"> <!-- -->Pregnant Woman Suffers 3rd Degree Leg Burns From Fireworks <!-- --> </h3></button><button type="button" aria-label="ESPN Reporter Rachel Nichols Apologizes for Controversial Comments Made Public"><h3 class="card__title line-clamp"> <!-- -->ESPN Reporter Rachel Nichols Apologizes for Controversial Comments Made Public<!-- --> </h3></button><button type="button" aria-label="Florida Woman Searches for Family of Lost Purple Heart Medal Recipient"><h3 class="card__title line-clamp"> <!-- -->Florida Woman Searches for Family of Lost Purple Heart Medal Recipient<!-- --> </h3></button><button type="button" aria-label="Non-Profit Created ‘Marine Vacuum’ to Collect Plastic Waste From Ocean"><h3 class="card__title line-clamp"> <!-- -->Non-Profit Created ‘Marine Vacuum’ to Collect Plastic Waste From Ocean<!-- --> </h3></button><button type="button" aria-label="Husband Screams Through Intercom to Alert Wife About Oregon Fire"><h3 class="card__title line-clamp"> <!-- -->Husband Screams Through Intercom to Alert Wife About Oregon Fire<!-- --> </h3></button><button type="button" aria-label="10-Year-Old Girl ‘Plays Dead’ After Gunman Kills Parents and Sister: Cops"><h3 class="card__title line-clamp"> <!-- -->10-Year-Old Girl ‘Plays Dead’ After Gunman Kills Parents and Sister: Cops<!-- --> </h3></button><button type="button" aria-label="Why This New Jersey Man’s Being Taunted by His Own Neighbors"><h3 class="card__title line-clamp"> <!-- -->Why This New Jersey Man’s Being Taunted by His Own Neighbors<!-- --> </h3></button><button type="button" aria-label="Sleeping Baby Narrowly Misses Being Hit by Tree That Fell Onto a Louisiana Home"><h3 class="card__title line-clamp"> <!-- -->Sleeping Baby Narrowly Misses Being Hit by Tree That Fell Onto a Louisiana Home<!-- --> </h3></button><button type="button" aria-label="Georgia Golf Pro Shot to Death for Allegedly ‘Witnessing an Active Crime’: Cops"><h3 class="card__title line-clamp"> <!-- -->Georgia Golf Pro Shot to Death for Allegedly ‘Witnessing an Active Crime’: Cops<!-- --> </h3></button><button type="button" aria-label="1st Person to Get Vaccine Celebrates Essential Workers at Ticker Tape Parade"><h3 class="card__title line-clamp"> <!-- -->1st Person to Get Vaccine Celebrates Essential Workers at Ticker Tape Parade<!-- --> </h3></button><button type="button" aria-label="Dutch Designer in Denmark Beats Guinness World Record for Tallest Sand Castle"><h3 class="card__title line-clamp"> <!-- -->Dutch Designer in Denmark Beats Guinness World Record for Tallest Sand Castle<!-- --> </h3></button><button type="button" aria-label="Man in Boxers Climbs Across California Roofs After Allegedly Setting Fire to Church"><h3 class="card__title line-clamp"> <!-- -->Man in Boxers Climbs Across California Roofs After Allegedly Setting Fire to Church<!-- --> </h3></button><button type="button" aria-label="Amanda Knox Says Shock of Miscarriage is Similar to Being Wrongfully Convicted "><h3 class="card__title line-clamp"> <!-- -->Amanda Knox Says Shock of Miscarriage is Similar to Being Wrongfully Convicted <!-- --> </h3></button><button type="button" aria-label="Phoenix Police Break Car’s Window to Rescue Trapped 2-Year-Old"><h3 class="card__title line-clamp"> <!-- -->Phoenix Police Break Car’s Window to Rescue Trapped 2-Year-Old<!-- --> </h3></button><button type="button" aria-label="Did ‘Scary’ Australian Ad for Covid Vaccine Go Too Far?"><h3 class="card__title line-clamp"> <!-- -->Did ‘Scary’ Australian Ad for Covid Vaccine Go Too Far?<!-- --> </h3></button><button type="button" aria-label="What Are ‘Micro-Weddings’ and Why Are They So Popular?"><h3 class="card__title line-clamp"> <!-- -->What Are ‘Micro-Weddings’ and Why Are They So Popular?<!-- --> </h3></button><button type="button" aria-label="Theresa Balboa Charged With Capital Murder in Death of 5-Year-Old Samuel Olson"><h3 class="card__title line-clamp"> <!-- -->Theresa Balboa Charged With Capital Murder in Death of 5-Year-Old Samuel Olson<!-- --> </h3></button><button type="button" aria-label="Mom Upset After Daughter’s Dirty Diaper Disposal Drama on Mesa Airlines"><h3 class="card__title line-clamp"> <!-- -->Mom Upset After Daughter’s Dirty Diaper Disposal Drama on Mesa Airlines<!-- --> </h3></button><button type="button" aria-label="House Cleaning Business Accidentally Cleans Wrong Family’s Home in New Jersey"><h3 class="card__title line-clamp"> <!-- -->House Cleaning Business Accidentally Cleans Wrong Family’s Home in New Jersey<!-- --> </h3></button></div></div><button class="carousel__arrow carousel__arrow--prev" type="button" aria-label="Previous Slide"><div></div></button><button class="carousel__arrow carousel__arrow--next" type="button" aria-label="Next Slide"><div></div></button></div><div class="carousel__mask"></div></div><div class="site-bg"><div class="constrain constrain--bg"><div class="content__body"><div class="content__topborder"></div><div class="content__byline"><div class="content__byline-author">By <!-- -->IE Staff</div><div class="content__byline-date"><div>First Published: <!-- -->9:14 AM PDT, August 4, 2021</div></div></div><h2 class="content__subheading">Ray “Reza” Baluchi was discovered in the middle of a journey up the east coast. </h2><div class="content__body-main"><div class="ctd-body"><div data-ad-ref="mobile-incontent-social" class="mobile-incontent-social bidbarrel-ad"></div><p>When a mysterious contraption&nbsp;washed up on the beach in <a href="https://www.insideedition.com/tag/florida" target="_blank">Florida</a>, authorities were stumped. But the floating hamster-wheel look-alike&nbsp;was actually occupied by Ray&nbsp;&ldquo;Reza&rdquo; Baluchi.</p><p>And Reza&nbsp;was actually on a journey. He set out in his homemade hydropod and planned to walk on water up the east coast all the way to <a href="https://www.insideedition.com/tag/new-york" target="_blank">New York</a>.&nbsp;</p><div data-ad-ref="mobile-flex-plus-middle" class="bidbarrel-ad"></div><p>But he hit a snag when his team alerted him that his tracking device wasn&rsquo;t working.&nbsp;So he came ashore to get another one and that&rsquo;s when the commotion started.&nbsp;</p><p>&ldquo;I coming out and they call police, so I worry that some people come and say, they give me a hard time,&rdquo; Reza explains. &ldquo;Police coming, Coast Guard coming&hellip;&rdquo;</p><div data-ad-ref="mpu-flex-middle" class="bidbarrel-ad"></div><p>Now, he&rsquo;s since decided to change his plans. Instead of walking to New York, he&rsquo;s going to set off from Bermuda and go all the way to London and then on to Portugal.&nbsp;And although It&rsquo;s going to be a long lonely journey, Baluchi is looking forward to it.</p><p>&ldquo;I&rsquo;m not scared,&rdquo; he states.&nbsp;&ldquo;I want to show people your mind is stronger and you can do it. I want to show these people who sit on the couch that decide for me what I must do.</p><div data-ad-ref="mpu-flex-inc" data-incremental="1" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="1" class="bidbarrel-ad"></div><p>&ldquo;It&rsquo;s not their business. It&rsquo;s my life, it&rsquo;s my dream. Some people like it, some people don&rsquo;t like it. I don&rsquo;t care.&rdquo;</p><p>Baluchi says he&rsquo;s raising money for organizations that support the homeless and he hopes people will follow along with him on his <a href="https://www.runwithreza.org/" target="_blank">website.&nbsp;</a></p><h2>Related Stories</h2><div class="shortcode-speedbump"><a href="https://www.insideedition.com/florida-man-injured-by-jaguar-after-sticking-his-hand-in-its-cage-at-the-jacksonville-zoo-68748" target="_self" rel="noopener noreferrer">Florida Man Injured by Jaguar After Sticking His Hand in Its Cage at the Jacksonville Zoo</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/florida-residents-are-suing-governor-to-restore-federal-unemployment-benefits-68677" target="_self" rel="noopener noreferrer">Florida Residents Are Suing Governor to Restore Federal Unemployment Benefits</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/bearded-bar-hoppers-in-floridas-key-west-compete-in-ernest-hemingway-lookalike-contest-68607" target="_self" rel="noopener noreferrer">Bearded Bar-Hoppers in Florida&#x27;s Key West Compete in Ernest Hemingway Lookalike Contest </a></div><div class="shortcode-video"><div class="related-links"><a class="title" href="/videos/4903-watch-chubby-cheeked-tiny-hamster-throw-july-4-barbecue-for-furry-pals">Watch Chubby-Cheeked &#x27;Tiny Hamster&#x27; Throw July 4 Barbecue for Furry Pals</a><a href="/news" class="category">News</a></div></div></div></div><div class="content__spacer"></div><div class="content__tags"><h3>Tags:</h3><ul><li class=""><a href="https://www.insideedition.com/tag/florida " aria-label="Visit florida">florida</a></li><li class=""><a href="https://www.insideedition.com/tag/new-york " aria-label="Visit new York">new York</a></li></ul></div><div class="content__spacer"></div><div class="right-rail"><div style="top:0"><div class="right-rail__content "><div data-ad-ref="mpu-plus-top" class="bidbarrel-ad"></div></div></div></div></div><div id="taboola-below-article-thumbnails"></div><div class="content__trending"><div class="trending"><h2 class="trending__block-title">Trending on Inside Edition</h2><div class="trending__items"><div class="trending__item"><a href="https://www.insideedition.com/denver-police-department-teams-up-with-advance-auto-parts-to-encourage-safe-driving-68834" class="trending__item__link"><span class="sr-only">Denver Police Department Teams Up With Advance Auto Parts to Encourage Safe Driving</span></a><div class="trending__item__image__container"><img alt="Denver Police Department Teams Up With Advance Auto Parts to Encourage Safe Driving" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-08/gettyimages-533079988.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">1</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Denver Police Department Teams Up With Advance Auto Parts to Encourage Safe Driving</p><a href="https://www.insideedition.com/offbeat" class="trending__item__text--kicker">Offbeat</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/new-york-gov-andrew-cuomo-again-denies-sexual-harassment-after-damning-attorney-generals-report" class="trending__item__link"><span class="sr-only">New York Gov. Andrew Cuomo Again Denies Sexual Harassment After Damning Attorney General&#x27;s Report Released</span></a><div class="trending__item__image__container"><img alt="New York Gov. Andrew Cuomo Again Denies Sexual Harassment After Damning Attorney General&#x27;s Report Released" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-08/gettyimages-1231600287.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">2</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">New York Gov. Andrew Cuomo Again Denies Sexual Harassment After Damning Attorney General&#x27;s Report Released</p><a href="https://www.insideedition.com/politics" class="trending__item__text--kicker">Politics</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/doritos-gives-australian-teen-20000-for-finding-a-puffy-chip-68814" class="trending__item__link"><span class="sr-only">Doritos Gives Australian Teen $20,000 for Finding a Puffy Chip </span></a><div class="trending__item__image__container"><img alt="Doritos Gives Australian Teen $20,000 for Finding a Puffy Chip " class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-08/080321_dorito_chip_money_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">3</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Doritos Gives Australian Teen $20,000 for Finding a Puffy Chip </p><a href="https://www.insideedition.com/offbeat" class="trending__item__text--kicker">Offbeat</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/species-resembling-spongebob-squarepants-and-patrick-star-spotted-off-new-york-coast-by-ocean-68828" class="trending__item__link"><span class="sr-only">Species Resembling SpongeBob SquarePants and Patrick Star Spotted Off New York Coast by Ocean Researchers</span></a><div class="trending__item__image__container"><img alt="Species Resembling SpongeBob SquarePants and Patrick Star Spotted Off New York Coast by Ocean Researchers" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-08/080221_spongebob_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">4</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Species Resembling SpongeBob SquarePants and Patrick Star Spotted Off New York Coast by Ocean Researchers</p><a href="https://www.insideedition.com/offbeat" class="trending__item__text--kicker">Offbeat</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/woman-stalked-by-a-coyote-on-cape-cod-beach-thanks-the-boaters-who-rescued-her-68815" class="trending__item__link"><span class="sr-only">Woman Stalked by a Coyote on Cape Cod Beach Thanks the Boaters Who Rescued Her</span></a><div class="trending__item__image__container"><img alt="Woman Stalked by a Coyote on Cape Cod Beach Thanks the Boaters Who Rescued Her" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-08/080221_coyote_attack_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">5</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Woman Stalked by a Coyote on Cape Cod Beach Thanks the Boaters Who Rescued Her</p><a href="https://www.insideedition.com/inspirational" class="trending__item__text--kicker">Inspirational</a></div></div></div></div></div></div></div></div></div></main><footer class="footer dark"><div class="footer-container dark"><div class="footer-right"><ul class="social"><li><a aria-label="Visit Facebook" href="http://www.facebook.com/Inside.Edition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Twitter" href="http://twitter.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Instagram" href="https://instagram.com/insideedition/" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Youtube" href="https://www.youtube.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit RSS" href="https://www.insideedition.com/rss" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li></ul></div><div class="footer-menu-wrapper dark"><div class="footer-menu dark"><h4>About Us</h4><ul><li><a href="/meet-the-team" aria-label="Visit Meet the Team">Meet the Team</a></li><li><a href="/awards" aria-label="Visit Awards">Awards</a></li><li><a href="/contact" aria-label="Visit Contact">Contact</a></li></ul></div><div class="footer-menu dark"><h4>Connect</h4><ul><li><a href="https://www.facebook.com/Inside.Edition" aria-label="Visit Facebook" rel="noopener noreferrer" target="_blank">Facebook</a></li><li><a href="https://twitter.com/insideedition" aria-label="Visit Twitter" rel="noopener noreferrer" target="_blank">Twitter</a></li><li><a href="https://instagram.com/insideedition/" aria-label="Visit Instagram" rel="noopener noreferrer" target="_blank">Instagram</a></li><li><a href="https://www.youtube.com/insideedition" aria-label="Visit YouTube" rel="noopener noreferrer" target="_blank">YouTube</a></li><li><a href="/rss" aria-label="Visit RSS">RSS</a></li><li><a href="https://cbsinteractive.com/advertising/" aria-label="Visit Advertise with Us" rel="noopener noreferrer" target="_blank">Advertise with Us</a></li></ul></div><div class="footer-menu dark"><h4>Watch Inside Edition</h4><ul><li><a href="/showfinder" aria-label="Visit Local Listings">Local Listings</a></li><li><a href="/form/we-want-your-story-ideas" aria-label="Visit Submit a Story">Submit a Story</a></li></ul></div><div class="footer-menu dark"><h4>Sites We Love</h4><ul><li><a href="https://www.paramountplus.com" aria-label="Visit Paramount+" rel="noopener noreferrer" target="_blank">Paramount+</a></li><li><a href="https://www.cbsnews.com/" aria-label="Visit CBS News" rel="noopener noreferrer" target="_blank">CBS News</a></li><li><a href="https://www.etonline.com/" aria-label="Visit ETonline" rel="noopener noreferrer" target="_blank">ETonline</a></li><li><a href="https://www.thedrewbarrymoreshow.com/" aria-label="Visit The Drew Barrymore Show" rel="noopener noreferrer" target="_blank">The Drew Barrymore Show</a></li><li><a href="https://www.rachaelrayshow.com/" aria-label="Visit Rachael Ray Show" rel="noopener noreferrer" target="_blank">Rachael Ray Show</a></li><li><a href="https://www.dabl.com" aria-label="Visit DABL" rel="noopener noreferrer" target="_blank">DABL</a></li><li><a href="https://www.drphil.com" aria-label="Visit Dr. Phil" rel="noopener noreferrer" target="_blank">Dr. Phil</a></li><li><a href="https://www.startrek.com" aria-label="Visit Star Trek" rel="noopener noreferrer" target="_blank">Star Trek</a></li><li><a href="https://www.thedoctorstv.com" aria-label="Visit The Doctors" rel="noopener noreferrer" target="_blank">The Doctors</a></li><li><a href="https://www.last.fm/" aria-label="Visit Last.fm" rel="noopener noreferrer" target="_blank">Last.fm</a></li></ul></div></div><div class="footer-bottom dark"><a href="/" class="logo-greyscale"><div alt="Inside Edition"></div></a><div class="footer-copy"><a href="https://legalterms.cbsinteractive.com/terms-of-use" target="_blank" rel="noopener noreferrer">Terms of Use</a> |<a href="https://legalterms.cbsinteractive.com/privacy" target="_blank" rel="noopener noreferrer"> Privacy Policy</a> |<a href="https://legalterms.cbsinteractive.com/eula" target="_blank" rel="noopener noreferrer"> Mobile User Agreement</a> |<a href="http://www.cbs.com/closed-captioning/" target="_blank" rel="noopener noreferrer"> Closed Captioning</a> |<a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/video-services-and-social-networking" target="_blank" rel="noopener noreferrer"> Video Services Policy</a> |<a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/third-party-online-advertising" target="_blank" rel="noopener noreferrer"> Ad Choices</a> |<a href="https://ca.privacy.cbs" target="_blank" rel="noopener noreferrer"> California Privacy/Info We Collect</a> |<a href="https://ca.privacy.cbs/donotsell" target="_blank" rel="noopener noreferrer"> California Do Not Sell My Info</a> | In Partnership with <a href="http://www.etonline.com" target="_blank" rel="noopener noreferrer"> ETonline</a>.<span>CBS interactive &#169; 2021 Inside Edition Inc. All Rights Reserved.</span></div></div></div></footer></div></div></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>