<!DOCTYPE html><html lang="en"><head><link rel="apple-touch-icon" sizes="57x57" href="/img/favicons/apple-icon-57x57.png"/><link rel="apple-touch-icon" sizes="60x60" href="/img/favicons/apple-icon-60x60.png"/><link rel="apple-touch-icon" sizes="72x72" href="/img/favicons/apple-icon-72x72.png"/><link rel="apple-touch-icon" sizes="76x76" href="/img/favicons/apple-icon-76x76.png"/><link rel="apple-touch-icon" sizes="114x114" href="/img/favicons/apple-icon-114x114.png"/><link rel="apple-touch-icon" sizes="120x120" href="/img/favicons/apple-icon-120x120.png"/><link rel="apple-touch-icon" sizes="144x144" href="/img/favicons/apple-icon-144x144.png"/><link rel="apple-touch-icon" sizes="152x152" href="/img/favicons/apple-icon-152x152.png"/><link rel="apple-touch-icon" sizes="180x180" href="/img/favicons/apple-icon-180x180.png"/><link rel="icon" type="image/png" sizes="192x192" href="/img/favicons/android-icon-192x192.png"/><link rel="icon" type="image/png" sizes="32x32" href="/img/favicons/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="96x96" href="/img/favicons/favicon-96x96.png"/><link rel="icon" type="image/png" sizes="16x16" href="/img/favicons/favicon-16x16.png"/><link rel="manifest" crossorigin="use-credentials" href="/manifest.json"/><meta name="msapplication-TileImage" content="/img/favicons/ms-icon-144x144.png"/><link rel="preconnect" href="https://cdn.cookielaw.org"/><link rel="preconnect" href="https://www.insideedition.com"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/><meta http-equiv="content-language" content="en_US"/><meta property="fb:app_id" content="966341826790079"/><meta property="fb:admins" content="3111204"/><meta property="fb:pages" content="71728150722"/><meta property="og:site_name" content="Inside Edition"/><meta name="twitter:site" content="@insideedition"/><meta name="twitter:site:id" content="23603092"/><meta name="twitter:creator" content="@insideedition"/><meta name="robots" content="max-image-preview:large"/><meta name="theme-color" content="#fd005b"/><meta name="msapplication-TileColor" content="#fd005b"/><script>var utag_data = window.utag_data || {}; window.utag_data.isSPA = true;</script><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><title>New Mexico Teen Canaan Bower, Hailed A Hero For Thwarting a 2020 Kidnapping, Dies in Fatal Motorcycle Accident | Inside Edition</title><meta name="title" content="New Mexico Teen Canaan Bower, Hailed A Hero For Thwarting a 2020 Kidnapping, Dies in Fatal Motorcycle Accident"/><link rel="canonical" href="https://www.insideedition.com/new-mexico-teen-canaan-bower-hailed-a-hero-for-thwarting-a-2020-kidnapping-dies-in-fatal-motorcycle"/><link rel="image_src" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=1280&amp;height=720"/><meta name="robots" content="index"/><meta name="description" content="Canaan Bower was just 16 years old when he intervened in an attempted kidnapping at a gas station, pinning down the suspect until authorities arrived."/><meta property="og:description" content="Canaan Bower was just 16 years old when he intervened in an attempted kidnapping at a gas station, pinning down the suspect until authorities arrived."/><meta property="og:title" content="Teen Who Thwarted Attempted Kidnapping Killed in Motorcycle Accident "/><meta property="og:type" content="Article"/><meta property="og:url" content="https://www.insideedition.com/new-mexico-teen-canaan-bower-hailed-a-hero-for-thwarting-a-2020-kidnapping-dies-in-fatal-motorcycle"/><meta property="og:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=1280&amp;height=720"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="Canaan Bower was just 16 years old when he intervened in an attempted kidnapping at a gas station, pinning down the suspect until authorities arrived."/><meta name="twitter:title" content="Teen Who Thwarted Attempted Kidnapping Killed in Motorcycle Accident "/><meta name="twitter:url" content="https://www.insideedition.com/new-mexico-teen-canaan-bower-hailed-a-hero-for-thwarting-a-2020-kidnapping-dies-in-fatal-motorcycle"/><meta name="twitter:creator" content="@insideedition"/><meta name="twitter:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=1280&amp;height=720"/><meta name="twitter:image:width" content="1280"/><meta name="twitter:image:height" content="720"/><meta property="article:published_time" content="2022-03-14T11:37:18-0700"/><meta name="keywords" content="Inside Edition, Human Interest, News, new mexico, teens"/><link rel="amphtml" href="https://www.insideedition.com/new-mexico-teen-canaan-bower-hailed-a-hero-for-thwarting-a-2020-kidnapping-dies-in-fatal-motorcycle?amp"/><script type="application/ld+json">{"@context":"http://schema.org","articleSection":"News","dateModified":"2022-03-14T11:37:18-0700","headline":"New Mexico Teen Canaan Bower, Hailed A Hero For Thwarting a 2020 Kidnapping, Dies in Fatal Motorcycle Accident","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.insideedition.comnew-mexico-teen-canaan-bower-hailed-a-hero-for-thwarting-a-2020-kidnapping-dies-in-fatal-motorcycle"},"datePublished":"2022-03-14T11:37:18-0700","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}},"url":"https://www.insideedition.comnew-mexico-teen-canaan-bower-hailed-a-hero-for-thwarting-a-2020-kidnapping-dies-in-fatal-motorcycle","description":"Canaan Bower was just 16 years old when he intervened in an attempted kidnapping at a gas station, pinning down the suspect until authorities arrived.","keywords":["Inside Edition, Human Interest, News, new mexico, teens"],"image":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg","height":1080,"width":1920},"author":{"@type":"Person","name":"Johanna Li"}}</script><link rel="preload" as="image" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=1280&amp;height=720" imagesrcset="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=375&amp;height=211 375w, https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=1170&amp;height=658 1170w" imagesizes="(max-width: 375px) 375px, 1170px"/><meta name="next-head-count" content="28"/><link rel="preload" href="/_next/static/css/941b8995b2ef62c447f2.css" as="style"/><link rel="stylesheet" href="/_next/static/css/941b8995b2ef62c447f2.css" data-n-g=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-a40ef1678bae11e696dba45124eadd70.js"></script><script src="" defer="" data-nscript="beforeInteractive"></script><script src="https://tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js" id="utag" defer="" data-nscript="beforeInteractive"></script><script defer="" src="/_next/static/chunks/05d954cf-969177cf4119e8468031.js"></script><script defer="" src="/_next/static/chunks/9617-5e723aef92131e95bbe8.js"></script><script defer="" src="/_next/static/chunks/9276-ffbbf17b782577510a5e.js"></script><script defer="" src="/_next/static/chunks/2637.4493ab020345f6671f5c.js"></script><script defer="" src="/_next/static/chunks/8756.f6eb7613a79ea589abd5.js"></script><script defer="" src="/_next/static/chunks/4617.961433eed4610aef81c8.js"></script><script defer="" src="/_next/static/chunks/7166.f5bfa777a5e854c314d9.js"></script><script defer="" src="/_next/static/chunks/8187.0a4b417ab06324adc05a.js"></script><script src="/_next/static/chunks/webpack-dd03abacaf3d6b4ad2c2.js" defer=""></script><script src="/_next/static/chunks/framework-83ac992d51aff21d6264.js" defer=""></script><script src="/_next/static/chunks/main-6367e6dc380486a8cf0c.js" defer=""></script><script src="/_next/static/chunks/pages/_app-bb7f460eed9a93654dae.js" defer=""></script><script src="/_next/static/chunks/2127-f81b0ad589052f314ca1.js" defer=""></script><script src="/_next/static/chunks/6478-efd13e768ca1e9d5e8ea.js" defer=""></script><script src="/_next/static/chunks/703-09c78caa65be98021195.js" defer=""></script><script src="/_next/static/chunks/pages/%5B...alias%5D-987cf435832fd85c6b4b.js" defer=""></script><script src="/_next/static/insideedition/_buildManifest.js" defer=""></script><script src="/_next/static/insideedition/_ssgManifest.js" defer=""></script></head><body class="skybox-auto-collapse"><div id="__next"><div><div class="dark"><div class="main-menu__sticky" style="top:0"><div class="header__wrapper"><div id="sticky-banner" class=""><div data-ad-ref="mobile-omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div></div><div data-ad-ref="intromercial"></div><header class="header affix-top dark" style="top:0px" id="header"><div class="header__container"><div class="header__column-1"><div class="header__logo_toggle_wrapper"><button type="button" class="header__menu-toggle header__menu-toggle--collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"><span class="sr-only">Toggle navigation</span></button><a class="header__logo" href="/"><img height="46" width="68" class="header__logo__image" alt="Inside Edition Logo" src="/img/logo.svg"/></a></div><div class="header__nav" style="display:none;transform:translateY(-100%) translateZ(0)"><ul class="main-menu"><li class="main-menu__item main-menu__item--submenu-closed"><a href="/news" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">News</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/news">Latest News</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/crime">Crime</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/politics">Politics</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/health">Health</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/entertainment">Entertainment</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/royals">Royals</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/human-interest">Human Interest</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/inspirational">Inspirational</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/category/the-issue">The Issue</a></li></ul></li><li class="main-menu__item"><a href="/videos" class="main-menu__link" aria-label="Video">Video</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/photos" class="main-menu__link" aria-label="Photos">Photos</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/investigative" class="main-menu__link" aria-label="Investigative">Investigative</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/offbeat" class="main-menu__link" aria-label="Offbeat">Offbeat</a></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/more" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">More</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/animals">Animal Edition</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/heroes">Heroes</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/in-depth">Inside Edition InDepth</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/sports">Sports</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/flashback">Flashback</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/shopping">Shopping</a></li></ul></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/showfinder" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">Watch on TV</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/showfinder">Local Listings</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/meet-the-team">Meet the Team</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/today-inside-edition">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="header__column-2"><div data-testid="toggleable" class="header__search header__search--closed"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group" aria-hidden="true"><label for="edit-keywords"><span class="sr-only">Search</span></label><input type="search" id="edit-keywords" class="header__search-form__input-keywords" title="Enter the terms you wish to search for." placeholder="Search" name="keywords" size="15" maxLength="128"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><div class="header__search-form__actions"><button type="submit" class="header__search-form__actions__submit" name="op" aria-label="Search"></button></div></form></div><button type="button" class="header__search__close-button" aria-label="Close Search"></button><div class="header__social"><ul class="header__social-menu"><li class="header__social-menu__item"><a href="http://www.facebook.com/Inside.Edition" class="header__social-menu__link header__social-menu__link--facebook"><span class="sr-only">Facebook Inside Edition</span></a></li><li class="header__social-menu__item"><a href="http://twitter.com/insideedition" class="header__social-menu__link header__social-menu__link--twitter"><span class="sr-only">Twitter Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://instagram.com/insideedition/" class="header__social-menu__link header__social-menu__link--instagram"><span class="sr-only">Instagram Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://www.youtube.com/insideedition" class="header__social-menu__link header__social-menu__link--youtube"><span class="sr-only">YouTube Inside Edition</span></a></li></ul></div></div></div></header></div></div><div class="wrap-site"><main><noscript><img alt="" height="1" width="1" src="https://www.facebook.com/tr?id=1223619061322807&amp;ev=PageView&amp;noscript=1"/></noscript><div class="wrap-site"><div class="content"><div class="top-container"><h1 class="content__title">New Mexico Teen Canaan Bower, Hailed A Hero For Thwarting a 2020 Kidnapping, Dies in Fatal Motorcycle Accident</h1><div class="cat-social-container"><div class="content__category"><a href="https://www.insideedition.com/human-interest">Human Interest</a></div><div class="content__share"><div class="share"><button type="button" class="share__social-btn" aria-label="Share to Facebook"><div></div></button><button type="button" class="share__social-btn" aria-label="Share to Twitter"><div></div></button></div></div></div></div><div class="content__header-img centered"><div class="content__header-img-wrapper"><div class="content__header-img-wrap"><picture><source media="(max-width: 375px)" srcSet="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=375&amp;height=211"/><img src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-03/031422-nmhero-1280x720.jpeg.jpg?width=1170&amp;height=658" alt="Canaan Bowers, 18, was hailed a hero by in his community and across the country for intervening in a 2020 attempted kidnapping." class="img-full "/></picture></div><div class="content__header-img-caption-wrap"><span class="content__header-image-caption">Canaan Bowers, 18, was hailed a hero by in his community and across the country for intervening in a 2020 attempted kidnapping.</span><span class="content__header-image-credit">Facebook</span></div></div></div><div class="site-bg"><div class="constrain constrain--bg"><div class="content__body"><div class="content__topborder"></div><div class="content__byline"><div class="content__byline-author">By <a href="https://www.insideedition.com/bios/johanna-li" aria-label="Biography of Johanna Li"> <!-- -->Johanna Li<!-- --> </a></div><div class="content__byline-date"><div>First Published: <!-- -->11:37 AM PDT, March 14, 2022</div></div></div><h2 class="content__subheading">Canaan Bower was just 16 years old when he intervened in an attempted kidnapping at a gas station, pinning down the suspect until authorities arrived.</h2><div class="content__body-main"><div class="ctd-body"><div data-ad-ref="mobile-incontent-social" class="mobile-incontent-social bidbarrel-ad" aria-hidden="true"></div><p>A New Mexico teen, who was celebrated as a hero in his town in 2020 for thwarting an attempted kidnapping, died last week after being involved in a fatal motorcycle crash, his family said. Recent high school graduate Canaan Bower, 18, had been riding his motorcycle last Wednesday when it collided with a car making a turn, authorities said, according to the <a href="https://www.santafenewmexican.com/ap/las-cruces-teen-who-helped-thwart-attempted-kidnapping-killed-in-crash/article_985f93fa-7c6b-5927-9dae-f3d1bc7e61e1.html" rel="" target="_blank">Santa Fe New Mexican</a>.</p><p>&ldquo;Canaan lived life to the fullest and loved with his whole heart,&rdquo; his mother, Kara Garrett Bower, wrote on Facebook. &ldquo;He will be forever missed.&rdquo;</p><div data-ad-ref="mobile-flex-plus-middle" class="bidbarrel-ad"></div><p>Bower was 16 years old,&nbsp;a high school football player and wrestler&nbsp;when he intervened in an attempted kidnapping at a gas station. He had been pumping gas when he heard screaming from across the road, his mother said in a previous post.</p><p>&ldquo;She had a baby in her arms and was running away towards the store, and there was a guy coming after her getting really frustrated,&rdquo; Bower told the <a href="https://www.lcsun-news.com/story/news/local/2022/03/10/canaan-bower-las-cruces-hero-killed-motorcycle-crash/6987210001/" rel="" target="_blank">Las Cruces Sun News</a> at the time.</p><div data-ad-ref="mpu-flex-middle" class="bidbarrel-ad"></div><p>The man had apparently attempted to kidnap a woman and her young children before he continued on to &ldquo;hit several people in the car station and &hellip; [cause] a bloody mess,&rdquo; his mom said.&nbsp;</p><p>Other witnesses unsuccessfully attempted to intervene before Bower &ldquo;threw him to the ground,&rdquo; and kept him pinned until authorities arrived soon later, the post read.&nbsp;</p><div data-ad-ref="mpu-flex-inc" data-incremental="1" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="1" class="bidbarrel-ad"></div><p>&ldquo;There is a very good chance that Canaan saved many lives today and he definitely protected the kids from harm,&rdquo; his mom wrote in 2020.&nbsp;</p><p>The suspect was ultimately charged with four counts of battery, two counts of assault, two counts of child abuse and one count of kidnapping, the Sun News reported.</p><p>The incident gained national attention, and his moves were commended by UFC President Dana White as well as professional fighters Henry Cejudo and Jorge Masvidal, according to the Sun News.</p><p>Bower was also honored for his heroism by the city&rsquo;s mayor, Do&ntilde;a Ana County and the New Mexico State Senate. His county even named the day of the incident the Canaan Bower Day of Valor.</p><p>The family has set up a <a href="https://www.gofundme.com/f/canaan-bower-memorial-fund" rel="" target="_blank">GoFundMe</a> page to fundraise for his funeral expenses.</p><h2>Related Stories</h2><div class="shortcode-speedbump"><a href="https://www.insideedition.com/man-who-saved-dozens-from-2018-thousand-oaks-mass-shooting-dies-in-motorcycle-crash-he-was-so-loved" target="_self" rel="noopener noreferrer">Man Who Saved Dozens From 2018 Thousand Oaks Mass Shooting Dies in Motorcycle Crash: &#x27;He Was So Loved&#x27;</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/4-killed-in-helicopter-crash-during-training-exercise-at-us-navy-facility-in-hawaii-73429" target="_self" rel="noopener noreferrer">4 Killed in Helicopter Crash During Training Exercise at US Navy Facility in Hawaii</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/leonardo-gil-tiktok-star-and-adored-hospital-employee-killed-in-hit-and-run-crash-72941" target="_self" rel="noopener noreferrer">Leonardo Gil, TikTok Star and Adored Hospital Employee, Killed in Hit-and-Run Crash</a></div></div></div><div class="content__spacer"></div><div class="content__tags"><h3>Tags:</h3><ul><li class=""><a href="https://www.insideedition.com/tag/new-mexico " aria-label="Visit new mexico">new mexico</a></li><li class=""><a href="https://www.insideedition.com/tag/teens " aria-label="Visit teens">teens</a></li></ul></div><div class="content__spacer"></div><div class="right-rail"><div style="top:95px"><div class="right-rail__content "><div data-ad-ref="mpu-plus-top" class="bidbarrel-ad"></div></div></div></div></div><div id="taboola-below-article-thumbnails"></div><div class="content__trending"><div class="trending"><h2 class="trending__block-title">Trending on Inside Edition</h2><div class="trending__items"><div class="trending__item"><a href="https://www.insideedition.com/ukraines-zelenskyy-bravely-reveals-hes-still-in-presidential-palace-not-in-hiding-73688" class="trending__item__link"><span class="sr-only">Ukraine&#x27;s Zelenskyy Bravely Reveals He’s Still in Presidential Palace, Not in Hiding</span></a><div class="trending__item__image__container"><img alt="Ukraine&#x27;s Zelenskyy Bravely Reveals He’s Still in Presidential Palace, Not in Hiding" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-03/030822_zelensky_palace_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">1</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Ukraine&#x27;s Zelenskyy Bravely Reveals He’s Still in Presidential Palace, Not in Hiding</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/with-her-family-still-in-ukraine-florida-woman-clings-to-hope-that-her-peoples-fighting-spirit-will" class="trending__item__link"><span class="sr-only">With Her Family Still in Ukraine, Florida Woman Clings to Hope That Her People&#x27;s Fighting Spirit Will Prevail</span></a><div class="trending__item__image__container"><img alt="With Her Family Still in Ukraine, Florida Woman Clings to Hope That Her People&#x27;s Fighting Spirit Will Prevail" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-03/KyivJuly2021.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">2</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">With Her Family Still in Ukraine, Florida Woman Clings to Hope That Her People&#x27;s Fighting Spirit Will Prevail</p><a href="https://www.insideedition.com/human-interest" class="trending__item__text--kicker">Human Interest</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/mom-charged-with-faking-2016-kidnapping-had-other-people-involved-sheriff-says-73686" class="trending__item__link"><span class="sr-only">Mom Charged With Faking 2016 Kidnapping Had &#x27;Other People&#x27; Involved, Sheriff Says</span></a><div class="trending__item__image__container"><img alt="Mom Charged With Faking 2016 Kidnapping Had &#x27;Other People&#x27; Involved, Sheriff Says" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-03/030822_sheri_papini_case_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">3</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Mom Charged With Faking 2016 Kidnapping Had &#x27;Other People&#x27; Involved, Sheriff Says</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/spring-breakers-let-loose-on-miami-beach-after-2-years-of-covid-19-73682" class="trending__item__link"><span class="sr-only">Spring Breakers Let Loose on Miami Beach After 2 Years of COVID-19</span></a><div class="trending__item__image__container"><img alt="Spring Breakers Let Loose on Miami Beach After 2 Years of COVID-19" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-03/030822_spring_break_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">4</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Spring Breakers Let Loose on Miami Beach After 2 Years of COVID-19</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/florida-couple-stabbed-to-death-in-vicious-and-gruesome-attack-as-they-rode-their-bicycles-home" class="trending__item__link"><span class="sr-only">Florida Couple Stabbed to Death in &#x27;Vicious and Gruesome&#x27; Attack as They Rode Their Bicycles Home, Police Say</span></a><div class="trending__item__image__container"><img alt="Florida Couple Stabbed to Death in &#x27;Vicious and Gruesome&#x27; Attack as They Rode Their Bicycles Home, Police Say" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-03/couplestabbed.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">5</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Florida Couple Stabbed to Death in &#x27;Vicious and Gruesome&#x27; Attack as They Rode Their Bicycles Home, Police Say</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div></div></div></div></div></div></div></div></main><footer class="footer dark"><div class="footer-container dark"><div class="footer-right"><ul class="social"><li><a aria-label="Visit Facebook" href="http://www.facebook.com/Inside.Edition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Twitter" href="http://twitter.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Instagram" href="https://instagram.com/insideedition/" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Youtube" href="https://www.youtube.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit RSS" href="https://www.insideedition.com/rss" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li></ul></div><div class="footer-menu-wrapper dark"><div class="footer-menu dark"><h4>About Us</h4><ul><li><a href="/meet-the-team" aria-label="Visit Meet the Team">Meet the Team</a></li><li><a href="/awards" aria-label="Visit Awards">Awards</a></li><li><a href="/contact" aria-label="Visit Contact">Contact</a></li></ul></div><div class="footer-menu dark"><h4>Connect</h4><ul><li><a href="https://www.facebook.com/Inside.Edition" aria-label="Visit Facebook" rel="noopener noreferrer" target="_blank">Facebook</a></li><li><a href="https://twitter.com/insideedition" aria-label="Visit Twitter" rel="noopener noreferrer" target="_blank">Twitter</a></li><li><a href="https://instagram.com/insideedition/" aria-label="Visit Instagram" rel="noopener noreferrer" target="_blank">Instagram</a></li><li><a href="https://www.youtube.com/insideedition" aria-label="Visit YouTube" rel="noopener noreferrer" target="_blank">YouTube</a></li><li><a href="/rss" aria-label="Visit RSS">RSS</a></li><li><a href="https://cbsinteractive.com/advertising/" aria-label="Visit Advertise with Us" rel="noopener noreferrer" target="_blank">Advertise with Us</a></li></ul></div><div class="footer-menu dark"><h4>Watch Inside Edition</h4><ul><li><a href="/showfinder" aria-label="Visit Local Listings">Local Listings</a></li><li><a href="/form/we-want-your-story-ideas" aria-label="Visit Submit a Story">Submit a Story</a></li></ul></div><div class="footer-menu dark"><h4>Sites We Love</h4><ul><li><a href="https://www.paramountplus.com?ftag=PPM-06-10aib3j" aria-label="Visit Paramount+" rel="noopener noreferrer" target="_blank">Paramount+</a></li><li><a href="https://www.cbsnews.com/" aria-label="Visit CBS News" rel="noopener noreferrer" target="_blank">CBS News</a></li><li><a href="https://www.etonline.com/" aria-label="Visit ETonline" rel="noopener noreferrer" target="_blank">ETonline</a></li><li><a href="https://www.thedrewbarrymoreshow.com/" aria-label="Visit The Drew Barrymore Show" rel="noopener noreferrer" target="_blank">The Drew Barrymore Show</a></li><li><a href="https://www.rachaelrayshow.com/" aria-label="Visit Rachael Ray Show" rel="noopener noreferrer" target="_blank">Rachael Ray Show</a></li><li><a href="https://www.dabl.com" aria-label="Visit DABL" rel="noopener noreferrer" target="_blank">DABL</a></li><li><a href="https://www.drphil.com" aria-label="Visit Dr. Phil" rel="noopener noreferrer" target="_blank">Dr. Phil</a></li><li><a href="https://www.startrek.com" aria-label="Visit Star Trek" rel="noopener noreferrer" target="_blank">Star Trek</a></li><li><a href="https://www.thedoctorstv.com" aria-label="Visit The Doctors" rel="noopener noreferrer" target="_blank">The Doctors</a></li><li><a href="https://www.last.fm/" aria-label="Visit Last.fm" rel="noopener noreferrer" target="_blank">Last.fm</a></li></ul></div></div><div class="footer-bottom dark"><a href="/" class="logo-greyscale"><div alt="Inside Edition"></div></a><div class="footer-copy"><a href="https://legalterms.cbsinteractive.com/terms-of-use" target="_blank" rel="noopener noreferrer">Terms of Use</a> |<a href="https://www.viacomcbsprivacy.com/policy" target="_blank" rel="noopener noreferrer"> Privacy Policy</a> |<a href="https://www.viacomcbsprivacy.com/cookies" target="_blank" rel="noopener noreferrer"> Cookies Policy</a> |<a href="http://www.cbs.com/closed-captioning/" target="_blank" rel="noopener noreferrer"> Closed Captioning</a> |<a href="https://www.viacomcbsprivacy.com/donotsell" target="_blank" rel="noopener noreferrer"> Do Not Sell My Personal Information</a> | In Partnership with <a href="http://www.etonline.com" target="_blank" rel="noopener noreferrer"> ETonline</a>.<span>CBS interactive &#169; 2022 Inside Edition Inc. All Rights Reserved.</span></div></div></div></footer></div></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>