<!DOCTYPE html><html lang="en"><head><link rel="apple-touch-icon" sizes="57x57" href="/img/favicons/apple-icon-57x57.png"/><link rel="apple-touch-icon" sizes="60x60" href="/img/favicons/apple-icon-60x60.png"/><link rel="apple-touch-icon" sizes="72x72" href="/img/favicons/apple-icon-72x72.png"/><link rel="apple-touch-icon" sizes="76x76" href="/img/favicons/apple-icon-76x76.png"/><link rel="apple-touch-icon" sizes="114x114" href="/img/favicons/apple-icon-114x114.png"/><link rel="apple-touch-icon" sizes="120x120" href="/img/favicons/apple-icon-120x120.png"/><link rel="apple-touch-icon" sizes="144x144" href="/img/favicons/apple-icon-144x144.png"/><link rel="apple-touch-icon" sizes="152x152" href="/img/favicons/apple-icon-152x152.png"/><link rel="apple-touch-icon" sizes="180x180" href="/img/favicons/apple-icon-180x180.png"/><link rel="icon" type="image/png" sizes="192x192" href="/img/favicons/android-icon-192x192.png"/><link rel="icon" type="image/png" sizes="32x32" href="/img/favicons/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="96x96" href="/img/favicons/favicon-96x96.png"/><link rel="icon" type="image/png" sizes="16x16" href="/img/favicons/favicon-16x16.png"/><link rel="manifest" crossorigin="use-credentials" href="/manifest.json"/><meta name="msapplication-TileImage" content="/img/favicons/ms-icon-144x144.png"/><link rel="preconnect" href="https://cdn.cookielaw.org"/><link rel="preconnect" href="https://www.insideedition.com"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/><meta http-equiv="content-language" content="en_US"/><meta property="fb:app_id" content="966341826790079"/><meta property="fb:admins" content="3111204"/><meta property="fb:pages" content="71728150722"/><meta property="og:site_name" content="Inside Edition"/><meta name="twitter:site" content="@insideedition"/><meta name="twitter:site:id" content="23603092"/><meta name="twitter:creator" content="@insideedition"/><meta name="robots" content="max-image-preview:large"/><meta name="theme-color" content="#fd005b"/><meta name="msapplication-TileColor" content="#fd005b"/><script>var utag_data = window.utag_data || {}; window.utag_data.isSPA = true;</script><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><title>&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness  | Inside Edition</title><meta name="title" content="&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness "/><link rel="canonical" href="https://www.insideedition.com/bat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724"/><link rel="image_src" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d&amp;width=1280&amp;height=720"/><meta name="robots" content="index"/><meta name="description" content="Last week Meat Loaf’s daughter, Pearl, revealed on social media that several of her family members had tested positive for COVID-19, however she did not reveal any names."/><meta property="og:description" content="Last week Meat Loaf’s daughter, Pearl, revealed on social media that several of her family members had tested positive for COVID-19, however she did not reveal any names."/><meta property="og:title" content="&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness "/><meta property="og:type" content="Article"/><meta property="og:url" content="https://www.insideedition.com/bat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724"/><meta property="og:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d&amp;width=1280&amp;height=720"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta property="og:video:secure_url" content="https://cbsi-insideedition-video-fastly.global.ssl.fastly.net/2022/01/21/1995155523685/012122_meatloaf_obit_web-8e3219e9_878346_5192.mp4"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="Last week Meat Loaf’s daughter, Pearl, revealed on social media that several of her family members had tested positive for COVID-19, however she did not reveal any names."/><meta name="twitter:title" content="&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness "/><meta name="twitter:url" content="https://www.insideedition.com/bat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724"/><meta name="twitter:creator" content="@insideedition"/><meta name="twitter:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d&amp;width=1280&amp;height=720"/><meta name="twitter:image:width" content="1280"/><meta name="twitter:image:height" content="720"/><meta property="article:published_time" content="2022-01-21T14:34:43-0800"/><meta name="keywords" content="Inside Edition, Entertainment, Health, News, celebrity, Coronavirus, obituary"/><link rel="amphtml" href="https://www.insideedition.com/bat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724?amp"/><script type="application/ld+json">{"@context":"http://schema.org","articleSection":"News","dateModified":"2022-01-21T14:34:43-0800","headline":"'Bat Out of Hell' Rock Legend Meat Loaf Dead at 74 After a Serious Illness ","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.insideedition.combat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724"},"datePublished":"2022-01-21T14:34:43-0800","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}},"url":"https://www.insideedition.combat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724","description":"Last week Meat Loaf’s daughter, Pearl, revealed on social media that several of her family members had tested positive for COVID-19, however she did not reveal any names.","keywords":["Inside Edition, Entertainment, Health, News, celebrity, Coronavirus, obituary"],"image":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d","height":1080,"width":1920},"author":{"@type":"Person","name":"IE Staff"},"video":{"@context":"https://schema.org","@type":"VideoObject","name":"012122_meatloaf_obit_web","description":"Last week Meat Loaf’s daughter, Pearl, revealed on social media that several of her family members had tested positive for COVID-19, however she did not reveal any names.","thumbnailUrl":"/sites/default/files/images/2022-01/012122_meatloaf_obit_web.jpg","thumbnail":{"@context":"https://schema.org","@type":"ImageObject","height":"360","width":"640","url":"/sites/default/files/images/2022-01/012122_meatloaf_obit_web.jpg"},"uploadDate":"2022-01-21T15:14:22-08:00","duration":"PT191S","embedUrl":"https://cbsi-insideedition-video-fastly.global.ssl.fastly.net/2022/01/21/1995155523685/878345_hls/master.m3u8","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}}}}</script><link rel="preload" as="image" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d&amp;width=1280&amp;height=720" imagesrcset="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d&amp;width=375&amp;height=211 375w, https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-01/012122_meatloaf_obit_web.jpg?h=d1cb525d&amp;width=1170&amp;height=658 1170w" imagesizes="(max-width: 375px) 375px, 1170px"/><meta name="next-head-count" content="29"/><link rel="preload" href="/_next/static/css/b7e7e84cf545b82b1550.css" as="style"/><link rel="stylesheet" href="/_next/static/css/b7e7e84cf545b82b1550.css" data-n-g=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-a40ef1678bae11e696dba45124eadd70.js"></script><script src="" defer="" data-nscript="beforeInteractive"></script><script src="https://tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js" id="utag" defer="" data-nscript="beforeInteractive"></script><script defer="" src="/_next/static/chunks/05d954cf.355ef0e5b3511141e94b.js"></script><script defer="" src="/_next/static/chunks/4fb89f36b476c12f47cc6508fb35a84db0eb0fa6.b4d36afab89d9ec134e0.js"></script><script defer="" src="/_next/static/chunks/35.3dafc5ee60ee4a400ba0.js"></script><script defer="" src="/_next/static/chunks/39.933c2cacfbda4a389061.js"></script><script defer="" src="/_next/static/chunks/29107295.8c2a2286d406c4e16fb9.js"></script><script defer="" src="/_next/static/chunks/41.3ede9805f4ddfb68faf0.js"></script><script defer="" src="/_next/static/chunks/33.72961e4942f933c15e9b.js"></script><script defer="" src="/_next/static/chunks/13.32ac8e9ac5d53ab22ffd.js"></script><script defer="" src="/_next/static/chunks/c8f7fe3b0e41be846d5687592cf2018ff6e22687.d412afcebfb53875575b.js"></script><script src="/_next/static/chunks/webpack-6fc37be9eaf3788424f3.js" defer=""></script><script src="/_next/static/chunks/framework.efe182f2d62be1d8151a.js" defer=""></script><script src="/_next/static/chunks/d6931faacbd75d480449bb1e4978ca1dd9857c84.e5ebd9a9dc48937a5931.js" defer=""></script><script src="/_next/static/chunks/1c9201d36438dd6de84623f98cd2f6e06abde4c5.465a3530ebdacf33e927.js" defer=""></script><script src="/_next/static/chunks/main-14798b871bc487957e7b.js" defer=""></script><script src="/_next/static/chunks/6d81ae3426b31e02b1f8addf5b50b69a832a68b7.e4363b419e69d1118f7e.js" defer=""></script><script src="/_next/static/chunks/pages/_app-79237cdc2d27a386dedc.js" defer=""></script><script src="/_next/static/chunks/ebff7526f9960be9b60e16087ac81c031725b6ac.8faab6e76909e26a0b2b.js" defer=""></script><script src="/_next/static/chunks/516d77f140e741cb5d11138e1ac1158ffad9e7dd.8642dd03dbba4efbe35a.js" defer=""></script><script src="/_next/static/chunks/0a4f3b6a5869d751323b8bf53908ff3a728fb8ed.0314111e536862688c27.js" defer=""></script><script src="/_next/static/chunks/pages/%5B...alias%5D-a958a74c7b631a4e5a3b.js" defer=""></script><script src="/_next/static/insideedition/_buildManifest.js" defer=""></script><script src="/_next/static/insideedition/_ssgManifest.js" defer=""></script></head><body class="skybox-auto-collapse"><div id="__next"><div><div class="dark"><div class="main-menu__sticky" style="top:0"><div class="header__wrapper"><div id="sticky-banner" class=""><div data-ad-ref="mobile-omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div></div><div data-ad-ref="intromercial"></div><header class="header affix-top dark" style="top:0px" id="header"><div class="header__container"><div class="header__column-1"><div class="header__logo_toggle_wrapper"><button type="button" class="header__menu-toggle header__menu-toggle--collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"><span class="sr-only">Toggle navigation</span></button><a class="header__logo" href="/"><img height="46" width="68" class="header__logo__image" alt="Inside Edition Logo" src="/img/logo.svg"/></a></div><div class="header__nav" style="display:none;transform:translateY(-100%) translateZ(0)"><ul class="main-menu"><li class="main-menu__item main-menu__item--submenu-closed"><a href="/news" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">News</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/news">Latest News</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/crime">Crime</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/politics">Politics</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/health">Health</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/entertainment">Entertainment</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/royals">Royals</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/human-interest">Human Interest</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/inspirational">Inspirational</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/category/the-issue">The Issue</a></li></ul></li><li class="main-menu__item"><a href="/videos" class="main-menu__link" aria-label="Video">Video</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/photos" class="main-menu__link" aria-label="Photos">Photos</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/investigative" class="main-menu__link" aria-label="Investigative">Investigative</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/offbeat" class="main-menu__link" aria-label="Offbeat">Offbeat</a></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/more" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">More</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/animals">Animal Edition</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/heroes">Heroes</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/in-depth">Inside Edition InDepth</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/sports">Sports</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/flashback">Flashback</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/shopping">Shopping</a></li></ul></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/showfinder" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">Watch on TV</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/showfinder">Local Listings</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/meet-the-team">Meet the Team</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/today-inside-edition">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="header__column-2"><div class="header__search header__search--closed"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group"><label for="edit-keywords"><span class="sr-only">Search</span></label><input type="search" id="edit-keywords" class="header__search-form__input-keywords" value="" title="Enter the terms you wish to search for." placeholder="Search" name="keywords" size="15" maxLength="128"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><input type="hidden" data-drupal-selector="edit-search-block-form" name="form_id" value="search_block_form"/><div data-drupal-selector="edit-actions" class="header__search-form__actions" id="edit-actions"><button type="submit" class="header__search-form__actions__submit" name="op" value="" aria-hidden="true"></button></div></form></div><button type="button" class="header__search__close-button" aria-label="Close Search"></button><div class="header__social"><ul class="header__social-menu"><li class="header__social-menu__item"><a href="http://www.facebook.com/Inside.Edition" class="header__social-menu__link header__social-menu__link--facebook"><span class="sr-only">Facebook Inside Edition</span></a></li><li class="header__social-menu__item"><a href="http://twitter.com/insideedition" class="header__social-menu__link header__social-menu__link--twitter"><span class="sr-only">Twitter Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://instagram.com/insideedition/" class="header__social-menu__link header__social-menu__link--instagram"><span class="sr-only">Instagram Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://www.youtube.com/insideedition" class="header__social-menu__link header__social-menu__link--youtube"><span class="sr-only">YouTube Inside Edition</span></a></li></ul></div></div></div></header></div></div><div class="wrap-site"><main><noscript><img alt="" height="1" width="1" src="https://www.facebook.com/tr?id=1223619061322807&amp;ev=PageView&amp;noscript=1"/></noscript><div class="wrap-site"><div class="content"><div class="top-container"><h1 class="content__title">&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness </h1><div class="cat-social-container"><div class="content__category"><a href="https://www.insideedition.com/entertainment">Entertainment</a></div><div class="content__share"><div class="share"><button type="button" class="share__social-btn" aria-label="Share to Facebook"><div></div></button><button type="button" class="share__social-btn" aria-label="Share to Twitter"><div></div></button></div></div></div></div><div class="content__header-video"><div class="content__header-video-wrap"><div class="sticky "><button type="button" class="stuck-close"><div></div></button><div></div></div></div></div><div class="carousel-main"><script async="" src="https://i-amlg-prod.appspot.com/display?id=12e3f033-1994-4ad9-96ae-df30258c4bc0"></script><div class="carousel__mask"></div><div class="carousel-rec__wrapper"><div class="carousel-rec"><div class="carousel__container"><button type="button" aria-label="012122_meatloaf_obit_web"><h3 class="card__title line-clamp"> <!-- -->012122_meatloaf_obit_web<!-- --> </h3></button><button type="button" aria-label="Families Ring in the New Year with Panda Cuddles"><h3 class="card__title line-clamp"> <!-- -->Families Ring in the New Year with Panda Cuddles<!-- --> </h3></button><button type="button" aria-label="Apple AirTags Can Be Used to Stalk Unsuspecting People"><h3 class="card__title line-clamp"> <!-- -->Apple AirTags Can Be Used to Stalk Unsuspecting People<!-- --> </h3></button><button type="button" aria-label="21-Year-Old California College Student Leading a Treasure Hunt Goes Missing"><h3 class="card__title line-clamp"> <!-- -->21-Year-Old California College Student Leading a Treasure Hunt Goes Missing<!-- --> </h3></button><button type="button" aria-label="Kansas TikToker Dies at 21 of Rare Genetic Disease That Causes Skin to Blister"><h3 class="card__title line-clamp"> <!-- -->Kansas TikToker Dies at 21 of Rare Genetic Disease That Causes Skin to Blister<!-- --> </h3></button><button type="button" aria-label="Lake Tahoe Commuters’ Trip Stretched 15 Hours in Epic Snow Storm"><h3 class="card__title line-clamp"> <!-- -->Lake Tahoe Commuters’ Trip Stretched 15 Hours in Epic Snow Storm<!-- --> </h3></button><button type="button" aria-label="Skier Says It Was ‘Scary’ Being Buried in 3 Feet of Snow Following Backflip "><h3 class="card__title line-clamp"> <!-- -->Skier Says It Was ‘Scary’ Being Buried in 3 Feet of Snow Following Backflip <!-- --> </h3></button><button type="button" aria-label="Top 2021 TV Moments Include Lady Gaga, Meghan Markle and Adele "><h3 class="card__title line-clamp"> <!-- -->Top 2021 TV Moments Include Lady Gaga, Meghan Markle and Adele <!-- --> </h3></button><button type="button" aria-label="Endangered Tiger Shot by Florida Police After Zoo Cleaner Stuck His Hand in Tiger Cage"><h3 class="card__title line-clamp"> <!-- -->Endangered Tiger Shot by Florida Police After Zoo Cleaner Stuck His Hand in Tiger Cage<!-- --> </h3></button><button type="button" aria-label="Bus Drivers Called on to Watch Classes After Teachers Call in Sick"><h3 class="card__title line-clamp"> <!-- -->Bus Drivers Called on to Watch Classes After Teachers Call in Sick<!-- --> </h3></button><button type="button" aria-label="Man Who Filmed Ashli Babbit Being Shot Claims He Was Wrongly Called a Rioter"><h3 class="card__title line-clamp"> <!-- -->Man Who Filmed Ashli Babbit Being Shot Claims He Was Wrongly Called a Rioter<!-- --> </h3></button><button type="button" aria-label="Andy Cohen Won’t Apologize for ‘Drunk and Stupid’ New Year’s Eve Rant"><h3 class="card__title line-clamp"> <!-- -->Andy Cohen Won’t Apologize for ‘Drunk and Stupid’ New Year’s Eve Rant<!-- --> </h3></button><button type="button" aria-label="6-Year-Old Calls 911 After Her Barbies Go Missing"><h3 class="card__title line-clamp"> <!-- -->6-Year-Old Calls 911 After Her Barbies Go Missing<!-- --> </h3></button><button type="button" aria-label="Trailblazing Black Actor Sidney Poitier Dies at 94 Years Old"><h3 class="card__title line-clamp"> <!-- -->Trailblazing Black Actor Sidney Poitier Dies at 94 Years Old<!-- --> </h3></button><button type="button" aria-label="Betty White’s Longtime Agent Says There Will Be No Public Memorial"><h3 class="card__title line-clamp"> <!-- -->Betty White’s Longtime Agent Says There Will Be No Public Memorial<!-- --> </h3></button><button type="button" aria-label="Newborn Allegedly Tossed in Trash by Teen Found Alive in New Mexico Dumpster"><h3 class="card__title line-clamp"> <!-- -->Newborn Allegedly Tossed in Trash by Teen Found Alive in New Mexico Dumpster<!-- --> </h3></button><button type="button" aria-label="Health Experts Worry New Year’s Parties Will Become COVID Super-Spreader Events"><h3 class="card__title line-clamp"> <!-- -->Health Experts Worry New Year’s Parties Will Become COVID Super-Spreader Events<!-- --> </h3></button><button type="button" aria-label="Chalk Artist&#x27;s 3D Characters Help Him &quot;Appreciate Every Single Place&#x27; "><h3 class="card__title line-clamp"> <!-- -->Chalk Artist&#x27;s 3D Characters Help Him &quot;Appreciate Every Single Place&#x27; <!-- --> </h3></button><button type="button" aria-label="Scientists Are Working on Creating Tastier Plant-Based Meat Alternatives"><h3 class="card__title line-clamp"> <!-- -->Scientists Are Working on Creating Tastier Plant-Based Meat Alternatives<!-- --> </h3></button><button type="button" aria-label="College Diver Paralyzed in Accident Walks Across the Stage at Graduation"><h3 class="card__title line-clamp"> <!-- -->College Diver Paralyzed in Accident Walks Across the Stage at Graduation<!-- --> </h3></button></div></div><button class="carousel__arrow carousel__arrow--prev" type="button" aria-label="Previous Slide"><div></div></button><button class="carousel__arrow carousel__arrow--next" type="button" aria-label="Next Slide"><div></div></button></div><div class="carousel__mask"></div></div><div class="site-bg"><div class="constrain constrain--bg"><div class="content__body"><div class="content__topborder"></div><div class="content__byline"><div class="content__byline-author">By <!-- -->IE Staff</div><div class="content__byline-date"><div>First Published: <!-- -->2:34 PM PST, January 21, 2022</div></div></div><h2 class="content__subheading">Last week Meat Loaf’s daughter, Pearl, revealed on social media that several of her family members had tested positive for COVID-19, however she did not reveal any names.</h2><div class="content__body-main"><div class="ctd-body"><div data-ad-ref="mobile-incontent-social" class="mobile-incontent-social bidbarrel-ad" aria-hidden="true"></div><p>Meat Loaf, the 74-year-old rock icon whose 1977 debut &ldquo;Bat Out of Hell&rdquo; became one of the best-selling albums of all time, <a href="https://www.insideedition.com/tag/obituary" rel="" target="_blank">died </a>Thursday after a serious illness, with his family by his side.</p><p>He passed away in a hospital outside <a href="https://www.insideedition.com/tag/tennessee" rel="" target="_blank">Nashville</a>, where he lived. His wife Deborah and two daughters were at his side. In a statement, the family said their "hearts are broken."</p><div data-ad-ref="mobile-flex-plus-middle" class="bidbarrel-ad"></div><p>Meat Loaf also appeared in classic movies, including&nbsp;&ldquo;Rocky Horror Picture Show,&rdquo; &ldquo;Wayne&rsquo;s World&rdquo; and &ldquo;Fight Club.&rdquo;&nbsp;</p><p>In 2011, he had an epic meltdown on &ldquo;Celebrity Apprentice&rdquo; in a face-off with Gary Busey.</p><div data-ad-ref="mpu-flex-middle" class="bidbarrel-ad"></div><p>Meat Loaf was&nbsp;an outspoken critic of <a href="https://www.insideedition.com/tag/coronavirus" rel="" target="_blank">vaccine and mask mandates</a> and was recently quoted as saying, &ldquo;If I die, I die, but I'm not going to be controlled."</p><p>&ldquo;He was kind of tired of the restrictions with COVID,&rdquo; Scott Mervis, Pittsburgh Post-Gazette music critic, told Inside Edition. &ldquo;He said that he had to go on a plane. He was wearing an N95 mask and it was so uncomfortable and a nuisance and how the flight attendants were just real strict about keeping the masks on.&rdquo;</p><div data-ad-ref="mpu-flex-inc" data-incremental="1" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="1" class="bidbarrel-ad"></div><p>Last week Meat Loaf&rsquo;s daughter, Pearl, revealed on social media that several of her family members had tested <a href="https://www.insideedition.com/tag/coronavirus" rel="" target="_blank">positive for COVID-19</a>, however she did not reveal any names.</p><p>&ldquo;Positive but doing OK,&rdquo; she wrote. &ldquo;They&rsquo;re all vaxxed, otherwise they&rsquo;d be way worse.&rdquo;</p><p>In recent years, Meat Loaf was in failing health. &nbsp;</p><p>&ldquo;This is not the life of Riley, let me tell you. I get to go to bed and I get to come and sit in this chair,&rdquo; he said in a video.</p><p>He suffered from<a href="https://www.insideedition.com/tag/cancer" rel="" target="_blank"> skin cancer</a>, a rare heart condition and asthma. In 2016, he collapsed on stage.</p><p>His family posted a final message from him for his fans: &ldquo;From his heart to your souls &mdash; don&rsquo;t ever stop rocking.&rdquo;</p><div data-ad-ref="mpu-flex-inc" data-incremental="2" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="2" class="bidbarrel-ad"></div><p>At the time of his death, Meat Loaf was working on a reality show based on his hit song &ldquo;I'd Do Anything for Love."</p><h2><strong>Related Stories</strong></h2><div class="shortcode-speedbump"><a href="https://www.insideedition.com/bob-sagets-widow-kelly-rizzo-speaks-out-for-the-first-time-since-comedians-passing-72695" target="_self" rel="noopener noreferrer">Bob Saget&#x27;s Widow Kelly Rizzo Speaks Out for the First Time Since Comedian&#x27;s Passing</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/betty-whites-cause-of-death-was-a-stroke-that-she-had-6-days-before-she-died-report-72441" target="_self" rel="noopener noreferrer">Betty White&#x27;s Cause of Death Was a Stroke That She Had 6 Days Before She Died: Report</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/1000-books-from-ruth-bader-ginsburgs-personal-library-are-up-for-auction-72722" target="_self" rel="noopener noreferrer">1,000 Books From Ruth Bader Ginsburg&#x27;s Personal Library Are Up for Auction</a></div><div class="shortcode-video"><div class="related-links"><a class="title" href="/media/videos/bob-saget-found-dead-at-65-friends-and-family-react-to-unexpected-death-72432">Bob Saget Found Dead at 65: Friends and Family React to Unexpected Death</a><a href="/entertainment" class="category">Entertainment</a></div></div></div></div><div class="content__spacer"></div><div class="content__tags"><h3>Tags:</h3><ul><li class=""><a href="https://www.insideedition.com/tag/celebrity " aria-label="Visit celebrity">celebrity</a></li><li class=""><a href="https://www.insideedition.com/tag/coronavirus " aria-label="Visit Coronavirus">Coronavirus</a></li><li class=""><a href="https://www.insideedition.com/tag/obituary " aria-label="Visit obituary">obituary</a></li></ul></div><div class="content__spacer"></div><div class="right-rail"><div style="top:0"><div class="right-rail__content "><div data-ad-ref="mpu-plus-top" class="bidbarrel-ad"></div></div></div></div></div><div id="taboola-below-article-thumbnails"></div><div class="content__trending"><div class="trending"><h2 class="trending__block-title">Trending on Inside Edition</h2><div class="trending__items"><div class="trending__item"><a href="https://www.insideedition.com/bat-out-of-hell-rock-legend-meat-loaf-dead-at-74-after-a-serious-illness-72724" class="trending__item__link"><span class="sr-only">&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness </span></a><div class="trending__item__image__container"><img alt="&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness " class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-01/012122_meatloaf_obit_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">1</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">&#x27;Bat Out of Hell&#x27; Rock Legend Meat Loaf Dead at 74 After a Serious Illness </p><a href="https://www.insideedition.com/entertainment" class="trending__item__text--kicker">Entertainment</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/jordan-turpin-is-making-a-name-for-herself-on-tiktok-after-surviving-her-parents-house-of-horrors" class="trending__item__link"><span class="sr-only">Jordan Turpin Is Making a Name for Herself on TikTok After Surviving Her Parents&#x27; &#x27;House of Horrors&#x27;</span></a><div class="trending__item__image__container"><img alt="Jordan Turpin Is Making a Name for Herself on TikTok After Surviving Her Parents&#x27; &#x27;House of Horrors&#x27;" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-01/012122_jordan_turpin_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">2</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Jordan Turpin Is Making a Name for Herself on TikTok After Surviving Her Parents&#x27; &#x27;House of Horrors&#x27;</p><a href="https://www.insideedition.com/inspirational" class="trending__item__text--kicker">Inspirational</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/florida-man-fights-bear-to-save-his-dog-nearly-snatched-from-his-porch-72728" class="trending__item__link"><span class="sr-only">Florida Man Fights Bear to Save His Dog Nearly Snatched From His Porch</span></a><div class="trending__item__image__container"><img alt="Florida Man Fights Bear to Save His Dog Nearly Snatched From His Porch" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-01/012122-bear-dog-1280x720.jpeg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">3</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Florida Man Fights Bear to Save His Dog Nearly Snatched From His Porch</p><a href="https://www.insideedition.com/animals" class="trending__item__text--kicker">Animals</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/as-arrest-is-made-in-killing-of-ashling-murphy-thousands-mourn-irish-school-teacher-slain-during" class="trending__item__link"><span class="sr-only">As Arrest Is Made in Killing of Ashling Murphy, Thousands Mourn Irish School Teacher Slain During Daytime Run</span></a><div class="trending__item__image__container"><img alt="As Arrest Is Made in Killing of Ashling Murphy, Thousands Mourn Irish School Teacher Slain During Daytime Run" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-01/ashling_murphy_ashling_murphy_facebook.jpeg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">4</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">As Arrest Is Made in Killing of Ashling Murphy, Thousands Mourn Irish School Teacher Slain During Daytime Run</p><a href="https://www.insideedition.com/human-interest" class="trending__item__text--kicker">Human Interest</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/baby-born-on-qatar-airways-flight-named-miracle-aisha-after-canadian-doctor-who-delivered-her-72711" class="trending__item__link"><span class="sr-only">Baby Born on Qatar Airways Flight Named &#x27;Miracle Aisha&#x27; After Canadian Doctor Who Delivered Her</span></a><div class="trending__item__image__container"><img alt="Baby Born on Qatar Airways Flight Named &#x27;Miracle Aisha&#x27; After Canadian Doctor Who Delivered Her" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2022-01/012122-baby-plane-1280x720.jpeg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">5</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Baby Born on Qatar Airways Flight Named &#x27;Miracle Aisha&#x27; After Canadian Doctor Who Delivered Her</p><a href="https://www.insideedition.com/health" class="trending__item__text--kicker">Health</a></div></div></div></div></div></div></div></div></div></main><footer class="footer dark"><div class="footer-container dark"><div class="footer-right"><ul class="social"><li><a aria-label="Visit Facebook" href="http://www.facebook.com/Inside.Edition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Twitter" href="http://twitter.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Instagram" href="https://instagram.com/insideedition/" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Youtube" href="https://www.youtube.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit RSS" href="https://www.insideedition.com/rss" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li></ul></div><div class="footer-menu-wrapper dark"><div class="footer-menu dark"><h4>About Us</h4><ul><li><a href="/meet-the-team" aria-label="Visit Meet the Team">Meet the Team</a></li><li><a href="/awards" aria-label="Visit Awards">Awards</a></li><li><a href="/contact" aria-label="Visit Contact">Contact</a></li></ul></div><div class="footer-menu dark"><h4>Connect</h4><ul><li><a href="https://www.facebook.com/Inside.Edition" aria-label="Visit Facebook" rel="noopener noreferrer" target="_blank">Facebook</a></li><li><a href="https://twitter.com/insideedition" aria-label="Visit Twitter" rel="noopener noreferrer" target="_blank">Twitter</a></li><li><a href="https://instagram.com/insideedition/" aria-label="Visit Instagram" rel="noopener noreferrer" target="_blank">Instagram</a></li><li><a href="https://www.youtube.com/insideedition" aria-label="Visit YouTube" rel="noopener noreferrer" target="_blank">YouTube</a></li><li><a href="/rss" aria-label="Visit RSS">RSS</a></li><li><a href="https://cbsinteractive.com/advertising/" aria-label="Visit Advertise with Us" rel="noopener noreferrer" target="_blank">Advertise with Us</a></li></ul></div><div class="footer-menu dark"><h4>Watch Inside Edition</h4><ul><li><a href="/showfinder" aria-label="Visit Local Listings">Local Listings</a></li><li><a href="/form/we-want-your-story-ideas" aria-label="Visit Submit a Story">Submit a Story</a></li></ul></div><div class="footer-menu dark"><h4>Sites We Love</h4><ul><li><a href="https://www.paramountplus.com?ftag=PPM-06-10aib3j" aria-label="Visit Paramount+" rel="noopener noreferrer" target="_blank">Paramount+</a></li><li><a href="https://www.cbsnews.com/" aria-label="Visit CBS News" rel="noopener noreferrer" target="_blank">CBS News</a></li><li><a href="https://www.etonline.com/" aria-label="Visit ETonline" rel="noopener noreferrer" target="_blank">ETonline</a></li><li><a href="https://www.thedrewbarrymoreshow.com/" aria-label="Visit The Drew Barrymore Show" rel="noopener noreferrer" target="_blank">The Drew Barrymore Show</a></li><li><a href="https://www.rachaelrayshow.com/" aria-label="Visit Rachael Ray Show" rel="noopener noreferrer" target="_blank">Rachael Ray Show</a></li><li><a href="https://www.dabl.com" aria-label="Visit DABL" rel="noopener noreferrer" target="_blank">DABL</a></li><li><a href="https://www.drphil.com" aria-label="Visit Dr. Phil" rel="noopener noreferrer" target="_blank">Dr. Phil</a></li><li><a href="https://www.startrek.com" aria-label="Visit Star Trek" rel="noopener noreferrer" target="_blank">Star Trek</a></li><li><a href="https://www.thedoctorstv.com" aria-label="Visit The Doctors" rel="noopener noreferrer" target="_blank">The Doctors</a></li><li><a href="https://www.last.fm/" aria-label="Visit Last.fm" rel="noopener noreferrer" target="_blank">Last.fm</a></li></ul></div></div><div class="footer-bottom dark"><a href="/" class="logo-greyscale"><div alt="Inside Edition"></div></a><div class="footer-copy"><a href="https://legalterms.cbsinteractive.com/terms-of-use" target="_blank" rel="noopener noreferrer">Terms of Use</a> |<a href="https://www.viacomcbsprivacy.com/policy" target="_blank" rel="noopener noreferrer"> Privacy Policy</a> |<a href="https://www.viacomcbsprivacy.com/cookies" target="_blank" rel="noopener noreferrer"> Cookies Policy</a> |<a href="http://www.cbs.com/closed-captioning/" target="_blank" rel="noopener noreferrer"> Closed Captioning</a> |<a href="https://www.viacomcbsprivacy.com/donotsell" target="_blank" rel="noopener noreferrer"> Do Not Sell My Personal Information</a> | In Partnership with <a href="http://www.etonline.com" target="_blank" rel="noopener noreferrer"> ETonline</a>.<span>CBS interactive &#169; 2022 Inside Edition Inc. All Rights Reserved.</span></div></div></div></footer></div></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>