<!DOCTYPE html><html lang="en"><head><link rel="apple-touch-icon" sizes="57x57" href="/img/favicons/apple-icon-57x57.png"/><link rel="apple-touch-icon" sizes="60x60" href="/img/favicons/apple-icon-60x60.png"/><link rel="apple-touch-icon" sizes="72x72" href="/img/favicons/apple-icon-72x72.png"/><link rel="apple-touch-icon" sizes="76x76" href="/img/favicons/apple-icon-76x76.png"/><link rel="apple-touch-icon" sizes="114x114" href="/img/favicons/apple-icon-114x114.png"/><link rel="apple-touch-icon" sizes="120x120" href="/img/favicons/apple-icon-120x120.png"/><link rel="apple-touch-icon" sizes="144x144" href="/img/favicons/apple-icon-144x144.png"/><link rel="apple-touch-icon" sizes="152x152" href="/img/favicons/apple-icon-152x152.png"/><link rel="apple-touch-icon" sizes="180x180" href="/img/favicons/apple-icon-180x180.png"/><link rel="icon" type="image/png" sizes="192x192" href="/img/favicons/android-icon-192x192.png"/><link rel="icon" type="image/png" sizes="32x32" href="/img/favicons/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="96x96" href="/img/favicons/favicon-96x96.png"/><link rel="icon" type="image/png" sizes="16x16" href="/img/favicons/favicon-16x16.png"/><link rel="manifest" crossorigin="use-credentials" href="/manifest.json"/><meta name="msapplication-TileImage" content="/img/favicons/ms-icon-144x144.png"/><link rel="preconnect" href="https://vidtech.cbsinteractive.com"/><link rel="preconnect" href="https://cdn.cookielaw.org"/><link rel="preconnect" href="https://www.insideedition.com"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/><meta http-equiv="content-language" content="en_US"/><meta property="fb:app_id" content="966341826790079"/><meta property="fb:admins" content="3111204"/><meta property="fb:pages" content="71728150722"/><meta property="og:site_name" content="Inside Edition"/><meta name="twitter:site" content="@insideedition"/><meta name="twitter:site:id" content="23603092"/><meta name="theme-color" content="#fd005b"/><meta name="msapplication-TileColor" content="#fd005b"/><script class="optanon-category-3" data-src="https://cdn.optimizely.com/js/18254496658.js" src="https://cdn.optimizely.com/js/18254496658.js" type="text/plain" defer=""></script><script>var utag_data = window.utag_data || {}; window.utag_data.isSPA = true;</script><script src="https://tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js" async=""></script><script src="//vidtech.cbsinteractive.com/cvp/1.2.0/cvp.all.min.js"></script><script src="//imasdk.googleapis.com/js/sdkloader/ima3.js" async=""></script><script>
                !function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var
                  d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();
              </script><script>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];cbsoptanon.onAdsReady(function(cmp, options) {console.log('Ads loaded, npa flag: ', options['npaFlag']);});
              </script><script src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js" async=""></script><script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charSet="UTF-8" data-domain-script="1e90d9ec-e15e-4932-a026-f218893ce26c" async=""></script><script async="" src="https://www.googletagmanager.com/gtag/js?id=AW-604815933"></script><script>
                window.dataLayer = window.dataLayer || [];
                function gtag(){dataLayer.push(arguments);}
                gtag('js', new Date());
                gtag('config', 'AW-604815933');
              </script><script>
                !function(f,b,e,v,n,t,s){
                  if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};
                  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];
                  t=b.createElement(e);
                  t.async=!0;
                  t.src=v;
                  t.setAttribute("class", "optanon-category-3");
                  t.setAttribute("data-src", v);
                  t.setAttribute("type", "text/plain");
                  s=b.getElementsByTagName(e)[0];
                  s.parentNode.insertBefore(t,s)}
                  (window,document,'script','https://connect.facebook.net/en_US/fbevents.js'); 
                  fbq('init', '1223619061322807'); fbq('track', 'PageView');
              </script><noscript><img alt="" height="1" width="1" src="https://www.facebook.com/tr?id=1223619061322807&amp;ev=PageView&amp;noscript=1"/></noscript><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><title>Falling Ice Kills One Climber, Injures Another at Alaska&#x27;s Denali National Park | Inside Edition</title><meta name="title" content="Falling Ice Kills One Climber, Injures Another at Alaska&#x27;s Denali National Park"/><link rel="canonical" href="https://www.insideedition.com/falling-ice-kills-one-climber-injures-another-at-alaskas-denali-national-park-66973"/><link rel="image_src" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-05/gettyimages-492370463.jpg?h=733c762c&amp;width=1280&amp;height=720"/><meta name="robots" content="index"/><meta name="description" content="Denali National Park is roughly 240 miles north of Anchorage. The region includes North America&#x27;s highest peak, Denali."/><meta property="og:description" content="Denali National Park is roughly 240 miles north of Anchorage. The region includes North America&#x27;s highest peak, Denali."/><meta property="og:title" content="Falling Ice Kills 32-Year-Old Climber in Alaska"/><meta property="og:type" content="Article"/><meta property="og:url" content="https://www.insideedition.com/falling-ice-kills-one-climber-injures-another-at-alaskas-denali-national-park-66973"/><meta property="og:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-05/gettyimages-492370463.jpg?h=733c762c&amp;width=1280&amp;height=720"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="Denali National Park is roughly 240 miles north of Anchorage. The region includes North America&#x27;s highest peak, Denali."/><meta name="twitter:title" content="Falling Ice Kills 32-Year-Old Climber in Alaska"/><meta name="twitter:url" content="https://www.insideedition.com/falling-ice-kills-one-climber-injures-another-at-alaskas-denali-national-park-66973"/><meta name="twitter:creator" content="@insideedition"/><meta name="twitter:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-05/gettyimages-492370463.jpg?h=733c762c&amp;width=1280&amp;height=720"/><meta name="twitter:image:width" content="1280"/><meta name="twitter:image:height" content="720"/><meta property="article:published_time" content="2021-05-15T12:43:07-0700"/><meta name="keywords" content="Inside Edition, News, News, alaska, idaho"/><link rel="amphtml" href="https://www.insideedition.com/falling-ice-kills-one-climber-injures-another-at-alaskas-denali-national-park-66973?amp"/><script type="application/ld+json">{"@context":"http://schema.org","articleSection":"News","dateModified":"2021-05-15T12:43:07-0700","headline":"Falling Ice Kills One Climber, Injures Another at Alaska's Denali National Park","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.insideedition.comfalling-ice-kills-one-climber-injures-another-at-alaskas-denali-national-park-66973"},"datePublished":"2021-05-15T12:43:07-0700","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}},"url":"https://www.insideedition.comfalling-ice-kills-one-climber-injures-another-at-alaskas-denali-national-park-66973","description":"Denali National Park is roughly 240 miles north of Anchorage. The region includes North America's highest peak, Denali.","keywords":["Inside Edition, News, News, alaska, idaho"],"image":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-05/gettyimages-492370463.jpg?h=733c762c","height":1080,"width":1920},"author":{"@type":"Person","name":"Inside Edition Staff"}}</script><meta name="next-head-count" content="27"/><link rel="preload" href="/_next/static/css/2e15dc70995d107d9ab2.css" as="style"/><link rel="stylesheet" href="/_next/static/css/2e15dc70995d107d9ab2.css" data-n-g=""/><noscript data-n-css=""></noscript><link rel="preload" href="/_next/static/chunks/framework-a9df3379397551bafe9f.js" as="script"/><link rel="preload" href="/_next/static/chunks/05d954cf.92676ad3b788a2272ab7.js" as="script"/><link rel="preload" href="/_next/static/chunks/2127-7108f4c6bbaa57c0aa58.js" as="script"/><link rel="preload" href="/_next/static/chunks/2121-c11590b5129adbf41b0b.js" as="script"/><link rel="preload" href="/_next/static/chunks/9617.1825be0bd321c18eb080.js" as="script"/><link rel="preload" href="/_next/static/chunks/2722.4e496c1701fdb5d22e92.js" as="script"/><link rel="preload" href="/_next/static/chunks/3911.2a0f025ac913a9a92bae.js" as="script"/><link rel="preload" href="/_next/static/chunks/1253.274619fa1fe116623357.js" as="script"/><link rel="preload" href="/_next/static/chunks/6084.cbb5d43f7f5ad2ab0b27.js" as="script"/><link rel="preload" href="/_next/static/chunks/6722.4d7c3bd5787bb0ca3637.js" as="script"/><link rel="preload" href="/_next/static/chunks/webpack-cb0e501590a19179169b.js" as="script"/><link rel="preload" href="/_next/static/chunks/framework-a9df3379397551bafe9f.js" as="script"/><link rel="preload" href="/_next/static/chunks/3138-d3ad3e0ab10ea0c3983b.js" as="script"/><link rel="preload" href="/_next/static/chunks/2633-afa7ec60e48fbb4c1dd1.js" as="script"/><link rel="preload" href="/_next/static/chunks/5778-163107443c1f7cb54147.js" as="script"/><link rel="preload" href="/_next/static/chunks/main-36e4a1cac15c18c642c8.js" as="script"/><link rel="preload" href="/_next/static/chunks/5927-fb6db3b5b122c4393903.js" as="script"/><link rel="preload" href="/_next/static/chunks/603-d1cf5dd3331baac7fc1c.js" as="script"/><link rel="preload" href="/_next/static/chunks/2234-2c82c0cf53af06e74b20.js" as="script"/><link rel="preload" href="/_next/static/chunks/pages/_app-807ddbd46235ad49a342.js" as="script"/><link rel="preload" href="/_next/static/chunks/2127-7108f4c6bbaa57c0aa58.js" as="script"/><link rel="preload" href="/_next/static/chunks/2121-c11590b5129adbf41b0b.js" as="script"/><link rel="preload" href="/_next/static/chunks/pages/%5B...alias%5D-1ddd2f6d76af6042d79c.js" as="script"/></head><body class="skybox-auto-collapse"><div id="__next"><div id="preload"><div><div class="dark"><div class="main-menu__sticky" style="top:0"><div class="header__wrapper"><div id="sticky-banner" class=""><div data-ad-ref="omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div><div data-ad-ref="mobile-omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div></div><header class="header affix-top dark" style="top:0px" id="header"><div class="header__container"><div class="header__column-1"><div class="header__logo_toggle_wrapper"><button type="button" class="header__menu-toggle header__menu-toggle--collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"><span class="sr-only">Toggle navigation</span></button><a class="header__logo" href="/" tabindex="-1"><img height="46" width="68" class="header__logo__image" alt="Inside Edition Logo" src="/img/logo.svg"/></a></div><div class="header__nav" style="display:none;transform:translateY(-100%) translateZ(0)"><ul class="main-menu"><li class="main-menu__item main-menu__item--submenu-closed"><a href="/news" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-label="News" aria-expanded="false" tabindex="-1">News</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/news" aria-label="Latest News">Latest News</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/crime" aria-label="Crime">Crime</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/politics" aria-label="Politics">Politics</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/health" aria-label="Health">Health</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/entertainment" aria-label="Entertainment">Entertainment</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/flashback" aria-label="Flashback">Flashback</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/royals" aria-label="Royals">Royals</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/coronavirus" aria-label="Coronavirus">Coronavirus</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/inspirational" aria-label="Inspirational">Inspirational</a></li></ul></li><li class="main-menu__item"><a href="/videos" class="main-menu__link" aria-label="Video">Video</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/investigative" class="main-menu__link" aria-label="Investigative">Investigative</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/category/the-issue" class="main-menu__link" aria-label="The Issue">The Issue</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/offbeat" class="main-menu__link" aria-label="Offbeat">Offbeat</a></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/more" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-label="More" aria-expanded="false" tabindex="-1">More</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/animals" aria-label="Animal Edition">Animal Edition</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/photos" aria-label="Photos">Photos</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/heroes" aria-label="Heroes">Heroes</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/in-depth" aria-label="Inside Edition InDepth">Inside Edition InDepth</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/sports" aria-label="Sports">Sports</a></li></ul></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/showfinder" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-label="Watch on TV" aria-expanded="false" tabindex="-1">Watch on TV</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/showfinder" aria-label="Local Listings">Local Listings</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/meet-the-team" aria-label="Meet the Team">Meet the Team</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/today-inside-edition" aria-label="Today on Inside Edition">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="header__column-2"><div class="header__search header__search--closed"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group"><label for="edit-keywords"><span class="sr-only">Search</span></label><input type="search" id="edit-keywords" class="header__search-form__input-keywords" value="" title="Enter the terms you wish to search for." placeholder="Search" name="keywords" size="15" maxLength="128" tabindex="-1"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><input type="hidden" data-drupal-selector="edit-search-block-form" name="form_id" value="search_block_form"/><div data-drupal-selector="edit-actions" class="header__search-form__actions" id="edit-actions"><button type="submit" class="header__search-form__actions__submit" name="op" value="" aria-hidden="true" tabindex="-1"></button></div></form></div><button type="button" class="header__search__close-button" aria-label="Close Search"></button><div class="header__social"><ul class="header__social-menu"><li class="header__social-menu__item"><a href="http://www.facebook.com/Inside.Edition" class="header__social-menu__link header__social-menu__link--facebook" tabindex="-1"><span class="sr-only">Facebook Inside Edition</span></a></li><li class="header__social-menu__item"><a href="http://twitter.com/insideedition" class="header__social-menu__link header__social-menu__link--twitter" tabindex="-1"><span class="sr-only">Twitter Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://instagram.com/insideedition/" class="header__social-menu__link header__social-menu__link--instagram" tabindex="-1"><span class="sr-only">Instagram Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://www.youtube.com/insideedition" class="header__social-menu__link header__social-menu__link--youtube" tabindex="-1"><span class="sr-only">YouTube Inside Edition</span></a></li></ul></div></div></div></header></div></div><div class="wrap-site"><main><div class="wrap-site"><div class="content"><div class="top-container"><h1 class="content__title">Falling Ice Kills One Climber, Injures Another at Alaska&#x27;s Denali National Park</h1><div class="cat-social-container"><div class="content__category"><a href="https://www.insideedition.com/news">News</a></div><div class="content__share"><div class="share"><button type="button" class="share__social-btn" aria-label="Share to Facebook"><div></div></button><button type="button" class="share__social-btn" aria-label="Share to Twitter"><div></div></button></div></div></div></div><div class="content__header-img centered"><div class="content__header-img-wrapper"><div class="content__header-img-wrap"><picture><source media="(max-width: 375px)" srcSet="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-05/gettyimages-492370463.jpg?h=733c762c&amp;width=375&amp;height=211"/><img src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-05/gettyimages-492370463.jpg?h=733c762c?width=1170&amp;height=658" alt="A general view of Mt. McKinley (top center) on May 17, 2014 in Denali National Park, Alaska." class="img-full " loading="eager"/></picture></div><div class="content__header-img-caption-wrap"><span class="content__header-image-credit">Getty Images</span></div></div></div><div class="site-bg"><div class="constrain constrain--bg"><div class="content__body"><div class="content__topborder"></div><div class="content__byline"><div class="content__byline-author">By <!-- -->Inside Edition Staff</div><div class="content__byline-date"><div>First Published: <!-- -->12:43 PM PDT, May 15, 2021</div></div></div><h2 class="content__subheading">Denali National Park is roughly 240 miles north of Anchorage. The region includes North America&#x27;s highest peak, Denali.</h2><div class="content__body-main"><div class="ctd-body"><div data-ad-ref="mobile-incontent-social" class="mobile-incontent-social bidbarrel-ad"></div><p>One climber was killed, and another injured in Denali National Park and Preserve in <a href="https://www.insideedition.com/tag/alaska" target="_blank">Alaska</a> earlier this week, according to a <a href="https://www.nps.gov/dena/learn/news/ice-debris-fatality-and-injury.htm" target="_blank">press</a> release. The two-person rope team was doing an early morning climb when a block of glacier ice dislodged from a peak and hit them.</p><p>A 31-year-old male from Logan, Utah, was the surviving climber. He was knocked unconscious by the impact but&nbsp;later regained consciousness. He then&nbsp;found his partner, a 32-year-old male from Rigby, <a href="https://www.insideedition.com/tag/idaho" target="_blank">Idaho</a>, only to discover that he had died in the accident.</p><div data-ad-ref="mobile-flex-plus-middle" class="bidbarrel-ad"></div><p>Despite significant injuries, the survivor was able to move outside of the debris zone until rescued.</p><p>After he alerted park officials using an InReach satellite communication device, rangers could locate him and evacuate him to a safe location so he could get emergency medical treatment. He was later taken by air ambulance to receive further medical care.</p><div data-ad-ref="mpu-flex-middle" class="bidbarrel-ad"></div><p>Afterward, the helicopter pilot and two mountaineering rangers attempted to return to the accident site, but clouds had moved into the area. Alaska News Source <a href="https://www.alaskasnewssource.com/2021/05/14/1-dead-1-injured-by-falling-ice-debris-at-denali-national-park/" target="_blank">adds</a> that the National Park Service announced that they were later able to recover the climber&rsquo;s remains.</p><p>According to <a href="https://www.cnn.com/2021/05/15/us/denali-national-park-climber-glacier-death-trnd/index.html" target="_blank">CNN</a>, Denali National Park and Preserve is roughly 240 miles north of Anchorage. The region includes North America's highest peak, Denali.</p><h2>Related Stories</h2><div class="shortcode-speedbump"><a href="https://www.insideedition.com/snowmobiler-dies-after-falling-900-feet-as-ice-shelf-breaks-on-california-cliffs-causing-avalanche" target="_self" rel="noopener noreferrer">Snowmobiler Dies After Falling 900 Feet as Ice Shelf Breaks on California Cliffs, Causing Avalanche</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/is-it-safe-to-drink-melted-snow-65060" target="_self" rel="noopener noreferrer">Is It Safe to Drink Melted Snow?</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/single-mom-and-nurse-killed-after-being-struck-by-snowplow-outside-new-york-hospital-where-she" target="_self" rel="noopener noreferrer">Single Mom and Nurse Killed After Being Struck by Snowplow Outside New York Hospital Where She Worked</a></div><div class="shortcode-video"><div class="related-links"><a class="title" href="/media/videos/daring-snow-runners-in-finland-forgo-shoes-for-only-wool-socks-64947">Daring Snow Runners in Finland Forgo Shoes for Only Wool Socks</a><a href="/offbeat" class="category">Offbeat</a></div></div></div></div><div class="content__spacer"></div><div class="content__tags"><h3>Tags:</h3><ul><li class=""><a href="https://www.insideedition.com/tag/alaska " aria-label="Visit alaska">alaska</a></li><li class=""><a href="https://www.insideedition.com/tag/idaho " aria-label="Visit idaho">idaho</a></li></ul></div><div class="content__spacer"></div><div class="right-rail"><div style="top:0"><div class="right-rail__content "><div data-ad-ref="mpu-plus-top" class="bidbarrel-ad"></div></div></div></div></div><div id="taboola-below-article-thumbnails"></div><div class="content__trending"><div class="trending"><h2 class="trending__block-title">Trending on Inside Edition</h2><div class="trending__items"><div class="trending__item"><a href="https://www.insideedition.com/texas-man-found-dead-with-neck-wound-after-freak-car-crash-had-been-bitten-by-dog-possibly-trying" class="trending__item__link"><span class="sr-only">Texas Man Found Dead With Neck Wound After Freak Car Crash Had Been Bitten by Dog Possibly Trying to Save Him</span></a><div class="trending__item__image__container"><img alt="Texas Man Found Dead With Neck Wound After Freak Car Crash Had Been Bitten by Dog Possibly Trying to Save Him" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-05/hewittew-site-size1280x720_1-recovered.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">1</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Texas Man Found Dead With Neck Wound After Freak Car Crash Had Been Bitten by Dog Possibly Trying to Save Him</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/youve-been-vaccinated-now-what-where-to-buy-your-own-covid-19-vaccine-card-holder-66914" class="trending__item__link"><span class="sr-only">You&#x27;ve Been Vaccinated. Now What? Where to Buy Your Own COVID-19 Vaccine Card Holder</span></a><div class="trending__item__image__container"><img alt="You&#x27;ve Been Vaccinated. Now What? Where to Buy Your Own COVID-19 Vaccine Card Holder" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-05/gettyimages-1303706874.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">2</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">You&#x27;ve Been Vaccinated. Now What? Where to Buy Your Own COVID-19 Vaccine Card Holder</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/teen-accused-of-killing-tristyn-bailey-had-evidence-in-his-home-linking-him-to-cold-blooded-murder" class="trending__item__link"><span class="sr-only">Teen Accused of Killing Tristyn Bailey Had Evidence in His Home Linking Him to &#x27;Cold-Blooded Murder,’ Cops Say</span></a><div class="trending__item__image__container"><img alt="Teen Accused of Killing Tristyn Bailey Had Evidence in His Home Linking Him to &#x27;Cold-Blooded Murder,’ Cops Say" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-05/051121-tristyn-bailey-1280x720.jpeg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">3</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Teen Accused of Killing Tristyn Bailey Had Evidence in His Home Linking Him to &#x27;Cold-Blooded Murder,’ Cops Say</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/viola-fletcher-oldest-known-survivor-of-tulsa-race-massacre-celebrates-107th-birthday-66923" class="trending__item__link"><span class="sr-only">Viola Fletcher, Oldest Known Survivor of Tulsa Race Massacre, Celebrates 107th Birthday</span></a><div class="trending__item__image__container"><img alt="Viola Fletcher, Oldest Known Survivor of Tulsa Race Massacre, Celebrates 107th Birthday" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-05/violanew-site-size1280x720_1-recovered.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">4</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Viola Fletcher, Oldest Known Survivor of Tulsa Race Massacre, Celebrates 107th Birthday</p><a href="https://www.insideedition.com/inspirational" class="trending__item__text--kicker">Inspirational</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/survivors-of-deck-collapse-caught-on-camera-at-rental-home-allege-decks-wood-was-rotted-66911" class="trending__item__link"><span class="sr-only">Survivors of Deck Collapse Caught on Camera at Rental Home Allege Deck&#x27;s Wood Was Rotted</span></a><div class="trending__item__image__container"><img alt="Survivors of Deck Collapse Caught on Camera at Rental Home Allege Deck&#x27;s Wood Was Rotted" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-05/051321_deck_collapse_party_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">5</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Survivors of Deck Collapse Caught on Camera at Rental Home Allege Deck&#x27;s Wood Was Rotted</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div></div></div></div></div></div></div></div></main><footer class="footer dark"><div class="footer-container dark"><div class="footer-right"><ul class="social"><li><a aria-label="Visit Facebook" href="http://www.facebook.com/Inside.Edition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Twitter" href="http://twitter.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Instagram" href="https://instagram.com/insideedition/" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Youtube" href="https://www.youtube.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit RSS" href="https://www.insideedition.com/rss" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li></ul></div><div class="footer-menu-wrapper dark"><div class="footer-menu dark"><h4>About Us</h4><ul><li><a href="/meet-the-team" aria-label="Visit Meet the Team">Meet the Team</a></li><li><a href="/awards" aria-label="Visit Awards">Awards</a></li><li><a href="/contact" aria-label="Visit Contact">Contact</a></li></ul></div><div class="footer-menu dark"><h4>Connect</h4><ul><li><a href="https://www.facebook.com/Inside.Edition" aria-label="Visit Facebook" rel="noopener noreferrer" target="_blank">Facebook</a></li><li><a href="https://twitter.com/insideedition" aria-label="Visit Twitter" rel="noopener noreferrer" target="_blank">Twitter</a></li><li><a href="https://instagram.com/insideedition/" aria-label="Visit Instagram" rel="noopener noreferrer" target="_blank">Instagram</a></li><li><a href="https://plus.google.com/104304424115513428440" aria-label="Visit Google+" rel="noopener noreferrer" target="_blank">Google+</a></li><li><a href="https://www.youtube.com/insideedition" aria-label="Visit YouTube" rel="noopener noreferrer" target="_blank">YouTube</a></li><li><a href="/rss" aria-label="Visit RSS">RSS</a></li><li><a href="https://cbsinteractive.com/advertising/" aria-label="Visit Advertise with Us" rel="noopener noreferrer" target="_blank">Advertise with Us</a></li></ul></div><div class="footer-menu dark"><h4>Watch Inside Edition</h4><ul><li><a href="/showfinder" aria-label="Visit Local Listings">Local Listings</a></li><li><a href="/form/we-want-your-story-ideas" aria-label="Visit Submit a Story">Submit a Story</a></li></ul></div><div class="footer-menu dark"><h4>Sites We Love</h4><ul><li><a href="https://www.paramountplus.com" aria-label="Visit Paramount+" rel="noopener noreferrer" target="_blank">Paramount+</a></li><li><a href="https://www.cbsnews.com/" aria-label="Visit CBS News" rel="noopener noreferrer" target="_blank">CBS News</a></li><li><a href="https://www.etonline.com/" aria-label="Visit ETonline" rel="noopener noreferrer" target="_blank">ETonline</a></li><li><a href="https://www.thedrewbarrymoreshow.com/" aria-label="Visit The Drew Barrymore Show" rel="noopener noreferrer" target="_blank">The Drew Barrymore Show</a></li><li><a href="https://www.rachaelrayshow.com/" aria-label="Visit Rachael Ray Show" rel="noopener noreferrer" target="_blank">Rachael Ray Show</a></li><li><a href="https://www.dabl.com" aria-label="Visit DABL" rel="noopener noreferrer" target="_blank">DABL</a></li><li><a href="https://www.drphil.com" aria-label="Visit Dr. Phil" rel="noopener noreferrer" target="_blank">Dr. Phil</a></li><li><a href="https://www.startrek.com" aria-label="Visit Star Trek" rel="noopener noreferrer" target="_blank">Star Trek</a></li><li><a href="https://www.thedoctorstv.com" aria-label="Visit The Doctors" rel="noopener noreferrer" target="_blank">The Doctors</a></li><li><a href="https://www.last.fm/" aria-label="Visit Last.fm" rel="noopener noreferrer" target="_blank">Last.fm</a></li></ul></div></div><div class="footer-bottom dark"><a href="/" class="logo-greyscale"><div alt="Inside Edition"></div></a><div class="footer-copy"><a href="https://legalterms.cbsinteractive.com/terms-of-use" target="_blank" rel="noopener noreferrer">Terms of Use</a> |<a href="https://legalterms.cbsinteractive.com/privacy" target="_blank" rel="noopener noreferrer"> Privacy Policy</a> |<a href="https://legalterms.cbsinteractive.com/eula" target="_blank" rel="noopener noreferrer"> Mobile User Agreement</a> |<a href="http://www.cbs.com/closed-captioning/" target="_blank" rel="noopener noreferrer"> Closed Captioning</a> |<a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/video-services-and-social-networking" target="_blank" rel="noopener noreferrer"> Video Services Policy</a> |<a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/third-party-online-advertising" target="_blank" rel="noopener noreferrer"> Ad Choices</a> |<a href="https://ca.privacy.cbs" target="_blank" rel="noopener noreferrer"> California Privacy/Info We Collect</a> |<a href="https://ca.privacy.cbs/donotsell" target="_blank" rel="noopener noreferrer"> California Do Not Sell My Info</a> | In Partnership with <a href="http://www.etonline.com" target="_blank" rel="noopener noreferrer"> ETonline</a>.<span>CBS interactive &#169; 2021 Inside Edition Inc. All Rights Reserved.</span></div></div></div></footer></div></div></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script><script nomodule="" src="/_next/static/chunks/polyfills-dba3e76732a807a91d11.js"></script><script async="" src="/_next/static/chunks/05d954cf.92676ad3b788a2272ab7.js"></script><script async="" src="/_next/static/chunks/9617.1825be0bd321c18eb080.js"></script><script async="" src="/_next/static/chunks/2722.4e496c1701fdb5d22e92.js"></script><script async="" src="/_next/static/chunks/3911.2a0f025ac913a9a92bae.js"></script><script async="" src="/_next/static/chunks/1253.274619fa1fe116623357.js"></script><script async="" src="/_next/static/chunks/6084.cbb5d43f7f5ad2ab0b27.js"></script><script async="" src="/_next/static/chunks/6722.4d7c3bd5787bb0ca3637.js"></script><script src="/_next/static/chunks/webpack-cb0e501590a19179169b.js" async=""></script><script src="/_next/static/chunks/framework-a9df3379397551bafe9f.js" async=""></script><script src="/_next/static/chunks/3138-d3ad3e0ab10ea0c3983b.js" async=""></script><script src="/_next/static/chunks/2633-afa7ec60e48fbb4c1dd1.js" async=""></script><script src="/_next/static/chunks/5778-163107443c1f7cb54147.js" async=""></script><script src="/_next/static/chunks/main-36e4a1cac15c18c642c8.js" async=""></script><script src="/_next/static/chunks/5927-fb6db3b5b122c4393903.js" async=""></script><script src="/_next/static/chunks/603-d1cf5dd3331baac7fc1c.js" async=""></script><script src="/_next/static/chunks/2234-2c82c0cf53af06e74b20.js" async=""></script><script src="/_next/static/chunks/pages/_app-807ddbd46235ad49a342.js" async=""></script><script src="/_next/static/chunks/2127-7108f4c6bbaa57c0aa58.js" async=""></script><script src="/_next/static/chunks/2121-c11590b5129adbf41b0b.js" async=""></script><script src="/_next/static/chunks/pages/%5B...alias%5D-1ddd2f6d76af6042d79c.js" async=""></script><script src="/_next/static/insideedition/_buildManifest.js" async=""></script><script src="/_next/static/insideedition/_ssgManifest.js" async=""></script></body></html>