<!DOCTYPE html><html lang="en" dir="ltr" prefix="og: http://ogp.me/ns#"><head><meta charset="utf-8" /><meta name="title" content="Man Killed by Former Girlfriend&#039;s Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say | Inside Edition" /><link rel="canonical" href="https://www.insideedition.com/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex" /><meta property="fb:admins" content="3111204" /><meta property="fb:pages" content="71728150722" /><meta property="og:site_name" content="Inside Edition" /><meta http-equiv="content-language" content="en_US" /><meta name="robots" content="index" /><meta name="twitter:card" content="summary_large_image" /><meta name="description" content="A man broke into his former girlfriend&#039;s home in Pasadena and started attacking her until the woman&#039;s mother and sister stepped in and fatally attacked him with a golf club and kitchen knife, Los Angeles County Sheriff&#039;s Department said." /><meta property="fb:app_id" content="966341826790079" /><meta name="twitter:title" content="Man Killed by Former Girlfriend&#039;s Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say" /><meta name="twitter:description" content="A man broke into his former girlfriend&#039;s home in Pasadena and started attacking her until the woman&#039;s mother and sister stepped in and fatally attacked him with a golf club and kitchen knife, Los Angeles County Sheriff&#039;s Department said." /><meta property="og:type" content="Article" /><meta name="twitter:site" content="@insideedition" /><meta name="msvalidate.01" content="DC10472F438B55F3A58638BC31271706" /><meta property="og:url" content="https://www.insideedition.com/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex" /><meta name="twitter:site:id" content="23603092" /><link rel="image_src" href="https://www.insideedition.com/sites/default/files/images/2020-11/policetape1280x720_5.jpg" /><meta name="google-site-verification" content="HcuSVZXpTET14VOTW9-qT-hRmaCgONCR_xaBkjDRGSE" /><meta name="keywords" content="Crime, News" /><meta property="og:title" content="Man Killed by Former Girlfriend&#039;s Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say" /><meta name="referrer" content="origin" /><link rel="publisher" href="http://plus.google.com/104304424115513428440" /><meta property="og:description" content="A man broke into his former girlfriend&#039;s home in Pasadena and started attacking her until the woman&#039;s mother and sister stepped in and fatally attacked him with a golf club and kitchen knife, Los Angeles County Sheriff&#039;s Department said." /><meta name="twitter:url" content="https://www.insideedition.com/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex" /><meta name="twitter:image" content="https://www.insideedition.com/sites/default/files/images/2020-11/policetape1280x720_5.jpg" /><meta property="og:image" content="https://www.insideedition.com/sites/default/files/images/2020-11/policetape1280x720_5.jpg" /><meta property="og:image:width" content="1280" /><meta property="og:image:height" content="720" /><meta property="article:published_time" content="2020-11-30T14:02:31-08:00" /><meta name="Generator" content="Drupal 8 (https://www.drupal.org)" /><meta name="MobileOptimized" content="width" /><meta name="HandheldFriendly" content="true" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","image":{"@type":"ImageObject","url":"https:\/\/www.insideedition.com\/sites\/default\/files\/images\/2020-11\/policetape1280x720_5.jpg","height":720,"width":1280},"headline":"Man Killed by Former Girlfriend's Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.insideedition.com\/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex"},"datePublished":"2020-11-30T14:02:31-08:00","dateModified":"2020-11-30T14:02:31-08:00","articleSection":"News","description":"A man broke into his former girlfriend's home in Pasadena and started attacking her until the woman's mother and sister stepped in and fatally attacked him with a golf club and kitchen knife, Los Angeles County Sheriff's Department said.","keywords":["Crime","News"],"@type":"NewsArticle","author":{"@type":"Person","name":"ANABEL SOSA"},"publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https:\/\/www.insideedition.com\/themes\/custom\/iebs\/logo.png"}},"url":"https:\/\/www.insideedition.com\/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex"}</script><script type="text/javascript" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="1e90d9ec-e15e-4932-a026-f218893ce26c"></script><script type="text/javascript" src="//production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js" id="bb-cbsoptanon"></script><script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();
</script><link rel="shortcut icon" href="/themes/custom/iebs/favicon.ico" type="image/vnd.microsoft.icon" /><link rel="revision" href="https://www.insideedition.com/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex" /><link rel="amphtml" href="https://www.insideedition.com/man-killed-by-former-girlfriends-mother-and-sister-after-he-broke-into-their-home-to-attack-ex?amp" /><title>Man Killed by Former Girlfriend&#039;s Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say | Inside Edition</title><link rel="stylesheet" media="all" href="/sites/default/files/css/css_t7AYp7JtmW7t8Tr7r5RIXoR6Z8kHZFn1Qc1ywtoKmLY.css?qkkinh" /><link rel="stylesheet" media="all" href="/sites/default/files/css/css_9nO3Le2n0DvDcumCbBOpuormMVnJGlzjFx7yK90u5mY.css?qkkinh" /><script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/63385","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ajaxPageState":{"libraries":"bootstrap\/popover,bootstrap\/tooltip,core\/html5shiv,ctd_bidbarrel\/bidbarrel,ctd_bidbarrel\/uvp_ads,ctd_media_net\/ctd_media_net,ctd_sourcepoint\/ctd_sourcepoint,ctd_taboola\/ctd_taboola,ctd_tealium\/uvp_tracking,ctd_uvp\/players,fastly\/fastly,iebs\/bootstrap-scripts,iebs\/global-scripts,iebs\/global-styling,iebs\/iebs-affix,iebs\/iebs-header-affix,iebs\/iebs-sticky-sidebar,iebs\/post-global-scripts,iebs\/sharethispickerexternalbuttons,iebs\/sharethispickerexternalbuttonsws,iebs\/ui-search,sharethis\/sharethis,system\/base,views\/views.module","theme":"iebs","theme_token":null},"ajaxTrustedUrl":{"\/search":true},"ctdBidBarrel":{"scriptUrl":"https:\/\/at.cbsi.com\/lib\/dist\/prod\/bidbarrel-insideedition.min.js","networkId":"8264","adUnitSizePrefix":"aw-insideedition","mobileAdUnitSizePrefix":"maw-insideedition","pageType":"article","adSelector":".bidbarrel-ad","mapToAdUnits":{"skybox-top":{"mobile":"mobile-skybox-top","tablet":"skybox-top","desktop":"skybox-top"},"leader-plus-top":{"mobile":"mobile-banner-plus-top","tablet":"leader-top","desktop":"leader-plus-top"},"native-top":{"mobile":"mobile-native-top","tablet":"native-top","desktop":"native-top","alt":{"home":{"mobile":"mobile-native-home-top","tablet":"native-home-top","desktop":"native-home-top"},"article":{"mobile":"mobile-native-article-top","tablet":"native-article-top","desktop":"native-article-top"},"video":{"mobile":"mobile-native-video-top","tablet":"native-video-top","desktop":"native-video-top"},"taxonomy":{"mobile":"mobile-native-section-top","tablet":"native-section-top","desktop":"native-section-top"},"slideshow":{"mobile":"mobile-native-gallery-top","tablet":"native-gallery-top","desktop":"native-gallery-top"}}},"mpu-plus-top":{"mobile":"mobile-banner-plus-middle","tablet":"mpu-top","desktop":"mpu-plus-top"},"mpu-bottom":{"mobile":"mobile-banner-plus-bottom","tablet":"mpu-bottom","desktop":"mpu-bottom"},"leader-plus-bottom":{"mobile":"mobile-banner-plus-bottom","tablet":"leader-bottom","desktop":"leader-plus-bottom"},"omni-intromercial":{"mobile":"omni-intromercial","tablet":"omni-intromercial","desktop":"omni-intromercial"}},"debug":false,"useAlt":"article","page_targeting":{"nid":"63385","keywords":[],"category":"crime","categories":["crime","news"],"ad_page_type":"article","ad_unit_path_suffix":"crime\/article","env":null}},"taboolaScriptUrl":"\/\/cdn.taboola.com\/libtrc\/cbsinteractive-insideedition\/loader.js","bootstrap":{"forms_has_error_value_toggle":1,"modal_animation":1,"modal_backdrop":"true","modal_keyboard":1,"modal_show":1,"modal_size":"","popover_enabled":1,"popover_animation":1,"popover_container":"body","popover_content":"","popover_delay":"0","popover_html":0,"popover_placement":"right","popover_selector":"","popover_title":"","popover_trigger":"click","popover_trigger_autoclose":1,"tooltip_enabled":1,"tooltip_animation":1,"tooltip_container":"body","tooltip_delay":"0","tooltip_html":0,"tooltip_placement":"auto left","tooltip_selector":"","tooltip_trigger":"hover"},"ctd_tealium_url":"\/\/tags.tiqcdn.com\/utag\/cbsi\/insideeditionsite\/prod\/utag.js","enable_vtg_tracker":null,"sharethis":{"switchTo5x":true,"__st_loadLate":true,"stlight":{"publisher":"dr-c188cc5e-3f0f-2556-e3bd-410bbc0a9ff8","version":"5x","doNotCopy":true,"hashAddressBar":false,"doNotHash":true,"popup":true}},"taboola_page_type":"article","taboola_container":"taboola-below-article-thumbnails","taboola_mode":"thumbnails-a","taboola_placement":"Below Article Thumbnails","user":{"uid":0,"permissionsHash":"f30863c952c49aefca9d0afb9300cadf0deceecea706b723c7bb2229d823c3e3"}}</script><!--[if lte IE 8]><script src="/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script><![endif]--><script src="/sites/default/files/js/js_Jy7B-rhcOV41wP9RRCLoNf76Du5B3LVJXLnhZxxUmuU.js"></script><script src="/modules/contrib/ctd_taboola/js/ctd-taboola.js?qkkinh" type="text/plain" class="optanon-category-4"></script><script src="//tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js"></script><script src="https://imasdk.googleapis.com/js/sdkloader/ima3.js"></script><bidbarrel-placeholder token="llmHIg-lmmkb0OCHn0O57v9LNWRGuZcamkzIZXbdnDGKdZd0RNMSc8LDvbflGmvJ6ry1p1j1fQ"></head><body class="path-node page-node-type-article has-glyphicons"><script>
var utag_data = {"assetPubDate":"2020-11-30T22:02:31","assetType":"content_article","assetTitle":"Man Killed by Former Girlfriend's Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say","assetId":"63385","authorId":"3190","authorName":"(62110)","videoAutoPlay":"off","videoExists":"true","siteSection":"crime","pageType":"article","gaAccount":"UA-1072526-1","siteHier":"crime|article","userState":"not authenticated","userType":"anon"};
utag_data.pageViewGuid = ctdTealium.viewGuid;
utag_data.deviceType = (ctdTealium.isMobile == false) ? 'desktop' : 'mobile';
utag_data.campaign = ctdTealium.campaign;
// Support legacy Brightcove video plugin.
site.section = utag_data.siteSection || '';
if (typeof utag_data['videoAutoPlay'] !== 'undefined' && utag_data['videoAutoPlay']) {
utag_data['videoAutoPlay'] = (ctdTealium.isMobile === false) ? utag_data['videoAutoPlay'] : false;
}
</script><div class="header-padding-offset"> <a href="#main-content" class="visually-hidden focusable skip-link"> Skip to main content </a><div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas><div id="flex-header" class="flex-ad flex-header"><div data-ad-ref="skybox-top" class="skybox-top bidbarrel-ad"></div></div><header class="main-header" role="banner" data-spy="affix"><div class="container main-header-container"><div class="row main-header-row"><div class="col-sm-12"><div class="row"><div id="menu-logo-wrapper" class="logo col-sm-2 col-md-1"><div id="menu-btn"> <button type="button" class="menu-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"> <span class="sr-only">Toggle navigation</span> </button></div> <span id="menu-logo"> <a href="https://www.insideedition.com/"> <img class="menu-logo" src="/themes/custom/iebs/logo.svg" alt="Inside Edition Homepage"> </a> </span></div><div id="navbar" class="navbar-collapse collapse"><div class="navbar-header"><ul class="menu nav navbar-nav"><li class="expanded dropdown menu-link-content-37899cb6-f020-4c35-a84c-f1bd06d2458b"> <a href="/news" class="dropdown-toggle" data-toggle="dropdown" aria-label="News" aria-expanded="false">News</a><ul class="menu dropdown-menu"><li class="menu-link-content-7061d623-efb3-4cd1-8d63-b19c99f34967"> <a href="/news" aria-label="Latest News" data-drupal-link-system-path="taxonomy/term/6">Latest News</a></li><li class="menu-link-content-77fd5e4d-1b09-4e9a-b9ef-7f2cd3f6c27c"> <a href="/crime" aria-label="Crime" data-drupal-link-system-path="taxonomy/term/4">Crime</a></li><li class="menu-link-content-7eb81050-aa78-4e0d-b642-850f6cbebe2b"> <a href="/politics" aria-label="Politics" data-drupal-link-system-path="taxonomy/term/5">Politics</a></li><li class="menu-link-content-6298b762-56b4-40bb-9f8a-fde76e0f2f1a"> <a href="/health" aria-label="Health" data-drupal-link-system-path="taxonomy/term/7">Health</a></li><li class="menu-link-content-7162b157-b550-48ee-b28f-757f83c75984"> <a href="/entertainment" aria-label="Entertainment" data-drupal-link-system-path="taxonomy/term/1">Entertainment</a></li><li class="menu-link-content-770e30c5-be12-4619-a77f-def704366867"> <a href="/flashback" aria-label="Flashback" data-drupal-link-system-path="taxonomy/term/46185">Flashback</a></li><li class="menu-link-content-436e839c-444f-4d13-93ff-61a45a531adc"> <a href="/royals" aria-label="Royals" data-drupal-link-system-path="taxonomy/term/45299">Royals</a></li><li class="menu-link-content-5afa2959-f45b-4045-babb-0209cc9aad3d"> <a href="/tag/coronavirus" aria-label="Coronavirus" data-drupal-link-system-path="taxonomy/term/46874">Coronavirus</a></li><li class="menu-link-content-a57cbb7f-4639-45d2-85fd-10e7b1306abd"> <a href="/inspirational" aria-label="Inspirational" data-drupal-link-system-path="taxonomy/term/9">Inspirational</a></li></ul></li><li class="menu-link-visible menu-link-content-7f1c4464-33be-4d36-8824-e6de94189c64"> <a href="/videos" aria-label="Video" data-drupal-link-system-path="videos">Video</a></li><li class="menu-link-content-890af9c5-f9d2-4c05-a66a-f97218aed59f"> <a href="/investigative" aria-label="Investigative" data-drupal-link-system-path="taxonomy/term/2">Investigative</a></li><li class="menu-link-content-c168893a-aad5-4aa3-8526-70bf48c08077"> <a href="/category/the-issue" aria-label="The Issue">The Issue</a></li><li class="menu-link-content-cbf524ed-b8ff-4358-b4fa-8924b66a98e0"> <a href="/offbeat" aria-label="Offbeat" data-drupal-link-system-path="taxonomy/term/10">Offbeat</a></li><li class="expanded dropdown views-view-views-section-pages-section-more"> <a href="/more" class="dropdown-toggle" data-toggle="dropdown" aria-label="More" aria-expanded="false">More</a><ul class="menu dropdown-menu"><li class="menu-link-content-d8d15c78-7c89-40f4-b0be-b0756eccba3b"> <a href="/animals" aria-label="Animal Edition" data-drupal-link-system-path="taxonomy/term/11">Animal Edition</a></li><li class="views-view-views-section-pages-section-photos"> <a href="/photos" aria-label="Photos" data-drupal-link-system-path="photos">Photos</a></li><li class="menu-link-content-bee89807-436d-4c69-94dd-0ed39c40d38b"> <a href="/heroes" aria-label="Heroes" data-drupal-link-system-path="taxonomy/term/46711">Heroes</a></li><li class="menu-link-content-0801d8a7-8ebd-4869-9274-cad32913c92b"> <a href="/in-depth" aria-label="Inside Edition InDepth" data-drupal-link-system-path="taxonomy/term/8">Inside Edition InDepth</a></li><li class="menu-link-content-aaf47f72-012e-4d8d-9501-1cdf5e64f245"> <a href="/sports" aria-label="Sports" data-drupal-link-system-path="taxonomy/term/45562">Sports</a></li></ul></li><li class="expanded dropdown menu-link-content-cc557156-fd42-4305-991a-a8cd967ddcba"> <a href="/showfinder" class="dropdown-toggle" data-toggle="dropdown" aria-label="Watch on TV" aria-expanded="false">Watch on TV</a><ul class="menu dropdown-menu"><li class="menu-link-content-12feafda-166a-4569-9d85-cb03a64964bc"> <a href="/showfinder" aria-label="Local Listings" data-drupal-link-system-path="showfinder">Local Listings</a></li><li class="menu-link-content-46759da3-82b9-4257-8f9e-0b2a5777df80"> <a href="/meet-the-team" aria-label="Meet the Team" data-drupal-link-system-path="meet-the-team">Meet the Team</a></li><li class="menu-link-content-90756a3e-d4c0-4958-812e-494f4425ad16"> <a href="/tag/today-inside-edition" aria-label="Today on Inside Edition" data-drupal-link-system-path="taxonomy/term/46643">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="search-header pull-right"><div class="block-ie-search"><div class="search"> <section class="block block-gcs-search block-gcs-search__search-form-block clearfix"><form class="search-block-form" data-drupal-selector="search-block-form" action="/search" method="get" id="search-block-form" accept-charset="UTF-8"><div class="form-item js-form-item form-type-search js-form-type-search form-item-keywords js-form-item-keywords form-no-label form-group"> <label for="edit-keywords" aria-hidden="true" aria-label=" " class="control-label sr-only">Search</label> <input title="Enter the terms you wish to search for." data-drupal-selector="edit-keywords" class="form-search form-control" placeholder="Search" type="search" id="edit-keywords" name="keywords" value="" size="15" maxlength="128" /><div id="edit-keywords--description" class="description help-block"> Enter the terms you wish to search for.</div></div><input autocomplete="off" data-drupal-selector="form-vj8gnzbqly3ojivibbdc-258vxjtfvoi3cn0mypqbye" type="hidden" name="form_build_id" value="form-Vj8gnZbqLY3OjiVIBBDc_258VxjTfVOI3cn0mYPQbyE" /><input data-drupal-selector="edit-search-block-form" type="hidden" name="form_id" value="search_block_form" /><div data-drupal-selector="edit-actions" class="form-actions form-group js-form-wrapper form-wrapper" id="edit-actions"><button data-drupal-selector="edit-go" class="button js-form-submit form-submit btn-default btn" type="submit" id="edit-go" name="op" value="" aria-hidden="true" tabindex="-1"></button></div></form> </section> <span class="sb-icon-search"><span class="icon-search"></span></span></div></div> <span class="sb-icon-close"><button class="close-search" aria-label="Close Search"></button></span><div class="block-ie-social hidden-xs"> <section class="block block-ie block-social-block clearfix"><ul class="social-block-content"><li><a href="http://www.facebook.com/Inside.Edition" class="icon icon-facebook" aria-label="Facebook Inside Edition"></a></li><li><a href="http://twitter.com/insideedition" class="icon icon-twitter" aria-label="Twitter Inside Edition"></a></li><li><a href="https://instagram.com/insideedition/" class="icon icon-instagram" aria-label="Instagram Inside Edition"></a></li><li><a href="https://www.youtube.com/insideedition" class="icon icon-youtube" aria-label="YouTube Inside Edition"></a></li><li><a href="/rss" class="icon icon-rss" aria-label="RSS Inside Edition"></a></li></ul> </section></div></div><div class="header-social"><ul class="header-social-share"><li class="header-social-share-item"> <span class="button button--share button--share-facebook st_facebook_custom"> <img alt="Facebook" class="icon icon-facebook" src="/themes/custom/iebs/images/sharethis/facebook.svg"> </span></li><li class="header-social-share-item"> <span class="button button--share button--share-twitter st_twitter_custom"> <img alt="Twitter" class="icon icon-twitter" src="/themes/custom/iebs/images/sharethis/twitter.svg"> </span></li><li class="header-social-share-item"> <span class="button button--share button--share-whatsapp st_whatsapp_custom"> <img alt="Whatsapp" class="icon icon-whatsapp" src="/themes/custom/iebs/images/sharethis/whatsapp.svg"> </span></li><li class="header-social-share-item"> <span class="button button--share button--share-reddit st_reddit_custom"> <img alt="Reddit" class="icon icon-reddit" src="/themes/custom/iebs/images/sharethis/reddit.svg"> </span></li></ul></div></div></div></div></div></header><div class="page-skin-container"><div role="main" class="main-container container js-quickedit-main-content"><div class="article-header visible-xs-block"><h1 class="page-header"> Man Killed by Former Girlfriend&#039;s Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say</h1><div class="article-meta"> <span class="category"> <a href="/crime">Crime</a> </span> <span class="publish-details"> 2:02 PM PST, November 30, 2020 - <a href="/bios/anabel-sosa" hreflang="en">ANABEL SOSA</a> </span></div></div><div data-ad-ref="leader-plus-top" class="leader-plus-top bidbarrel-ad"></div><div class="row main-row"> <section class="col-xs-12 col-sm-8 col-md-9 col-sm-push-4 col-md-push-3"> <a id="main-content"></a><div class="region region-content"><div data-drupal-messages-fallback class="hidden"></div> <article role="article" class="article full clearfix"><div class="article-header hidden-xs"><h1 class="page-header"> <span>Man Killed by Former Girlfriend&#039;s Mother and Sister After He Broke Into Their Home to Attack Ex, Police Say</span></h1><div class="article-meta"> <span class="category"><div class="field field--name-field-category field--type-entity-reference field--label-hidden field--item"><a href="/crime" aria-label="Category Crime" hreflang="en">Crime</a></div> </span> <span class="publish-details"><time datetime="2020-11-30T22:02:31Z">2:02 PM PST, November 30, 2020</time> - <a href="/bios/anabel-sosa" hreflang="en">ANABEL SOSA</a></span></div></div><div class="article-hero"><div class="media media-image"><div class="field field--name-field-image-landscape field--type-image field--label-hidden field--item"> <img data-portal-copyright="Getty Images" src="/sites/default/files/styles/931x523/public/images/2020-11/policetape1280x720_5.jpg?h=c673cd1c&amp;itok=yS5iEG0Y" width="969" height="546" alt="Crime scene" class="img-responsive" /></div></div><div class="hero-image-caption"> <span class="hero-image-credit">Getty Images</span></div></div> <section class="content"><div class="story_parent"><div class="story_links story_links-vertical" > <button class="button button--share button--share-facebook st_facebook_custom" st_image=""> <img alt="Facebook" class="icon icon-facebook" src="/themes/custom/iebs/images/sharethis/facebook.svg"> </button> <button class="button button--share button--share-twitter st_twitter_custom" st_image=""> <img alt="Twitter" class="icon icon-twitter" src="/themes/custom/iebs/images/sharethis/twitter.svg"> </button> <button class="button button--share button--share-email st_email_custom" st_image=""> <img alt="Email" class="icon icon-email" src="/themes/custom/iebs/images/sharethis/email.svg"> </button> <button class="button button--share button--share-reddit st_reddit_custom" st_image=""> <img alt="Reddit" class="icon icon-reddit" src="/themes/custom/iebs/images/sharethis/reddit.svg"> </button></div></div><div class="row--article-text"><div class="field field--name-body field--type-text-with-summary field--label-hidden field--item"><div><p>A man broke into his former girlfriend's home and started attacking her until the woman's mother and sister stepped in and fatally attacked him using a golf club and kitchen knife, according to a report. The estranged boyfriend broke into his ex's Pasadena home on Saturday morning, leaving behind shattered window glass as he made his way inside, according to the Los Angeles Times.</p><p>When police arrived at the Oaks Drive home after a report of domestic violence, they said they found the front window broken into and a man, later identified as 40-year-old Justin Goss, inside stabbed and beaten, the Times wrote.</p><div data-ad-ref="mpu-plus-top" class="mpu-plus-top bidbarrel-ad"></div><p>Goss was pronounced dead at the scene by the South Pasadena Fire Department.</p><p>Investigators discovered that in the process of beating and choking his 37-year-old estranged girlfriend, the woman's mother and older sister came to her rescue, the outlet reported.</p><div data-ad-ref="native-top" class="native-top bidbarrel-ad"></div><p>"They tried to pull him off, and it didn't work; he was too strong," Los Angeles County Sheriff's Lt. Barry Hall told the Los Angeles Times. "So they had to resort to using weapons."</p><p>Police said the mother and sister will not be facing charges because they were acting in self-defense.</p><p>"They were well within their right to act in defense of their sister and daughter," Hall told the outlet.</p><p>The victim was taken to a local hospital and treated for facial injuries.&nbsp;</p><p><strong>RELATED STORIES</strong></p><p class="speedbump"> <a target="_blank" href="https://www.insideedition.com/los-angeles-8-year-old-living-with-family-in-shed-starts-plant-business-that-helps-them-secure"> Los Angeles 8-Year-Old Living With Family in Shed Starts Plant Business That Helps Them Secure Stable Housing </a></p><p class="speedbump"> <a target="_blank" href="https://www.insideedition.com/los-angeles-fedex-driver-who-put-out-backyard-blaze-on-route-meets-grateful-homeowners-63094"> Los Angeles FedEx Driver Who Put Out Backyard Blaze on Route Meets Grateful Homeowners </a></p><div data-ad-ref="mpu-bottom" class="mpu-bottom bidbarrel-ad"></div><p class="speedbump"> <a target="_blank" href="https://www.insideedition.com/taco-bell-will-soon-be-giving-away-free-tacos-thanks-to-los-angeles-dodger-mookie-betts-62569"> Taco Bell Will Soon Be Giving Away Free Tacos, Thanks to Los Angeles Dodger Mookie Betts </a></p><article role="article" class="video related clearfix node--shortcode-video-embed"><h2> <a href="/media/videos/kendall-jenner-throws-wild-halloween-party-despite-los-angeles-county-ban-62794" rel="bookmark"><span>Kendall Jenner Throws Wild Halloween Party Despite Los Angeles County Ban</span></a></h2><div class="content"><div class="field field--name-field-video-mpx-id field--type-string field--label-hidden field--item"><div class="uvp-outer"><div class="adBanner"></div><div class="uvp-ad-blocked"> This video is unavailable because we were unable to load a message from our sponsors. <br /><br />If you are using ad-blocking software, please disable it and reload the page.</div><div class="uvp-wrapper"><div data-site-uvpc-url="/onetrust/uvpconfig" data-hls="https://cbsi-insideedition-video-fastly.global.ssl.fastly.net/2020/11/02/1814710851710/579153_hls/master.m3u8" data-duration="152" data-title="Kendall Jenner Throws Wild Halloween Party Despite Los Angeles County Ban" data-keywords="Coronavirus,celebrity,Inside Edition,Inside_Edition,IE Coronavirus,IE Celebrity,kardashians,jenner,kendall jenner halloween party,kendall jenner party,los angeles,justin bieber,justin beiber,the weeknd,kim kardashian,kylie jenner,celebrities partying" data-has-preroll-ad="true" data-player-has-preroll-ads="true" data-ad-url="https://pubads.g.doubleclick.net/gampad/ads?sz=640x480&amp;iu=%2F8264%2Fvaw-ctd%2FPH-DEVICE-TYPE%2Finside_edition&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vmap1&amp;unviewed_position_start=1&amp;description_url=https%3A%2F%2Fwww.insideedition.com&amp;correlator=" data-brand="inside_edition" data-cms-id="2289" data-recommendation="false" data-tracking-data="{&quot;assetId&quot;:&quot;6NP_3L7Qffn3mUlCjMlqeBB0BXvL_UtE&quot;,&quot;assetPubDate&quot;:&quot;2020-11-02T23:08:54Z&quot;,&quot;assetTitle&quot;:&quot;Kendall Jenner Throws Wild Halloween Party Despite Los Angeles County Ban&quot;,&quot;assetType&quot;:&quot;video&quot;,&quot;authorId&quot;:&quot;87&quot;,&quot;authorName&quot;:&quot;Inside Edition Staff&quot;,&quot;brandPlatformId&quot;:&quot;insideedition_site&quot;,&quot;deviceType&quot;:null,&quot;mediaContentType&quot;:&quot;vod&quot;,&quot;pageName&quot;:null,&quot;pageType&quot;:null,&quot;pageURL&quot;:null,&quot;pageViewGuid&quot;:null,&quot;sitePrimaryRsid&quot;:&quot;cbsiinsideeditionsite&quot;,&quot;siteSection&quot;:&quot;entertainment&quot;,&quot;siteType&quot;:null,&quot;userState&quot;:&quot;not authenticated&quot;,&quot;userType&quot;:&quot;anon&quot;}" data-instance-uvpc="[]" data-uvp data-endscreen="false" data-partner="can" data-default-autoplay="false" data-default-muted="false" data-mobile-autoplay="false" data-mobile-muted="false" data-poster-url="/sites/default/files/styles/video_1920x1080/public/images/2020-11/110220_kardashian_party_web.jpg?h=d1cb525d&amp;itok=FqqQHSdg" data-captions-url="" data-env-uvpc="null" data-ref-id="6NP_3L7Qffn3mUlCjMlqeBB0BXvL_UtE" class="uvp-player uvp-inner"></div></div></div><div class="end-screen-overlay end-screen-template" style="display:none;"><div class="end-screen-outer"><form><h1 class="uvp-endslate-title"></h1> <label class="uvp-endslate-embed-code" aria-label="Read Only: Embed Code"> <span class="uvp-endslate-label-text">Embed Code</span> </label> <button tabindex="0" class="uvp-endslate-replay">Restart</button></form></div></div><div id="hero" class="owl-theme hero-video--carousel"><div class="owl-controls"><div class="owl-nav"></div></div><div class="owl-carousel"></div> <span class="carousel-item-template visually-hidden"><div class="item"> <a class="player_link"><div class="image-container"> <img src="/themes/custom/iebs/images/1x1_transparent.png"> <span class="now-playing">Now playing</span><div class="time-block"> <svg class="video-play-button"></svg> <span class="timecode"></span></div></div><h2 class="item__title"></h2> </a></div> </span></div></div></div></article></div></div><div class="article-social"><ul class="article-social-share"><li class="article-social-share-item article-social-share-li-facebook"> <button class="button button--share button--share-facebook st_facebook_custom"> <img alt="Facebook" class="icon icon-facebook" src="/themes/custom/iebs/images/sharethis/article_facebook_share.svg"> </button></li><li class="article-social-share-item article-social-share-li-twitter"> <button class="button button--share button--share-twitter st_twitter_custom"> <img alt="Twitter" class="icon icon-twitter" src="/themes/custom/iebs/images/sharethis/article_twitter_share.svg"> </button></li><li class="article-social-share-item article-social-share-li-reddit"> <button class="button button--share button--share-reddit st_reddit_custom"> <img alt="Reddit" class="icon icon-reddit" src="/themes/custom/iebs/images/sharethis/article_reddit_share.png"> </button></li></ul></div></div> </section></article></div><div class="content-bottom" id="content-bottom"><div class="region region-content-bottom"> <section id="block-taboolawidget" class="block block-ctd-taboola clearfix"><div id="taboola-below-article-thumbnails" class="ctd-taboola"></div> </section><section id="block-taboolawidget-5" class="block block-ctd-taboola clearfix"><div id="taboola-below-article-thumbnails" class="ctd-taboola"></div> </section><section id="block-medianetwidget" class="block block-ctd-media-net clearfix"><div id="434717348"><script>
window.cbsoptanon.onAdsReady(function(cmp,_cbsoptanon, adOpts) {
cmp.ot.targetingAllowed(function(allowed) {
if (allowed) {
try {
window._mNHandle.queue.push(function () {
window._mNDetails.loadTag("434717348", "800x200", "434717348");
});
}
catch (error) {
}
}
});
});
</script></div> </section></div></div> </section> <aside class="col-xs-12 col-sm-4 col-md-3 col-sm-pull-8 col-md-pull-9" role="complementary"><div class="sidebar-container"><div class="sidebar-one-container" ><div class="region region-sidebar"> <section class="views-element-container block block-views block-views-blocklatest-news-latest-news clearfix" id="block-views-block-latest-news-latest-news"><h2 class="block-title">Latest <span class="last-word">News</span></h2><div class="form-group"><div class="view view-latest-news view-id-latest_news view-display-id-latest_news js-view-dom-id-ccefedc093d7a21a315944e6c921d2551b77a72fc991ef89bdcb9d71d46267fb"><div class="view-content"><div class="views-row"> <article role="article" class="article teaser-small-single-link teaser-template node--article--teaser-small-single-link node--teaser-small-single-link teaser-small clearfix"> <a href="/group-of-friends-pay-for-40k-worth-of-groceries-for-shoppers-at-atlanta-krogers-ahead-of-63401"><div role="text"> <span class="hero-media"> <span role="article" class="article teaser-small-single-link teaser-template node--article--teaser-small-single-link node--teaser-small-single-link teaser-small clearfix image-overlay-container"><div class="media media-image"><div class="field field--name-field-image field--type-image field--label-hidden field--item"> <img data-portal-copyright="Tronda Giles " src="/sites/default/files/styles/100x100/public/images/2020-11/113020-kroger-friends-1280x720.jpg?h=c673cd1c&amp;itok=xt68XmqB" width="100" height="100" class="img-responsive" /></div></div> </span> </span> <span class="article-details"><h4><div class="field field--name-field-display-headline field--type-string field--label-hidden field--item">Group of Friends Pay for $40K Worth of Groceries for Shoppers at Atlanta Krogers Ahead of Thanksgiving</div></h4> </span></div> </a></article></div><div class="views-row"> <article role="article" class="article teaser-small-single-link teaser-template node--article--teaser-small-single-link node--teaser-small-single-link teaser-small clearfix"> <a href="/aspiring-makeup-artist-and-youtubers-body-found-in-trunk-of-car-that-crashed-during-police-chase"><div role="text"> <span class="hero-media"> <span role="article" class="article teaser-small-single-link teaser-template node--article--teaser-small-single-link node--teaser-small-single-link teaser-small clearfix image-overlay-container"><div class="media media-image"><div class="field field--name-field-image field--type-image field--label-hidden field--item"> <img data-portal-copyright="GoFundMe" src="/sites/default/files/styles/100x100/public/images/2020-11/11302-car-chase-body-1280x720.jpg?h=c673cd1c&amp;itok=p1u-B9vt" width="100" height="100" class="img-responsive" /></div></div> </span> </span> <span class="article-details"><h4><div class="field field--name-field-display-headline field--type-string field--label-hidden field--item">Aspiring Makeup Artist and YouTuber&#039;s Body Found in Trunk of Car That Crashed During Police Chase, Cops Say</div></h4> </span></div> </a></article></div></div></div></div> </section><section id="block-ctdbidbarreladwidget" class="block block-ctd-bidbarrel block-ctd-bidbarrel-ad-block clearfix"><div data-ad-ref="mpu-plus-top" class="mpu-plus-top bidbarrel-ad"></div> </section><section id="block-gotatipblock-2" class="block block-ie block-tip-block clearfix"><div class="tip-block-content speech-bubble"> <span class="block-title">Got a tip?</span><p>Email Us: <strong>tips@insideedition.com</strong></p><p>Call Us: <strong>(212) 817-5555</strong></p></div> </section><section id="block-trendingnow-2" class="block block-block-content block-block-contenteb27e4b4-600f-4e94-871e-94a577d7dec8 clearfix"><h2 class="block-title">Trending <span class="last-word">Now</span></h2><ol class="field field--name-field-links field--type-link field--label-hidden field--items"><li class="field--item"><a href="https://www.insideedition.com/best-friends-for-nearly-2-decades-find-out-theyre-actually-sisters-62717">Best Friends for Nearly 2 Decades Find Out They&#039;re Actually Sisters</a></li><li class="field--item"><a href="https://www.insideedition.com/what-is-the-national-popular-vote-interstate-compact-the-movement-to-skirt-the-electoral-college-is">What Is the National Popular Vote Interstate Compact? The Movement to Skirt the Electoral College Is Growing.</a></li><li class="field--item"><a href="https://www.insideedition.com/two-holocaust-survivors-find-each-other-again-through-zoom-after-71-years-62662">Two Holocaust Survivors Find Each Other Again Through Zoom After 71 Years</a></li><li class="field--item"><a href="https://www.insideedition.com/meet-dr-richard-gallagher-a-catholic-psychiatrist-who-helps-with-exorcisms-62863">Meet Dr. Richard Gallagher, a Catholic Psychiatrist Who Helps With Exorcisms</a></li><li class="field--item"><a href="https://www.insideedition.com/why-do-people-turn-to-conspiracy-theories-during-times-of-uncertainty-62750">Why Do People Turn to Conspiracy Theories During Times of Uncertainty?</a></li></ol> </section></div></div><div class="sidebar-two-container"><div class="region region-sidebar-two"> <section id="block-ctdbidbarreladwidget-2" class="block block-ctd-bidbarrel block-ctd-bidbarrel-ad-block clearfix"><div data-ad-ref="mpu-bottom" class="mpu-bottom bidbarrel-ad"></div> </section></div></div></div> </aside></div><div data-ad-ref="leader-plus-bottom" class="leader-plus-bottom bidbarrel-ad"></div></div></div> <footer class="footer" role="contentinfo"><div class=" container"><div class="region region-footer row"><div class="col-lg-1 grey-no-display"></div> <section id="block-social-footer" class="col-sm-2 col-sm-push-8 block block-ie block-social-block clearfix"><ul class="social-block-content"><li><a href="http://www.facebook.com/Inside.Edition" class="icon icon-facebook" aria-label="Facebook Inside Edition"></a></li><li><a href="http://twitter.com/insideedition" class="icon icon-twitter" aria-label="Twitter Inside Edition"></a></li><li><a href="https://instagram.com/insideedition/" class="icon icon-instagram" aria-label="Instagram Inside Edition"></a></li><li><a href="https://www.youtube.com/insideedition" class="icon icon-youtube" aria-label="YouTube Inside Edition"></a></li><li><a href="/rss" class="icon icon-rss" aria-label="RSS Inside Edition"></a></li></ul> </section><nav role="navigation" aria-labelledby="block-footeraboutmenu-menu" id="block-footeraboutmenu" class="col-sm-2 col-sm-pull-2"><h4 id="block-footeraboutmenu-menu">About Us</h4><ul class="menu menu--footer-about-menu nav"><li> <a href="/meet-the-team" data-drupal-link-system-path="meet-the-team">Meet the Team</a></li><li> <a href="/awards" data-drupal-link-system-path="awards">Awards</a></li><li> <a href="/contact" data-drupal-link-system-path="node/1">Contact</a></li></ul> </nav><nav role="navigation" aria-labelledby="block-footerconnectmenu-menu" id="block-footerconnectmenu" class="col-sm-2 col-sm-pull-2"><h4 id="block-footerconnectmenu-menu">Connect</h4><ul class="menu menu--footer-connect-menu nav"><li> <a href="https://www.facebook.com/Inside.Edition">Facebook</a></li><li> <a href="https://twitter.com/insideedition">Twitter</a></li><li> <a href="https://instagram.com/insideedition/">Instagram</a></li><li> <a href="https://plus.google.com/104304424115513428440">Google+</a></li><li> <a href="https://www.youtube.com/insideedition">YouTube</a></li><li> <a href="/rss" data-drupal-link-system-path="node/2">RSS</a></li><li> <a href="https://cbsinteractive.com/advertising/">Advertise with Us</a></li></ul> </nav><nav role="navigation" aria-labelledby="block-footerwatchiemenu-menu" id="block-footerwatchiemenu" class="col-sm-2 col-sm-pull-2"><h4 id="block-footerwatchiemenu-menu">Watch Inside Edition</h4><ul class="menu menu--footer-watch-ie-menu nav"><li> <a href="/showfinder" data-drupal-link-system-path="showfinder">Local Listings</a></li><li> <a href="/form/we-want-your-story-ideas">Submit a Story</a></li></ul> </nav><nav role="navigation" aria-labelledby="block-footersitesmenu-menu" id="block-footersitesmenu" class="col-sm-2 col-sm-pull-2"><h4 id="block-footersitesmenu-menu">Sites We Love</h4><ul class="menu menu--footer-sites-menu nav"><li> <a href="https://www.cbsnews.com/" title="CBS News">CBS News</a></li><li> <a href="https://www.tvguide.com/">TV Guide</a></li><li> <a href="https://www.tv.com/">TV.com</a></li><li> <a href="https://www.thedrewbarrymoreshow.com/" title="The Drew Barrymore Show">The Drew Barrymore Show</a></li><li> <a href="https://www.etonline.com/" title="Entertainment Tonight">ETonline</a></li><li> <a href="https://www.metacritic.com/">Metacritic</a></li><li> <a href="https://www.last.fm/">Last.fm</a></li><li> <a href="https://www.metrolyrics.com/">Metrolyrics</a></li><li> <a href="https://www.rachaelrayshow.com/">Rachael Ray Show</a></li></ul> </nav><div class="col-lg-1 grey-no-display"></div></div><div class="legal"> <a href="https://legalterms.cbsinteractive.com/terms-of-use" target="_blank">Terms of Use</a> | <a href="https://legalterms.cbsinteractive.com/privacy" target="_blank">Privacy Policy</a> | <a href="https://legalterms.cbsinteractive.com/eula" target="_blank">Mobile User Agreement</a> | <a href="http://www.cbs.com/closed-captioning/" target="_blank">Closed Captioning</a> | <a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/video-services-and-social-networking" target="_blank">Video Services Policy</a> | <a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/third-party-online-advertising" target="_blank">Ad Choices</a> | <a href="https://ca.privacy.cbs" target="_blank">California Privacy/Info We Collect</a> | <a href="https://ca.privacy.cbs/donotsell" target="_blank">Do Not Sell My Personal Information</a> | In Partnership with <a href="http://www.etonline.com" target="_blank">ETonline</a>. CBS interactive &#169; 2020 Inside Edition Inc. All Rights Reserved.</div></div></footer></div><div data-ad-ref="omni-intromercial" class="omni-intromercial bidbarrel-ad"></div></div><script src="/sites/default/files/js/js_hgjd39M3gtVP0OknpKd3TuRZ6jdNqvkvUzJn7OQzVZg.js"></script><script src="/modules/contrib/ctd_sourcepoint/js/ctd-sourcepoint-loader.js?qkkinh" type="text/plain" class="optanon-category-4"></script><script src="/sites/default/files/js/js_AwmsC-vsVYbBKr425tiuE7SCmajja9_Hwdqtdp0B-0c.js"></script><script src="https://vidtech.cbsinteractive.com/uvpjs/0.43.300/CBSI-PLAYER.js"></script><script src="/sites/default/files/js/js_Di8hqokMzxbmnatHDyAEmcwAvqn9Gm7uI2PdiVMGUjM.js"></script></body></html>