<!DOCTYPE html><html lang="en"><head><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><link rel="amphtml" href="https://www.insideedition.com/computer-repairman-who-alerted-trump-campaign-to-hunter-bidens-laptop-contents-is-releasing-book?amp"/><script type="application/ld+json">{"@context":"http://schema.org","dateModified":"2022-11-10T15:51:04-0800","headline":"Computer Repairman Who Alerted Trump Campaign to Hunter Biden's Laptop Contents Is Releasing Book","name":"Computer Repairman Who Alerted Trump Campaign to Hunter Biden's Laptop Contents Is Releasing Book","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.insideedition.com/computer-repairman-who-alerted-trump-campaign-to-hunter-bidens-laptop-contents-is-releasing-book"},"datePublished":"2022-11-10T15:51:04-0800","publisher":{"@type":"Organization","@id":"https://www.insideedition.com","name":"Inside Edition","url":"https://www.insideedition.com","sameAs":["https://www.insideedition.com","https://www.facebook.com/Inside.Edition/","https://www.instagram.com/insideedition/","https://twitter.com/InsideEdition","https://www.youtube.com/c/InsideEdition","https://en.wikipedia.org/wiki/Inside_Edition"],"logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png","height":1000,"width":1000}},"url":"https://www.insideedition.com/computer-repairman-who-alerted-trump-campaign-to-hunter-bidens-laptop-contents-is-releasing-book","description":"John Paul Mac Isaac owned the computer repair shop where Hunter Biden is said to have brought a water-damaged laptop. When Biden failed to pick up the computer after 90 days, the laptop- and its photos and videos- became Mac Isaac's property.","keywords":["Inside Edition, Politics, News, joe biden, rudy giuliani, Donald Trump, Delaware"],"@type":"NewsArticle","articleSection":"News","image":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_hunter_laptop_guy_0.jpg?h=d1cb525d","height":1080,"width":1920},"thumbnail":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_hunter_laptop_guy_0.jpg?h=d1cb525d","height":1080,"width":1920},"thumbnailUrl":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_hunter_laptop_guy_0.jpg?h=d1cb525d","author":[{"@type":"Person","name":"IE Staff"}],"video":{"@context":"https://schema.org","@type":"VideoObject","name":"Hunter Biden Laptop Repairman Says He Has No Regrets","description":"John Paul Mac Isaac owned the computer repair shop where Hunter Biden is said to have brought a water-damaged laptop. When Biden failed to pick up the computer after 90 days, the laptop- and its photos and videos- became Mac Isaac's property.","thumbnailUrl":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_hunter_laptop_guy.jpg?h=d1cb525d","thumbnail":{"@context":"https://schema.org","@type":"ImageObject","height":1080,"width":1920,"url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_hunter_laptop_guy.jpg?h=d1cb525d"},"uploadDate":"2022-11-10T15:51:04-0800","duration":"PT199S","embedUrl":"https://cbsi-insideedition-video-fastly.global.ssl.fastly.net/2022/11/10/2107680835600/1456731_hls/master.m3u8","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}}}}</script><link rel="preload" as="image" href="undefined" imagesrcset="undefined 375w, undefined 1170w" imagesizes="(max-width: 375px) 375px, 1170px"/><link rel="canonical" href="https://www.insideedition.com/computer-repairman-who-alerted-trump-campaign-to-hunter-bidens-laptop-contents-is-releasing-book"/><link rel="image_src" href="undefined"/><title>Hunter Biden Laptop Repairman Releasing Book, Has No Regrets | Inside Edition</title><meta name="description" content="John Paul Mac Isaac owned the computer repair shop where Hunter Biden is said to have brought a water-damaged laptop. When Biden failed to pick up the computer after 90 days, the laptop- and its photos and videos- became Mac Isaac&#x27;s property."/><meta property="og:description" content="John Paul Mac Isaac owned the computer repair shop where Hunter Biden is said to have brought a water-damaged laptop. When Biden failed to pick up the computer after 90 days, the laptop- and its photos and videos- became Mac Isaac&#x27;s property."/><meta name="twitter:description" content="John Paul Mac Isaac owned the computer repair shop where Hunter Biden is said to have brought a water-damaged laptop. When Biden failed to pick up the computer after 90 days, the laptop- and its photos and videos- became Mac Isaac&#x27;s property."/><meta name="title" content="Hunter Biden Laptop Repairman Releasing Book, Has No Regrets"/><meta property="og:title" content="Hunter Biden Laptop Repairman Releasing Book, Has No Regrets"/><meta property="og:site_name" content="Inside Edition"/><meta property="og:url" content="https://www.insideedition.com/computer-repairman-who-alerted-trump-campaign-to-hunter-bidens-laptop-contents-is-releasing-book"/><meta property="og:image" content="undefined"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta property="og:type" content="Articles"/><meta name="twitter:title" content="Hunter Biden Laptop Repairman Releasing Book, Has No Regrets"/><meta name="twitter:site"/><meta name="twitter:site:id"/><meta name="twitter:url" content="https://www.insideedition.com/computer-repairman-who-alerted-trump-campaign-to-hunter-bidens-laptop-contents-is-releasing-book"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:creator" content="@insideedition"/><meta name="twitter:image" content="undefined"/><meta name="twitter:image:width" content="1280"/><meta name="twitter:image:height" content="720"/><meta name="fb:pages"/><meta name="fb:admins"/><meta name="fb:app_id"/><meta property="article:published_time" content="2022-11-10T15:51:04-0800"/><meta name="article:opinion" content="false"/><meta name="keywords" content="Inside Edition, Politics, News, joe biden, rudy giuliani, Donald Trump, Delaware"/><meta name="robots" content="index"/><meta name="robots" content="max-image-preview:large"/><meta name="next-head-count" content="36"/><link rel="apple-touch-icon" sizes="57x57" href="/img/favicons/apple-icon-57x57.png"/><link rel="apple-touch-icon" sizes="60x60" href="/img/favicons/apple-icon-60x60.png"/><link rel="apple-touch-icon" sizes="72x72" href="/img/favicons/apple-icon-72x72.png"/><link rel="apple-touch-icon" sizes="76x76" href="/img/favicons/apple-icon-76x76.png"/><link rel="apple-touch-icon" sizes="114x114" href="/img/favicons/apple-icon-114x114.png"/><link rel="apple-touch-icon" sizes="120x120" href="/img/favicons/apple-icon-120x120.png"/><link rel="apple-touch-icon" sizes="144x144" href="/img/favicons/apple-icon-144x144.png"/><link rel="apple-touch-icon" sizes="152x152" href="/img/favicons/apple-icon-152x152.png"/><link rel="apple-touch-icon" sizes="180x180" href="/img/favicons/apple-icon-180x180.png"/><link rel="icon" type="image/png" sizes="192x192" href="/img/favicons/android-icon-192x192.png"/><link rel="icon" type="image/png" sizes="32x32" href="/img/favicons/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="96x96" href="/img/favicons/favicon-96x96.png"/><link rel="icon" type="image/png" sizes="16x16" href="/img/favicons/favicon-16x16.png"/><link rel="manifest" crossorigin="use-credentials" href="/manifest.json"/><meta name="msapplication-TileImage" content="/img/favicons/ms-icon-144x144.png"/><link rel="preconnect" href="https://cdn.cookielaw.org"/><link rel="preconnect" href="https://www.insideedition.com"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/><meta http-equiv="content-language" content="en_US"/><meta property="fb:app_id" content="966341826790079"/><meta property="fb:admins" content="3111204"/><meta property="fb:pages" content="71728150722"/><meta property="og:site_name" content="Inside Edition"/><meta name="twitter:site" content="@insideedition"/><meta name="twitter:site:id" content="23603092"/><meta name="twitter:creator" content="@insideedition"/><meta name="robots" content="max-image-preview:large"/><meta name="theme-color" content="#fd005b"/><meta name="msapplication-TileColor" content="#fd005b"/><script>var utag_data = window.utag_data || {}; window.utag_data.isSPA = true;</script><link rel="preload" href="/_next/static/css/c6fc041cc5b66470.css" as="style"/><link rel="stylesheet" href="/_next/static/css/c6fc041cc5b66470.css" data-n-g=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-5cd94c89d3acac5f.js"></script><script src="" defer="" data-nscript="beforeInteractive"></script><script src="https://tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js" id="utag" defer="" data-nscript="beforeInteractive"></script><script src="//production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js" id="optanon-request" defer="" data-nscript="beforeInteractive"></script><script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" id="cmp-request" type="text/javascript" charSet="UTF-8" data-domain-script="1e90d9ec-e15e-4932-a026-f218893ce26c" defer="" data-nscript="beforeInteractive"></script><script defer="" src="/_next/static/chunks/05d954cf-0f759294eabfda59.js"></script><script defer="" src="/_next/static/chunks/9713-1c6661acb3087a77.js"></script><script defer="" src="/_next/static/chunks/9716-0b561c9e80da3878.js"></script><script defer="" src="/_next/static/chunks/6310.0bde44eb188e82b0.js"></script><script defer="" src="/_next/static/chunks/9063.fb162f08e370c859.js"></script><script defer="" src="/_next/static/chunks/29107295.55db3f7ea8c5c9b7.js"></script><script defer="" src="/_next/static/chunks/5091.3da727615df5b419.js"></script><script defer="" src="/_next/static/chunks/5585-2fb8d9aeb8cfced2.js"></script><script defer="" src="/_next/static/chunks/6391.7cb9575fd5775734.js"></script><script defer="" src="/_next/static/chunks/5829.718745eb7c2b8447.js"></script><script defer="" src="/_next/static/chunks/228.aab6aa806e79f846.js"></script><script defer="" src="/_next/static/chunks/2655.c26d64b531c4b2da.js"></script><script src="/_next/static/chunks/webpack-a2c3d05e54f90edb.js" defer=""></script><script src="/_next/static/chunks/framework-a070cbfff3c750c5.js" defer=""></script><script src="/_next/static/chunks/main-c92e0a52ad404727.js" defer=""></script><script src="/_next/static/chunks/pages/_app-577a1200de6ece84.js" defer=""></script><script src="/_next/static/chunks/9204-2ea266c6cde856cf.js" defer=""></script><script src="/_next/static/chunks/2127-4e844fb53989f066.js" defer=""></script><script src="/_next/static/chunks/8748-7f73c54cac4ce557.js" defer=""></script><script src="/_next/static/chunks/pages/%5B...alias%5D-be1f3cb20878654d.js" defer=""></script><script src="/_next/static/insideedition/_buildManifest.js" defer=""></script><script src="/_next/static/insideedition/_ssgManifest.js" defer=""></script><script src="/_next/static/insideedition/_middlewareManifest.js" defer=""></script></head><body class="skybox-auto-collapse"><div id="__next" data-reactroot=""><div><div class="light"><div class="main-menu__sticky" style="top:0"><div class="header__wrapper"><div id="sticky-banner" class=""><div data-ad-ref="mobile-omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div></div><div data-ad-ref="intromercial"></div><header class="header affix-top light" style="top:0px" id="header"><div class="header__container"><div class="header__column-1"><div class="header__logo_toggle_wrapper"><button type="button" class="header__menu-toggle header__menu-toggle--collapsed" data-toggle="collapse" data-target="#navbar" aria-label="Toggle navigation menu" aria-expanded="false"></button><a class="header__logo" href="/"><img height="46" width="68" class="header__logo__image" alt="Inside Edition Logo" src="/img/logo-black.png"/></a><li class="main-menu__item main-menu__item--hide-tablet"><a href="/live?ftag=ETM-16-10aab3h" class="main-menu__link main-menu__link--show-mobile live-cta live-cta--submenu" aria-label="Live">Live</a></li></div><div class="header__nav" style="display:none;transform:translateY(-100%) translateZ(0)"><ul class="main-menu"><li class="main-menu__item main-menu__item--show-mobile"><div class="header-search--mobile"><div class="header__search"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group"><input type="search" id="edit-keywords" class="header__search-form__input-keywords" title="Enter the terms you wish to search for." placeholder="Search" aria-label="Search" name="keywords" size="15" maxLength="128"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><div class="header__search-form__actions"><button type="submit" class="header__search-form__actions__submit" name="op" aria-label="Search"></button></div></form></div></div></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/news" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">News</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/news">Latest News</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/crime">Crime</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/investigative">Investigative</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/offbeat">Offbeat</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/politics">Politics</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/health">Health</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/entertainment">Entertainment</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/royals">Royals</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/human-interest">Human Interest</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/inspirational">Inspirational</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/category/the-issue">The Issue</a></li></ul></li><li class="main-menu__item"><a href="/videos" class="main-menu__link toolbar-icon toolbar-icon-menu-link-content:7f1c4464-33be-4d36-8824-e6de94189c64" aria-label="Video">Video</a></li><li class="main-menu__item main-menu__item--hide-mobile-tablet"><a href="/live?ftag=ETM-16-10aab3h" class="main-menu__link live-cta toolbar-icon toolbar-icon-menu-link-content:6b523234-bd04-4653-96d6-b0beaa58a44c" aria-label="Live">Live</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/photos" class="main-menu__link toolbar-icon toolbar-icon-views-view:views-section-pages-section-photos" aria-label="Photos">Photos</a></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/more" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">More</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/animals">Animal Edition</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/heroes">Heroes</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/in-depth">Inside Edition InDepth</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/sports">Sports</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/flashback">Flashback</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/shopping">Shopping</a></li></ul></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/showfinder" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-expanded="false">Watch on TV</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/showfinder">Local Listings</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/meet-the-team">Meet the Team</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/today-inside-edition">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="header__column-2"><div class="header__search"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group"><input type="search" id="edit-keywords" class="header__search-form__input-keywords" title="Enter the terms you wish to search for." placeholder="Search" aria-label="Search" name="keywords" size="15" maxLength="128"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><div class="header__search-form__actions"><button type="submit" class="header__search-form__actions__submit" name="op" aria-label="Search"></button></div></form></div><div class="header__social"><ul class="header__social-menu"><li class="header__social-menu__item"><a href="http://www.facebook.com/Inside.Edition" class="header__social-menu__link header__social-menu__link--facebook"><span class="sr-only">Facebook Inside Edition</span></a></li><li class="header__social-menu__item"><a href="http://twitter.com/insideedition" class="header__social-menu__link header__social-menu__link--twitter"><span class="sr-only">Twitter Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://instagram.com/insideedition/" class="header__social-menu__link header__social-menu__link--instagram"><span class="sr-only">Instagram Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://www.youtube.com/insideedition" class="header__social-menu__link header__social-menu__link--youtube"><span class="sr-only">YouTube Inside Edition</span></a></li></ul></div></div></div></header></div></div><div class="wrap-site"><main><noscript><img alt="" height="1" width="1" src="https://www.facebook.com/tr?id=1223619061322807&amp;ev=PageView&amp;noscript=1"/></noscript><div class="wrap-site"><div class="content"><div class="top-container"><h1 class="content__title">Computer Repairman Who Alerted Trump Campaign to Hunter Biden&#x27;s Laptop Contents Is Releasing Book</h1><div class="cat-social-container"><div class="content__category"><a href="https://www.insideedition.com/politics">Politics</a></div><div class="content__share"><div class="share"><button type="button" class="share__social-btn" aria-label="Share to Facebook"><div></div></button><button type="button" class="share__social-btn" aria-label="Share to Twitter"><div></div></button></div></div></div></div><div class="content__header-video"><div class="content__header-video-wrap"><div class="sticky " style="top:90px"><button type="button" class="stuck-close" aria-label="Close video player"><div></div></button><div></div></div></div></div><div class="carousel-main"><script async="" src="https://i-amlg-prod.appspot.com/display?id=216b2f04-a289-4698-9331-0e260e782d81"></script><div class="carousel__mask"></div><div class="carousel-rec__wrapper"><div class="carousel-rec"><div class="carousel__container"><button type="button" aria-label="Hunter Biden Laptop Repairman Says He Has No Regrets"><h3 class="card__title line-clamp"> <!-- -->Hunter Biden Laptop Repairman Says He Has No Regrets<!-- --> </h3></button><button type="button" aria-label="NASA Says Planetary Defense Mission Successful in Reducing Asteroid’s Orbit Time"><h3 class="card__title line-clamp"> <!-- -->NASA Says Planetary Defense Mission Successful in Reducing Asteroid’s Orbit Time<!-- --> </h3></button><button type="button" aria-label="How a Mummy Was Uncovered After 25 Years Inside a Drag Queen&#x27;s Closet"><h3 class="card__title line-clamp"> <!-- -->How a Mummy Was Uncovered After 25 Years Inside a Drag Queen&#x27;s Closet<!-- --> </h3></button><button type="button" aria-label="A Cat With Extra Long Teeth and Other Vampire Stories"><h3 class="card__title line-clamp"> <!-- -->A Cat With Extra Long Teeth and Other Vampire Stories<!-- --> </h3></button><button type="button" aria-label="Controversy Whirls Around Kanye West, as George Floyd’s Family Wants to Sue Him"><h3 class="card__title line-clamp"> <!-- -->Controversy Whirls Around Kanye West, as George Floyd’s Family Wants to Sue Him<!-- --> </h3></button><button type="button" aria-label="Kidnap Hoaxer Bonnie Sweeten Accused of Stealing Thousands From Boss"><h3 class="card__title line-clamp"> <!-- -->Kidnap Hoaxer Bonnie Sweeten Accused of Stealing Thousands From Boss<!-- --> </h3></button><button type="button" aria-label="Accused Stockton Serial Killer Wesley Brownlee Charged With 3 Murders"><h3 class="card__title line-clamp"> <!-- -->Accused Stockton Serial Killer Wesley Brownlee Charged With 3 Murders<!-- --> </h3></button><button type="button" aria-label="Inside Deals on Shark Vacuum, Smartphone Stands, Down Alternative Comforter - Up to 75% off"><h3 class="card__title line-clamp"> <!-- -->Inside Deals on Shark Vacuum, Smartphone Stands, Down Alternative Comforter - Up to 75% off<!-- --> </h3></button><button type="button" aria-label="Nicole Mann Makes History as the First Native American Woman in Space"><h3 class="card__title line-clamp"> <!-- -->Nicole Mann Makes History as the First Native American Woman in Space<!-- --> </h3></button><button type="button" aria-label="Man Accused of Killing 2 Cops Played High School Football With Aaron Hernandez"><h3 class="card__title line-clamp"> <!-- -->Man Accused of Killing 2 Cops Played High School Football With Aaron Hernandez<!-- --> </h3></button><button type="button" aria-label="New ‘Butter Board’ Food Trend Receives Mixed Reactions"><h3 class="card__title line-clamp"> <!-- -->New ‘Butter Board’ Food Trend Receives Mixed Reactions<!-- --> </h3></button><button type="button" aria-label="Artist Damien Hirst Burns Famous Spot Paintings When Buyers Purchase NFT"><h3 class="card__title line-clamp"> <!-- -->Artist Damien Hirst Burns Famous Spot Paintings When Buyers Purchase NFT<!-- --> </h3></button><button type="button" aria-label="A Haunted Open House and Other Halloween Pranks"><h3 class="card__title line-clamp"> <!-- -->A Haunted Open House and Other Halloween Pranks<!-- --> </h3></button><button type="button" aria-label="Surveillance Video Shows Suspect Push Another Man Onto NYC Subway Tracks: NYPD"><h3 class="card__title line-clamp"> <!-- -->Surveillance Video Shows Suspect Push Another Man Onto NYC Subway Tracks: NYPD<!-- --> </h3></button><button type="button" aria-label="Thrill-Seekers in North Carolina Race in ‘Build Your Own Boat’ Competition"><h3 class="card__title line-clamp"> <!-- -->Thrill-Seekers in North Carolina Race in ‘Build Your Own Boat’ Competition<!-- --> </h3></button><button type="button" aria-label="Massachusetts Bride and Nurses Help Save Wedding Guest Who Collapsed"><h3 class="card__title line-clamp"> <!-- -->Massachusetts Bride and Nurses Help Save Wedding Guest Who Collapsed<!-- --> </h3></button><button type="button" aria-label="Sword-Wielding Man Arrested After Slashing Woman in LA, Cops Say"><h3 class="card__title line-clamp"> <!-- -->Sword-Wielding Man Arrested After Slashing Woman in LA, Cops Say<!-- --> </h3></button><button type="button" aria-label="&#x27;Just Stop Oil&#x27; Activists Spray Paint Luxury Department Store Harrods"><h3 class="card__title line-clamp"> <!-- -->&#x27;Just Stop Oil&#x27; Activists Spray Paint Luxury Department Store Harrods<!-- --> </h3></button><button type="button" aria-label="$40 Million of Counterfeit Designer Items Seized From Long Island Boutique: Cops"><h3 class="card__title line-clamp"> <!-- -->$40 Million of Counterfeit Designer Items Seized From Long Island Boutique: Cops<!-- --> </h3></button><button type="button" aria-label="Mississippi River Drought Reveals Hundred-Year-Old Shipwreck in Baton Rouge"><h3 class="card__title line-clamp"> <!-- -->Mississippi River Drought Reveals Hundred-Year-Old Shipwreck in Baton Rouge<!-- --> </h3></button><button type="button" aria-label="Missing Michigan Family Found Safe in Wisconsin After Mysterious Disappearance"><h3 class="card__title line-clamp"> <!-- -->Missing Michigan Family Found Safe in Wisconsin After Mysterious Disappearance<!-- --> </h3></button></div></div><button class="carousel__arrow carousel__arrow--prev" type="button" aria-label="Previous Slide"><div></div></button><button class="carousel__arrow carousel__arrow--next" type="button" aria-label="Next Slide"><div></div></button></div><div class="carousel__mask"></div></div><div class="site-bg"><div class="constrain constrain--bg"><div class="content__body"><div class="content__topborder"></div><div class="content__byline"><div class="content__byline-author">By<!-- --> <!-- -->Inside Edition Staff</div><div class="content__byline-date"><div>First Published: <!-- -->3:51 PM PST, November 10, 2022</div></div></div><h2 class="content__subheading">John Paul Mac Isaac owned the computer repair shop where Hunter Biden is said to have brought a water-damaged laptop. When Biden failed to pick up the computer after 90 days, the laptop- and its photos and videos- became Mac Isaac&#x27;s property.</h2><div class="content__body-main"><div class="ctd-body"><div data-ad-ref="mobile-incontent-social" class="mobile-incontent-social bidbarrel-ad" aria-hidden="true"></div><p>The former computer repair shop owner who said he discovered shocking photos and concerning documents on a laptop Hunter Biden left there has now written a book about his experiences. &nbsp;</p><p>John Paul Mac Isaac owned a computer repair shop in a strip mall in Wilmington, <a href="https://www.insideedition.com/tag/delaware" rel="" target="_blank">Delaware</a>, when he discovered photos on Biden&rsquo;s laptop showing President Joe Biden&rsquo;s son looking strung out, smocking crack cocaine and wielding a gun. &nbsp;&nbsp;</p><div data-ad-ref="mobile-flex-plus-middle" class="bidbarrel-ad"></div><p>Hunter Biden is said to have brought the water-damaged laptop to the shop in April 2019 with the hope of restoring its information. When Biden failed to pick-up the computer after 90 days, the laptop became Mac Isaac's property, and with it, all those photos and videos.</p><p>&ldquo;Unfortunately, I saw the homemade porn,&rdquo; he says. &ldquo;It was not an episode of &lsquo;Friends,&rsquo; it was homemade porn.&rdquo;</p><div data-ad-ref="mpu-flex-middle" class="bidbarrel-ad"></div><p>Mac Isaac says that while some people may perceive his actions as having gone through another person&rsquo;s property, &ldquo;He hired me to do that.&rdquo;</p><p>Mac Isaac says he also found documents that show payments made to Hunter Biden from a Ukrainian energy company that have become the center of a <a href="https://www.insideedition.com/politics" rel="" target="_blank">political </a>firestorm.</p><div data-ad-ref="mpu-flex-inc" data-incremental="1" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="1" class="bidbarrel-ad"></div><p>&ldquo;I definitely had a legitimate concern for national security and that is why I went to the FBI,&rdquo; he says.</p><p>Mac Isaac says he turned the laptop over to the FBI in 2019 but after eight months of waiting, in 2020, during the presidential campaign, he approached then <a href="https://www.insideedition.com/tag/donald-trump" rel="" target="_blank">President Donald Trump</a>'s lawyer <a href="https://www.insideedition.com/tag/rudy-giuliani" rel="" target="_blank">Rudy Giuliani.&nbsp;</a></p><p>&ldquo;I had to do something with it because a I am a boy scout and when you see criminality, you should be able to take it to the authorities,&rdquo; he says. &nbsp;</p><p>Mac Isaac, who acknowledges he's a Trump supporter, has now&nbsp;written a book about his experiences called "American Injustice:My Battle to Expose The Truth."&nbsp;</p><p>He says he fears for his&nbsp;safety&nbsp;from&nbsp;&ldquo;both individuals, foreign and domestic, from&nbsp;what I have seen on the laptop.&rdquo;&nbsp;</p><p>&ldquo;I realized that this was much bigger than me,&rdquo; he says.&nbsp;&nbsp;</p><div data-ad-ref="mpu-flex-inc" data-incremental="2" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="2" class="bidbarrel-ad"></div><p>With the Republican party poised to take control of the House, the contents of the laptop are facing renewed scrutiny. Yesterday, at a press conference, <a href="https://www.insideedition.com/tag/joe-biden" rel="" target="_blank">President Biden</a> was asked what his message is to Republicans considering investigating his family, particularly Hunter Biden, and Hunter Biden&rsquo;s business dealings.&nbsp;&nbsp;</p><p>&ldquo;&rsquo;Lots of luck in your senior year,&rsquo; as my coach used to say,&rdquo; President Biden said. &ldquo;Look, I think the American people want us to move on and get things done for them.&rdquo;&nbsp;</p><p>Mac Isaac says he has no regrets.</p><p>&ldquo;If I did not do it, I would be doing a disservice to the country," he says.&nbsp;</p><p>The FBI told us&nbsp;they had no comment on Mac Issac&rsquo;s statements, including his statement in his book that he is under FBI investigation. While the White House and Hunter Biden did not return our calls, Hunter Biden, who has not been charged with any crime, has previously said&nbsp;he is "100% certain" he will be cleared of any wrongdoing.</p><p><em><strong>An excerpt from &ldquo;American Injustice: My Battle to Expose The Truth&rdquo; by John Paul Mac Isaac, forthcoming from Liberatio Protocol on Nov. 22, can be read below.</strong></em></p><div data-ad-ref="mpu-flex-inc" data-incremental="3" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="3" class="bidbarrel-ad"></div><p><em>October 16th 2020</em></p><p><em>He texted again that evening, telling me to download an encrypted instant-messaging app called Signal and then contact him on it. When I did, he informed me that I was now under investigation by the FBI and that moving forward, we should use Signal to protect our conversations.</em></p><p><em>&ldquo;Why am I under investigation? I&rsquo;ve done nothing wrong!&rdquo; I asked, panic rising in my chest.</em></p><p><em>&ldquo;You&rsquo;re at the center of a new investigation centered around the possibility that the laptop is part of a Russian disinformation scheme,&rdquo; he answered.</em></p><p><em>&ldquo;Here we go, using the &lsquo;Russia excuse&rsquo; again,&rdquo; I thought. Out loud I said, &ldquo;But the FBI has sat on this thing for almost a year. How can they get away with calling it Russian disinformation now?&rdquo;</em></p><p><em>&ldquo;It&rsquo;s what sells newspapers and gets people&rsquo;s attention away from them and on to you,&rdquo; Larry explained. &ldquo;All that matters is you have to be careful. Your phone and communications are being tapped. So are your parents&rsquo;. You need to get them on board with Signal and watch what you say. They&rsquo;re going to try to catch you in a lie or trick you into an obstruction charge. Now more than ever, you have to be careful who you talk to.&rdquo;</em></p><h2>Related Stories&nbsp;</h2><div class="shortcode-speedbump"><a href="https://www.insideedition.com/fbi-believes-they-have-evidence-that-hunter-biden-lied-on-application-to-purchase-a-gun-in-2018" target="_blank" rel="noopener noreferrer">Did Hunter Biden Lie on His Application to Buy a Gun in 2018?</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/kathleen-buhle-hunter-bidens-ex-wife-speaks-out-about-new-book-detailing-marriage-woes-75342" target="_blank" rel="noopener noreferrer">Kathleen Buhle, Hunter Biden&#x27;s Ex-Wife, Breaks Silence on &#x27;GMA&#x27;</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/hunter-bidens-secret-service-detail-in-malibu-costs-30000-per-month-74233" target="_blank" rel="noopener noreferrer">Hunter Biden&#x27;s Secret Service Detail in Malibu Costs $30,000 Per Month</a></div><div class="shortcode-video"><div class="related-links"><a class="title" href="/media/videos/unearthed-images-show-hunter-biden-brandishing-handgun-77324">Unearthed Images Show Hunter Biden Brandishing Handgun</a><a href="/politics" class="category"></a></div></div><p>&nbsp;</p></div></div><div class="content__spacer"></div><div class="content__tags"><h3>Tags:</h3><ul><li class=""><a href="https://www.insideedition.com/tag/joe-biden " aria-label="Visit joe biden">joe biden</a></li><li class=""><a href="https://www.insideedition.com/tag/rudy-giuliani " aria-label="Visit rudy giuliani">rudy giuliani</a></li><li class=""><a href="https://www.insideedition.com/tag/donald-trump " aria-label="Visit Donald Trump">Donald Trump</a></li><li class=""><a href="https://www.insideedition.com/tag/delaware " aria-label="Visit Delaware">Delaware</a></li></ul></div><div class="content__spacer"></div><div class="right-rail"><div style="top:95px"><div class="right-rail__content "><div data-ad-ref="mpu-plus-top" class="bidbarrel-ad"></div></div></div></div></div><div id="taboola-below-article-thumbnails"></div><div class="content__trending"><div class="trending"><h2 class="trending__block-title">Trending on Inside Edition</h2><div class="trending__items"><div class="trending__item"><a href="https://www.insideedition.com/who-is-casey-desantis-first-lady-of-florida-and-ron-desantis-wife-and-closest-advisor-77974" class="trending__item__link"><span class="sr-only">Who Is Casey DeSantis, First Lady of Florida and Ron DeSantis&#x27; Wife and Closest Advisor?</span></a><div class="trending__item__image__container"><img alt="Who Is Casey DeSantis, First Lady of Florida and Ron DeSantis&#x27; Wife and Closest Advisor?" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_desantis_profile_web.jpg?h=d1cb525d?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">1</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Who Is Casey DeSantis, First Lady of Florida and Ron DeSantis&#x27; Wife and Closest Advisor?</p><a href="https://www.insideedition.com/politics" class="trending__item__text--kicker">Politics</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/california-off-duty-officer-arrested-after-shooting-service-weapon-into-air-while-out-with-friends" class="trending__item__link"><span class="sr-only">California Off-Duty Officer Arrested After Shooting Service Weapon Into Air While Out With Friends: Cops</span></a><div class="trending__item__image__container"><img alt="California Off-Duty Officer Arrested After Shooting Service Weapon Into Air While Out With Friends: Cops" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/gettyimages-1400355497.jpg?h=07b04915?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">2</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">California Off-Duty Officer Arrested After Shooting Service Weapon Into Air While Out With Friends: Cops</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/watch-now-the-best-of-inside-edition-77455" class="trending__item__link"><span class="sr-only">Watch Now: The Best of Inside Edition</span></a><div class="trending__item__image__container"><img alt="Watch Now: The Best of Inside Edition" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-10/ie_stream.jpg?h=c673cd1c?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">3</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Watch Now: The Best of Inside Edition</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/meet-maxwell-frost-the-first-gen-z-member-to-be-elected-to-congress-77944" class="trending__item__link"><span class="sr-only">Meet Maxwell Frost, the First Gen Z Member to Be Elected to Congress </span></a><div class="trending__item__image__container"><img alt="Meet Maxwell Frost, the First Gen Z Member to Be Elected to Congress " class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/maxwellfrost.jpg?h=c673cd1c?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">4</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Meet Maxwell Frost, the First Gen Z Member to Be Elected to Congress </p><a href="https://www.insideedition.com/politics" class="trending__item__text--kicker">Politics</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/pennsylvania-democrat-wins-state-seat-despite-dying-a-month-ago-77963" class="trending__item__link"><span class="sr-only">Pennsylvania Democrat Wins State Seat Despite Dying a Month Ago</span></a><div class="trending__item__image__container"><img alt="Pennsylvania Democrat Wins State Seat Despite Dying a Month Ago" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/anthonydeluca.jpg?h=3e5298b1?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">5</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Pennsylvania Democrat Wins State Seat Despite Dying a Month Ago</p><a href="https://www.insideedition.com/politics" class="trending__item__text--kicker">Politics</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/was-cold-case-murder-victim-lady-of-the-dunes-an-extra-in-jaws-movie-could-hold-answers-to-mystery" class="trending__item__link"><span class="sr-only">Was Cold Case Murder Victim &#x27;Lady of the Dunes,&#x27; an Extra in &#x27;Jaws&#x27;? Movie Could Hold Answers to Mystery</span></a><div class="trending__item__image__container"><img alt="Was Cold Case Murder Victim &#x27;Lady of the Dunes,&#x27; an Extra in &#x27;Jaws&#x27;? Movie Could Hold Answers to Mystery" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2022-11/111022_jaws_cold_case_murder_web.jpg?h=d1cb525d?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">6</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Was Cold Case Murder Victim &#x27;Lady of the Dunes,&#x27; an Extra in &#x27;Jaws&#x27;? Movie Could Hold Answers to Mystery</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div></div></div></div></div></div></div></div></main><footer class="footer dark"><div class="footer-container dark"><div class="footer-right"><ul class="social"><li><a aria-label="Visit Facebook" href="http://www.facebook.com/Inside.Edition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Twitter" href="http://twitter.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Instagram" href="https://instagram.com/insideedition/" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Youtube" href="https://www.youtube.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit RSS" href="https://www.insideedition.com/rss" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li></ul></div><div class="footer-menu-wrapper dark"><div class="footer__menu"><h4>About Us</h4><nav aria-label="About Us"><ul class="menu"><li class="menu__item"><a href="/meet-the-team" class="menu__link menu__link--internal" aria-label="Visit Meet the Team">Meet the Team</a></li><li class="menu__item"><a href="/awards" class="menu__link menu__link--internal" aria-label="Visit Awards">Awards</a></li><li class="menu__item"><a href="/contact" class="menu__link menu__link--internal" aria-label="Visit Contact">Contact</a></li></ul></nav></div><div class="footer__menu"><h4>Connect</h4><nav aria-label="Connect"><ul class="menu"><li class="menu__item"><a href="https://www.facebook.com/Inside.Edition" class="menu__link menu__link--external" aria-label="Visit Facebook" rel="noopener noreferrer" target="_blank">Facebook</a></li><li class="menu__item"><a href="https://twitter.com/insideedition" class="menu__link menu__link--external" aria-label="Visit Twitter" rel="noopener noreferrer" target="_blank">Twitter</a></li><li class="menu__item"><a href="https://instagram.com/insideedition/" class="menu__link menu__link--external" aria-label="Visit Instagram" rel="noopener noreferrer" target="_blank">Instagram</a></li><li class="menu__item"><a href="https://www.youtube.com/insideedition" class="menu__link menu__link--external" aria-label="Visit YouTube" rel="noopener noreferrer" target="_blank">YouTube</a></li><li class="menu__item"><a href="/rss" class="menu__link menu__link--internal" aria-label="Visit RSS">RSS</a></li></ul></nav></div><div class="footer__menu"><h4>Watch Inside Edition</h4><nav aria-label="Watch Inside Edition"><ul class="menu"><li class="menu__item"><a href="/showfinder" class="menu__link menu__link--internal" aria-label="Visit Local Listings">Local Listings</a></li><li class="menu__item"><a href="/form/we-want-your-story-ideas" class="menu__link menu__link--internal" aria-label="Visit Submit a Story">Submit a Story</a></li></ul></nav></div><div class="footer__menu"><h4>Sites We Love</h4><nav aria-label="Sites We Love"><ul class="menu"><li class="menu__item"><a href="https://www.paramountplus.com?ftag=PPM-06-10aib3j" class="menu__link menu__link--external" aria-label="Visit Paramount+" rel="noopener noreferrer" target="_blank">Paramount+</a></li><li class="menu__item"><a href="https://www.cbsnews.com/" class="menu__link menu__link--external" aria-label="Visit CBS News" rel="noopener noreferrer" target="_blank">CBS News</a></li><li class="menu__item"><a href="https://www.etonline.com/" class="menu__link menu__link--external" aria-label="Visit ETonline" rel="noopener noreferrer" target="_blank">ETonline</a></li><li class="menu__item"><a href="https://www.thedrewbarrymoreshow.com/" class="menu__link menu__link--external" aria-label="Visit The Drew Barrymore Show" rel="noopener noreferrer" target="_blank">The Drew Barrymore Show</a></li><li class="menu__item"><a href="https://www.rachaelrayshow.com/" class="menu__link menu__link--external" aria-label="Visit Rachael Ray Show" rel="noopener noreferrer" target="_blank">Rachael Ray Show</a></li><li class="menu__item"><a href="https://www.dabl.com" class="menu__link menu__link--external" aria-label="Visit DABL" rel="noopener noreferrer" target="_blank">DABL</a></li><li class="menu__item"><a href="https://www.drphil.com" class="menu__link menu__link--external" aria-label="Visit Dr. Phil" rel="noopener noreferrer" target="_blank">Dr. Phil</a></li><li class="menu__item"><a href="https://www.startrek.com" class="menu__link menu__link--external" aria-label="Visit Star Trek" rel="noopener noreferrer" target="_blank">Star Trek</a></li><li class="menu__item"><a href="https://www.thedoctorstv.com" class="menu__link menu__link--external" aria-label="Visit The Doctors" rel="noopener noreferrer" target="_blank">The Doctors</a></li><li class="menu__item"><a href="https://www.last.fm/" class="menu__link menu__link--external" aria-label="Visit Last.fm" rel="noopener noreferrer" target="_blank">Last.fm</a></li><li class="menu__item"><a href="https://www.mixible.com/" class="menu__link menu__link--external" aria-label="Visit Mixible" rel="noopener noreferrer" target="_blank">Mixible</a></li></ul></nav></div></div><div class="footer-bottom dark"><a href="/" class="logo-greyscale" aria-label="Inside Edition logo"><div alt="Inside Edition"></div></a><div class="footer-copy"><a target="_blank" rel="noopener noreferrer" aria-label="Visit Terms of Use" href="https://www.viacomcbs.legal/us/en/cbsi/terms-of-use">Terms of Use | </a><a target="_blank" rel="noopener noreferrer" aria-label="Visit Privacy Policy" href="https://www.viacomcbsprivacy.com/policy">Privacy Policy | </a><a target="_blank" rel="noopener noreferrer" aria-label="Visit Cookies Policy" href="https://www.viacomcbsprivacy.com/cookies">Cookies Policy | </a><a target="_blank" rel="noopener noreferrer" aria-label="Visit Closed Captioning" href="https://www.cbs.com/closed-captioning/">Closed Captioning | </a><a class="ot-sdk-show-settings">Do Not Sell My Personal Information</a><div>™ King World Productions Inc. © 2022 Inside Edition Inc. and CBS interactive Inc., Paramount companies. All Rights Reserved.</div></div></div></div></footer></div></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>