<!DOCTYPE html><html lang="en"><head><link rel="apple-touch-icon" sizes="57x57" href="/img/favicons/apple-icon-57x57.png"/><link rel="apple-touch-icon" sizes="60x60" href="/img/favicons/apple-icon-60x60.png"/><link rel="apple-touch-icon" sizes="72x72" href="/img/favicons/apple-icon-72x72.png"/><link rel="apple-touch-icon" sizes="76x76" href="/img/favicons/apple-icon-76x76.png"/><link rel="apple-touch-icon" sizes="114x114" href="/img/favicons/apple-icon-114x114.png"/><link rel="apple-touch-icon" sizes="120x120" href="/img/favicons/apple-icon-120x120.png"/><link rel="apple-touch-icon" sizes="144x144" href="/img/favicons/apple-icon-144x144.png"/><link rel="apple-touch-icon" sizes="152x152" href="/img/favicons/apple-icon-152x152.png"/><link rel="apple-touch-icon" sizes="180x180" href="/img/favicons/apple-icon-180x180.png"/><link rel="icon" type="image/png" sizes="192x192" href="/img/favicons/android-icon-192x192.png"/><link rel="icon" type="image/png" sizes="32x32" href="/img/favicons/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="96x96" href="/img/favicons/favicon-96x96.png"/><link rel="icon" type="image/png" sizes="16x16" href="/img/favicons/favicon-16x16.png"/><link rel="manifest" crossorigin="use-credentials" href="/manifest.json"/><meta name="msapplication-TileImage" content="/img/favicons/ms-icon-144x144.png"/><link rel="preconnect" href="https://vidtech.cbsinteractive.com"/><link rel="preconnect" href="https://cdn.cookielaw.org"/><link rel="preconnect" href="https://www.insideedition.com"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowDisplay-Bd/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Bold/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff" as="font" type="font/woff" crossorigin="true"/><link rel="preload" href="/fonts/HelveticaNowText-Regular/font.woff2" as="font" type="font/woff2" crossorigin="true"/><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/><meta http-equiv="content-language" content="en_US"/><meta property="fb:app_id" content="966341826790079"/><meta property="fb:admins" content="3111204"/><meta property="fb:pages" content="71728150722"/><meta property="og:site_name" content="Inside Edition"/><meta name="twitter:site" content="@insideedition"/><meta name="twitter:site:id" content="23603092"/><meta name="theme-color" content="#fd005b"/><meta name="msapplication-TileColor" content="#fd005b"/><script>var utag_data = window.utag_data || {}; window.utag_data.isSPA = true;</script><script src="https://tags.tiqcdn.com/utag/cbsi/insideeditionsite/prod/utag.js" async=""></script><script>
                !function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var
                  d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();
              </script><script>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];cbsoptanon.onAdsReady(function(cmp, options) {console.log('Ads loaded, npa flag: ', options['npaFlag']);});
              </script><script src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js" async=""></script><script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charSet="UTF-8" data-domain-script="1e90d9ec-e15e-4932-a026-f218893ce26c" async=""></script><script async="" src="https://www.googletagmanager.com/gtag/js?id=AW-604815933"></script><script>
                window.dataLayer = window.dataLayer || [];
                function gtag(){dataLayer.push(arguments);}
                gtag('js', new Date());
                gtag('config', 'AW-604815933');
              </script><script>
                !function(f,b,e,v,n,t,s){
                  if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};
                  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];
                  t=b.createElement(e);
                  t.async=!0;
                  t.src=v;
                  t.setAttribute("class", "optanon-category-3");
                  t.setAttribute("data-src", v);
                  t.setAttribute("type", "text/plain");
                  s=b.getElementsByTagName(e)[0];
                  s.parentNode.insertBefore(t,s)}
                  (window,document,'script','https://connect.facebook.net/en_US/fbevents.js'); 
                  fbq('init', '1223619061322807'); fbq('track', 'PageView');
              </script><noscript><img alt="" height="1" width="1" src="https://www.facebook.com/tr?id=1223619061322807&amp;ev=PageView&amp;noscript=1"/></noscript><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><title>24 Packages of Cocaine Worth $1.2 Million Washes Ashore at Cape Canaveral Discovered by Wildlife Manager | Inside Edition</title><meta name="title" content="24 Packages of Cocaine Worth $1.2 Million Washes Ashore at Cape Canaveral Discovered by Wildlife Manager"/><link rel="canonical" href="https://www.insideedition.com/24-packages-of-cocaine-worth-12-million-washes-ashore-at-cape-canaveral-discovered-by-wildlife"/><link rel="image_src" href="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-06/cocainenew-site-size1280x720_4.jpg?h=733c762c&amp;width=1280&amp;height=720"/><meta name="robots" content="index"/><meta name="description" content="The drugs were transported to a secure location and turned over to Homeland Security Investigations."/><meta property="og:description" content="The drugs were transported to a secure location and turned over to Homeland Security Investigations."/><meta property="og:title" content="$1.2M Worth of Cocaine Found on Florida Beach"/><meta property="og:type" content="Article"/><meta property="og:url" content="https://www.insideedition.com/24-packages-of-cocaine-worth-12-million-washes-ashore-at-cape-canaveral-discovered-by-wildlife"/><meta property="og:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-06/cocainenew-site-size1280x720_4.jpg?h=733c762c&amp;width=1280&amp;height=720"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="The drugs were transported to a secure location and turned over to Homeland Security Investigations."/><meta name="twitter:title" content="$1.2M Worth of Cocaine Found on Florida Beach"/><meta name="twitter:url" content="https://www.insideedition.com/24-packages-of-cocaine-worth-12-million-washes-ashore-at-cape-canaveral-discovered-by-wildlife"/><meta name="twitter:creator" content="@insideedition"/><meta name="twitter:image" content="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-06/cocainenew-site-size1280x720_4.jpg?h=733c762c&amp;width=1280&amp;height=720"/><meta name="twitter:image:width" content="1280"/><meta name="twitter:image:height" content="720"/><meta property="article:published_time" content="2021-06-16T10:36:30-0700"/><meta name="keywords" content="Inside Edition, News, News, florida"/><link rel="amphtml" href="https://www.insideedition.com/24-packages-of-cocaine-worth-12-million-washes-ashore-at-cape-canaveral-discovered-by-wildlife?amp"/><script type="application/ld+json">{"@context":"http://schema.org","articleSection":"News","dateModified":"2021-06-16T10:36:30-0700","headline":"24 Packages of Cocaine Worth $1.2 Million Washes Ashore at Cape Canaveral Discovered by Wildlife Manager","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.insideedition.com24-packages-of-cocaine-worth-12-million-washes-ashore-at-cape-canaveral-discovered-by-wildlife"},"datePublished":"2021-06-16T10:36:30-0700","publisher":{"name":"Inside Edition","@type":"Organization","logo":{"@type":"ImageObject","url":"https://www.insideedition.com/img/logo.png"}},"url":"https://www.insideedition.com24-packages-of-cocaine-worth-12-million-washes-ashore-at-cape-canaveral-discovered-by-wildlife","description":"The drugs were transported to a secure location and turned over to Homeland Security Investigations.","keywords":["Inside Edition, News, News, florida"],"image":{"@type":"ImageObject","url":"https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-06/cocainenew-site-size1280x720_4.jpg?h=733c762c","height":1080,"width":1920},"author":{"@type":"Person","name":"Ruth Bashinsky"}}</script><meta name="next-head-count" content="27"/><link rel="preload" href="/_next/static/css/84994d70e4810965bb33.css" as="style"/><link rel="stylesheet" href="/_next/static/css/84994d70e4810965bb33.css" data-n-g=""/><noscript data-n-css=""></noscript><link rel="preload" href="/_next/static/chunks/framework.efe182f2d62be1d8151a.js" as="script"/><link rel="preload" href="/_next/static/chunks/05d954cf.1f2f8b8d79b258a8f08a.js" as="script"/><link rel="preload" href="/_next/static/chunks/c8f7fe3b0e41be846d5687592cf2018ff6e22687.add8624da729cb9af9f6.js" as="script"/><link rel="preload" href="/_next/static/chunks/9cb9333cb5d5b60100bab7bad47eadb4c03e8c5a.c23e10893c1e045cd366.js" as="script"/><link rel="preload" href="/_next/static/chunks/29.e818500f8947fdd4bc78.js" as="script"/><link rel="preload" href="/_next/static/chunks/45.89d00a6ff8487278b971.js" as="script"/><link rel="preload" href="/_next/static/chunks/12.5e11cc6f02b7972cd49a.js" as="script"/><link rel="preload" href="/_next/static/chunks/10.679a8b0b868cc36892ba.js" as="script"/><link rel="preload" href="/_next/static/chunks/webpack-13779fdf7b4e4ca63f61.js" as="script"/><link rel="preload" href="/_next/static/chunks/framework.efe182f2d62be1d8151a.js" as="script"/><link rel="preload" href="/_next/static/chunks/1e5054a7a75d97efbd16bfd1a83cd1510d699017.7ae81140e7958cef1396.js" as="script"/><link rel="preload" href="/_next/static/chunks/e10cc333ce965bed2194ce496e777defbe226e7a.3410ac71d45449857e8d.js" as="script"/><link rel="preload" href="/_next/static/chunks/main-793a71c2d1e12a4a5145.js" as="script"/><link rel="preload" href="/_next/static/chunks/da69db543d0ad66700d26dd7d8137c089277d8ed.c914d7fd0397bfd7fb96.js" as="script"/><link rel="preload" href="/_next/static/chunks/9.d7c378bd3e32504cd7af.js" as="script"/><link rel="preload" href="/_next/static/chunks/pages/_app-b79bcd5bc2ba5c1113fb.js" as="script"/><link rel="preload" href="/_next/static/chunks/9cb9333cb5d5b60100bab7bad47eadb4c03e8c5a.c23e10893c1e045cd366.js" as="script"/><link rel="preload" href="/_next/static/chunks/842ab27a9c34edeca9b9f5deeb9b639d1fd44b95.1cf9d2bada0d24212aaf.js" as="script"/><link rel="preload" href="/_next/static/chunks/21f07fc9585b81c3d90771c8f31348b270a6dadd.6e5874950be33aca3f1e.js" as="script"/><link rel="preload" href="/_next/static/chunks/pages/%5B...alias%5D-e42031adb3c12e7dfef2.js" as="script"/></head><body class="skybox-auto-collapse"><div id="__next"><div id="preload"><div><div class="dark"><div class="main-menu__sticky" style="top:0"><div class="header__wrapper"><div id="sticky-banner" class=""><div data-ad-ref="omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div><div data-ad-ref="mobile-omni-skybox-plus-sticky" class="bidbarrel-ad skybox-closeBtn skybox-collapseBtn skybox-videoStop"></div></div><div data-ad-ref="intromercial"></div><header class="header affix-top dark" style="top:0px" id="header"><div class="header__container"><div class="header__column-1"><div class="header__logo_toggle_wrapper"><button type="button" class="header__menu-toggle header__menu-toggle--collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false"><span class="sr-only">Toggle navigation</span></button><a class="header__logo" href="/" tabindex="-1"><img height="46" width="68" class="header__logo__image" alt="Inside Edition Logo" src="/img/logo.svg"/></a></div><div class="header__nav" style="display:none;transform:translateY(-100%) translateZ(0)"><ul class="main-menu"><li class="main-menu__item main-menu__item--submenu-closed"><a href="/news" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-label="News" aria-expanded="false" tabindex="-1">News</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/news" aria-label="Latest News">Latest News</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/crime" aria-label="Crime">Crime</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/politics" aria-label="Politics">Politics</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/health" aria-label="Health">Health</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/entertainment" aria-label="Entertainment">Entertainment</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/royals" aria-label="Royals">Royals</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/human-interest" aria-label="Human Interest">Human Interest</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/inspirational" aria-label="Inspirational">Inspirational</a></li></ul></li><li class="main-menu__item"><a href="/videos" class="main-menu__link" aria-label="Video">Video</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/investigative" class="main-menu__link" aria-label="Investigative">Investigative</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/category/the-issue" class="main-menu__link" aria-label="The Issue">The Issue</a></li><li class="main-menu__item main-menu__item--hide-tablet"><a href="/offbeat" class="main-menu__link" aria-label="Offbeat">Offbeat</a></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/more" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-label="More" aria-expanded="false" tabindex="-1">More</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/animals" aria-label="Animal Edition">Animal Edition</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/photos" aria-label="Photos">Photos</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/heroes" aria-label="Heroes">Heroes</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/in-depth" aria-label="Inside Edition InDepth">Inside Edition InDepth</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/sports" aria-label="Sports">Sports</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/flashback" aria-label="Flashback">Flashback</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/shopping" aria-label="Shopping">Shopping</a></li></ul></li><li class="main-menu__item main-menu__item--submenu-closed"><a href="/showfinder" class="main-menu__link dropdown-toggle" data-toggle="dropdown" aria-label="Watch on TV" aria-expanded="false" tabindex="-1">Watch on TV</a><ul class="main-menu__submenu"><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/showfinder" aria-label="Local Listings">Local Listings</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/meet-the-team" aria-label="Meet the Team">Meet the Team</a></li><li class="main-menu__item main-menu__submenu__item"><a class="main-menu__link main-menu__submenu__link" href="/tag/today-inside-edition" aria-label="Today on Inside Edition">Today on Inside Edition</a></li></ul></li></ul></div></div><div class="header__column-2"><div class="header__search header__search--closed"><form class="header__search-form" action="/search" method="get" accept-charset="UTF-8"><div class="form-group"><label for="edit-keywords"><span class="sr-only">Search</span></label><input type="search" id="edit-keywords" class="header__search-form__input-keywords" value="" title="Enter the terms you wish to search for." placeholder="Search" name="keywords" size="15" maxLength="128" tabindex="-1"/></div><input type="hidden" autoComplete="off" data-drupal-selector="form-avqtn-pftnijnbl-p524povbyyt-kfxlc45o-n08s3a" name="form_build_id" value="form-AVqTn_pftNijNBl_p524pOvbyYt_kFxlC45O-N08s3A"/><input type="hidden" data-drupal-selector="edit-search-block-form" name="form_id" value="search_block_form"/><div data-drupal-selector="edit-actions" class="header__search-form__actions" id="edit-actions"><button type="submit" class="header__search-form__actions__submit" name="op" value="" aria-hidden="true" tabindex="-1"></button></div></form></div><button type="button" class="header__search__close-button" aria-label="Close Search"></button><div class="header__social"><ul class="header__social-menu"><li class="header__social-menu__item"><a href="http://www.facebook.com/Inside.Edition" class="header__social-menu__link header__social-menu__link--facebook" tabindex="-1"><span class="sr-only">Facebook Inside Edition</span></a></li><li class="header__social-menu__item"><a href="http://twitter.com/insideedition" class="header__social-menu__link header__social-menu__link--twitter" tabindex="-1"><span class="sr-only">Twitter Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://instagram.com/insideedition/" class="header__social-menu__link header__social-menu__link--instagram" tabindex="-1"><span class="sr-only">Instagram Inside Edition</span></a></li><li class="header__social-menu__item"><a href="https://www.youtube.com/insideedition" class="header__social-menu__link header__social-menu__link--youtube" tabindex="-1"><span class="sr-only">YouTube Inside Edition</span></a></li></ul></div></div></div></header></div></div><div class="wrap-site"><main><div class="wrap-site"><div class="content"><div class="top-container"><h1 class="content__title">24 Packages of Cocaine Worth $1.2 Million Washes Ashore at Cape Canaveral Discovered by Wildlife Manager</h1><div class="cat-social-container"><div class="content__category"><a href="https://www.insideedition.com/news">News</a></div><div class="content__share"><div class="share"><button type="button" class="share__social-btn" aria-label="Share to Facebook"><div></div></button><button type="button" class="share__social-btn" aria-label="Share to Twitter"><div></div></button></div></div></div></div><div class="content__header-img centered"><div class="content__header-img-wrapper"><div class="content__header-img-wrap"><picture><source media="(max-width: 375px)" srcSet="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-06/cocainenew-site-size1280x720_4.jpg?h=733c762c&amp;width=375&amp;height=211"/><img src="https://www.insideedition.com/sites/default/files/styles/video_1920x1080/public/images/2021-06/cocainenew-site-size1280x720_4.jpg?h=733c762c&amp;width=1170&amp;height=658" alt="Defenders from the 45th Security Forces Squadron seize nearly 30 kilograms of cocaine." class="img-full "/></picture></div><div class="content__header-img-caption-wrap"><span class="content__header-image-credit">Space Launch Delta 45</span></div></div></div><div class="site-bg"><div class="constrain constrain--bg"><div class="content__body"><div class="content__topborder"></div><div class="content__byline"><div class="content__byline-author">By <a href="https://www.insideedition.com/bios/ruth-bashinsky" aria-label="Biography of Ruth Bashinsky"> <!-- -->Ruth Bashinsky<!-- --> </a></div><div class="content__byline-date"><div>First Published: <!-- -->10:36 AM PDT, June 16, 2021</div></div></div><h2 class="content__subheading">The drugs were transported to a secure location and turned over to Homeland Security Investigations.</h2><div class="content__body-main"><div class="ctd-body"><div data-ad-ref="mobile-incontent-social" class="mobile-incontent-social bidbarrel-ad"></div><p>A wildlife manager searching for sea turtles at Florida&rsquo;s Cape Canaveral Space Station stumbled upon something completely unexpected: $1.2 million worth of cocaine, authorities said.</p><p>Angy Chambers, 45th Civilian Engineer Squadron wildlife manager, was patrolling the beach and performing a turtle nesting survey May 19 when she noticed a small &ldquo;package wrapped tightly in plastic and tape&rdquo; and said she &ldquo;thought it could be drugs," Space Launch Delta 45 said in a <a href="https://www.patrick.spaceforce.mil/News/Article-Display/Article/2651782/defenders-seize-12-million-in-cocaine-at-ccsfs/">news release</a>.</p><div data-ad-ref="mobile-flex-plus-middle" class="bidbarrel-ad"></div><p>Chambers said she immediately contacted the 45th Security Forces Squadron (SFS) with Space Force. As she waited for them to arrive she said she &ldquo;drove a little further and found another package and then another.&rdquo;&nbsp; &ldquo;At that point, I called the SFS back and suggested they bring their Utility Terrain Vehicle (UTV), as I counted at least 18 packages,&rdquo; the release said.</p><p>Once officials arrived they secured the scene and collected the contraband,&nbsp;45th SFS Flight Sargeant Joseph Parker said. Defenders from the 45th Security Forces Squadron seized nearly 30 kilograms of cocaine.The Brevard County Sheriff&rsquo;s Office narcotics agent performed a field test on one of the packages and confirmed that it was cocaine, Parker said, <a href="https://www.cbsnews.com/news/sea-turtle-nesting-survey-one-million-dollars-cocaine-cape-canaveral-space-force-station/">CBS News reported.</a>&nbsp;</p><div data-ad-ref="mpu-flex-middle" class="bidbarrel-ad"></div><p>Parker said all 24 packages were documented&nbsp;and placed them in evidence bags then were transported to a secure location and turned over to Homeland Security Investigations, the investigative arm of the U.S. Department of Homeland Security,</p><p>Special Agent David Castro said it had not been determined where the drugs came from but said &ldquo;oftentimes maritime drug traffickers will transport bulk shipments of controlled substances in bales consisting of 25 &lsquo;bricks&rsquo; or &lsquo;kilograms of drugs,&rdquo; CBS reported.</p><div data-ad-ref="mpu-flex-inc" data-incremental="1" class="bidbarrel-ad"></div><div data-ad-ref="mobile-flex-plus-inc" data-incremental="1" class="bidbarrel-ad"></div><p>&ldquo;Sometimes the bale wrapping is destroyed during transit cause bricks to be lost at sea and eventually recovered on the coastline of the United States,&rdquo; Castro said.</p><p>Officials said intelligence at the scene was collected, unique marking on the packages, photographs, the weight of drugs, was also shared with the <a href="https://www.ojp.gov/ncjrs/virtual-library/abstracts/el-paso-intelligence-center-national-resource-local-agencies">El Paso Intelligence Center (EPIC) </a>that serves as a repository for abandoned drugs discovered in the United States, the release said.&nbsp;</p><p>Parker thanked Chambers for her vigilance, and for the team effort that will prevent the drugs&nbsp;from reaching the&nbsp;streets.</p><p>"We take pride in protecting our base and the surrounding community," said Parker. "There is also a higher level of job satisfaction knowing that these drugs will not make it into our community.&rdquo;</p><p>The origin of the cocaine is under investigation, officials said.</p><h2>Related Stories&nbsp;</h2><div class="shortcode-speedbump"><a href="https://www.insideedition.com/woman-arrested-in-atlanta-airport-for-smuggling-cocaine-in-7-shoes-66706" target="_self" rel="noopener noreferrer">Woman Arrested in Atlanta Airport for Smuggling Cocaine in 7 Shoes</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/15-million-of-cocaine-found-on-south-florida-beach-and-its-not-the-first-time-it-has-happened-this" target="_self" rel="noopener noreferrer">$1.5 Million of Cocaine Found on South Florida Beach and It&#x27;s Not the First Time It Has Happened This Year</a></div><div class="shortcode-speedbump"><a href="https://www.insideedition.com/plane-carrying-80m-of-cocaine-crashes-under-weight-of-drugs-61028" target="_self" rel="noopener noreferrer">Plane Carrying $80M of Cocaine Crashes Under Weight of Drugs</a></div><div class="shortcode-video"><div class="related-links"><a class="title" href="/videos/11540-26-tons-of-cocaine-seized-offshore-in-historic-us-drug-smuggling-bust">26 Tons Of Cocaine Seized Offshore In Historic U.S. Drug Smuggling Bust</a><a href="/news" class="category">News</a></div></div></div></div><div class="content__spacer"></div><div class="content__tags"><h3>Tags:</h3><ul><li class=""><a href="https://www.insideedition.com/tag/florida " aria-label="Visit florida">florida</a></li></ul></div><div class="content__spacer"></div><div class="right-rail"><div style="top:0"><div class="right-rail__content "><div data-ad-ref="mpu-plus-top" class="bidbarrel-ad"></div></div></div></div></div><div id="taboola-below-article-thumbnails"></div><div class="content__trending"><div class="trending"><h2 class="trending__block-title">Trending on Inside Edition</h2><div class="trending__items"><div class="trending__item"><a href="https://www.insideedition.com/woman-from-ukraine-sets-guinness-world-record-for-biggest-collection-of-ladybug-themed-items-67534" class="trending__item__link"><span class="sr-only">Woman From Ukraine Sets Guinness World Record for Biggest Collection of ‘Ladybug-Themed Items’</span></a><div class="trending__item__image__container"><img alt="Woman From Ukraine Sets Guinness World Record for Biggest Collection of ‘Ladybug-Themed Items’" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-06/060921_ladybugs_web_0.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">1</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Woman From Ukraine Sets Guinness World Record for Biggest Collection of ‘Ladybug-Themed Items’</p><a href="https://www.insideedition.com/offbeat" class="trending__item__text--kicker">Offbeat</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/paul-murdaugh-mother-found-shot-to-death-near-south-carolina-home-67527" class="trending__item__link"><span class="sr-only">Paul Murdaugh, Mother Found Shot to Death Near South Carolina Home</span></a><div class="trending__item__image__container"><img alt="Paul Murdaugh, Mother Found Shot to Death Near South Carolina Home" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-06/murdaugh.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">2</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Paul Murdaugh, Mother Found Shot to Death Near South Carolina Home</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/woman-in-wisconsin-charged-with-killing-friend-with-eye-drops-and-stealing-290000-from-her-cops-say" class="trending__item__link"><span class="sr-only">Woman in Wisconsin Charged With Killing Friend With Eye Drops and Stealing $290,000 From Her, Cops Say</span></a><div class="trending__item__image__container"><img alt="Woman in Wisconsin Charged With Killing Friend With Eye Drops and Stealing $290,000 From Her, Cops Say" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-06/061021_killer_eye_drops_web.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">3</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Woman in Wisconsin Charged With Killing Friend With Eye Drops and Stealing $290,000 From Her, Cops Say</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/taylor-pomaskis-mother-and-friend-appeal-to-boyfriend-for-answers-as-search-for-missing-texas-woman" class="trending__item__link"><span class="sr-only">Taylor Pomaski&#x27;s Mother and Friend Appeal to Boyfriend for Answers as Search for Missing Texas Woman Continues</span></a><div class="trending__item__image__container"><img alt="Taylor Pomaski&#x27;s Mother and Friend Appeal to Boyfriend for Answers as Search for Missing Texas Woman Continues" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-06/taylorsplit-screen1280x7202cpsd_3-recovered-recovered.jpg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">4</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">Taylor Pomaski&#x27;s Mother and Friend Appeal to Boyfriend for Answers as Search for Missing Texas Woman Continues</p><a href="https://www.insideedition.com/crime" class="trending__item__text--kicker">Crime</a></div></div><div class="trending__item"><a href="https://www.insideedition.com/how-did-russias-alexei-navalny-become-president-vladimir-putins-biggest-enemy-67553" class="trending__item__link"><span class="sr-only">How Did Russia&#x27;s Alexei Navalny Become President Vladimir Putin&#x27;s Biggest Enemy?</span></a><div class="trending__item__image__container"><img alt="How Did Russia&#x27;s Alexei Navalny Become President Vladimir Putin&#x27;s Biggest Enemy?" class="trending__item__image__container--image" loading="lazy" src="https://www.insideedition.com/sites/default/files/images/2021-06/060921-navalny-1280x720.jpeg?crop=16:9&amp;width=314&amp;height=196"/><div class="trending__item__rank"><span class="trending__item__rank--number">5</span></div></div><div class="trending__item__text"><p class="trending__item__text--title">How Did Russia&#x27;s Alexei Navalny Become President Vladimir Putin&#x27;s Biggest Enemy?</p><a href="https://www.insideedition.com/news" class="trending__item__text--kicker">News</a></div></div></div></div></div></div></div></div></div></main><footer class="footer dark"><div class="footer-container dark"><div class="footer-right"><ul class="social"><li><a aria-label="Visit Facebook" href="http://www.facebook.com/Inside.Edition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Twitter" href="http://twitter.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Instagram" href="https://instagram.com/insideedition/" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit Youtube" href="https://www.youtube.com/insideedition" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li><li><a aria-label="Visit RSS" href="https://www.insideedition.com/rss" target="_blank" rel="noopener noreferrer"><div></div><span class="visuallyhidden">Opens a new window</span></a></li></ul></div><div class="footer-menu-wrapper dark"><div class="footer-menu dark"><h4>About Us</h4><ul><li><a href="/meet-the-team" aria-label="Visit Meet the Team">Meet the Team</a></li><li><a href="/awards" aria-label="Visit Awards">Awards</a></li><li><a href="/contact" aria-label="Visit Contact">Contact</a></li></ul></div><div class="footer-menu dark"><h4>Connect</h4><ul><li><a href="https://www.facebook.com/Inside.Edition" aria-label="Visit Facebook" rel="noopener noreferrer" target="_blank">Facebook</a></li><li><a href="https://twitter.com/insideedition" aria-label="Visit Twitter" rel="noopener noreferrer" target="_blank">Twitter</a></li><li><a href="https://instagram.com/insideedition/" aria-label="Visit Instagram" rel="noopener noreferrer" target="_blank">Instagram</a></li><li><a href="https://www.youtube.com/insideedition" aria-label="Visit YouTube" rel="noopener noreferrer" target="_blank">YouTube</a></li><li><a href="/rss" aria-label="Visit RSS">RSS</a></li><li><a href="https://cbsinteractive.com/advertising/" aria-label="Visit Advertise with Us" rel="noopener noreferrer" target="_blank">Advertise with Us</a></li></ul></div><div class="footer-menu dark"><h4>Watch Inside Edition</h4><ul><li><a href="/showfinder" aria-label="Visit Local Listings">Local Listings</a></li><li><a href="/form/we-want-your-story-ideas" aria-label="Visit Submit a Story">Submit a Story</a></li></ul></div><div class="footer-menu dark"><h4>Sites We Love</h4><ul><li><a href="https://www.paramountplus.com" aria-label="Visit Paramount+" rel="noopener noreferrer" target="_blank">Paramount+</a></li><li><a href="https://www.cbsnews.com/" aria-label="Visit CBS News" rel="noopener noreferrer" target="_blank">CBS News</a></li><li><a href="https://www.etonline.com/" aria-label="Visit ETonline" rel="noopener noreferrer" target="_blank">ETonline</a></li><li><a href="https://www.thedrewbarrymoreshow.com/" aria-label="Visit The Drew Barrymore Show" rel="noopener noreferrer" target="_blank">The Drew Barrymore Show</a></li><li><a href="https://www.rachaelrayshow.com/" aria-label="Visit Rachael Ray Show" rel="noopener noreferrer" target="_blank">Rachael Ray Show</a></li><li><a href="https://www.dabl.com" aria-label="Visit DABL" rel="noopener noreferrer" target="_blank">DABL</a></li><li><a href="https://www.drphil.com" aria-label="Visit Dr. Phil" rel="noopener noreferrer" target="_blank">Dr. Phil</a></li><li><a href="https://www.startrek.com" aria-label="Visit Star Trek" rel="noopener noreferrer" target="_blank">Star Trek</a></li><li><a href="https://www.thedoctorstv.com" aria-label="Visit The Doctors" rel="noopener noreferrer" target="_blank">The Doctors</a></li><li><a href="https://www.last.fm/" aria-label="Visit Last.fm" rel="noopener noreferrer" target="_blank">Last.fm</a></li></ul></div></div><div class="footer-bottom dark"><a href="/" class="logo-greyscale"><div alt="Inside Edition"></div></a><div class="footer-copy"><a href="https://legalterms.cbsinteractive.com/terms-of-use" target="_blank" rel="noopener noreferrer">Terms of Use</a> |<a href="https://legalterms.cbsinteractive.com/privacy" target="_blank" rel="noopener noreferrer"> Privacy Policy</a> |<a href="https://legalterms.cbsinteractive.com/eula" target="_blank" rel="noopener noreferrer"> Mobile User Agreement</a> |<a href="http://www.cbs.com/closed-captioning/" target="_blank" rel="noopener noreferrer"> Closed Captioning</a> |<a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/video-services-and-social-networking" target="_blank" rel="noopener noreferrer"> Video Services Policy</a> |<a href="https://www.cbsinteractive.com/legal/cbsi/privacy-policy/third-party-online-advertising" target="_blank" rel="noopener noreferrer"> Ad Choices</a> |<a href="https://ca.privacy.cbs" target="_blank" rel="noopener noreferrer"> California Privacy/Info We Collect</a> |<a href="https://ca.privacy.cbs/donotsell" target="_blank" rel="noopener noreferrer"> California Do Not Sell My Info</a> | In Partnership with <a href="http://www.etonline.com" target="_blank" rel="noopener noreferrer"> ETonline</a>.<span>CBS interactive &#169; 2021 Inside Edition Inc. All Rights Reserved.</span></div></div></div></footer></div></div></div></div></div><script id="__NEXT_DATA__" type="application/json">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</script><script nomodule="" src="/_next/static/chunks/polyfills-538e6a00a500ba24355f.js"></script><script async="" src="/_next/static/chunks/05d954cf.1f2f8b8d79b258a8f08a.js"></script><script async="" src="/_next/static/chunks/c8f7fe3b0e41be846d5687592cf2018ff6e22687.add8624da729cb9af9f6.js"></script><script async="" src="/_next/static/chunks/29.e818500f8947fdd4bc78.js"></script><script async="" src="/_next/static/chunks/45.89d00a6ff8487278b971.js"></script><script async="" src="/_next/static/chunks/12.5e11cc6f02b7972cd49a.js"></script><script async="" src="/_next/static/chunks/10.679a8b0b868cc36892ba.js"></script><script src="/_next/static/chunks/webpack-13779fdf7b4e4ca63f61.js" async=""></script><script src="/_next/static/chunks/framework.efe182f2d62be1d8151a.js" async=""></script><script src="/_next/static/chunks/1e5054a7a75d97efbd16bfd1a83cd1510d699017.7ae81140e7958cef1396.js" async=""></script><script src="/_next/static/chunks/e10cc333ce965bed2194ce496e777defbe226e7a.3410ac71d45449857e8d.js" async=""></script><script src="/_next/static/chunks/main-793a71c2d1e12a4a5145.js" async=""></script><script src="/_next/static/chunks/da69db543d0ad66700d26dd7d8137c089277d8ed.c914d7fd0397bfd7fb96.js" async=""></script><script src="/_next/static/chunks/9.d7c378bd3e32504cd7af.js" async=""></script><script src="/_next/static/chunks/pages/_app-b79bcd5bc2ba5c1113fb.js" async=""></script><script src="/_next/static/chunks/9cb9333cb5d5b60100bab7bad47eadb4c03e8c5a.c23e10893c1e045cd366.js" async=""></script><script src="/_next/static/chunks/842ab27a9c34edeca9b9f5deeb9b639d1fd44b95.1cf9d2bada0d24212aaf.js" async=""></script><script src="/_next/static/chunks/21f07fc9585b81c3d90771c8f31348b270a6dadd.6e5874950be33aca3f1e.js" async=""></script><script src="/_next/static/chunks/pages/%5B...alias%5D-e42031adb3c12e7dfef2.js" async=""></script><script src="/_next/static/insideedition/_buildManifest.js" async=""></script><script src="/_next/static/insideedition/_ssgManifest.js" async=""></script></body></html>